Microsoft® Office

Excel 2016

Part 2

Includes:

- Data and Tables
- Collaborate with Excel
- Pivot Tables

University of Salford

CustomGuide
Interactive Training
# Table of Contents

INTRODUCING CUSTOMGUIDE TRAINING MANUALS .............................................................................. 4

DATA AND TABLES ................................................................................................................................. 5

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>SORT DATA</td>
<td>6</td>
</tr>
<tr>
<td>Sort by One Column</td>
<td>6</td>
</tr>
<tr>
<td>Sort by Multiple Columns</td>
<td>7</td>
</tr>
<tr>
<td>FILTER DATA</td>
<td>8</td>
</tr>
<tr>
<td>Filter</td>
<td>8</td>
</tr>
<tr>
<td>Clear a Filter</td>
<td>8</td>
</tr>
<tr>
<td>QUICK ANALYSIS</td>
<td>9</td>
</tr>
<tr>
<td>TABLES</td>
<td>10</td>
</tr>
<tr>
<td>Create a Table</td>
<td>10</td>
</tr>
<tr>
<td>Apply a Table Style</td>
<td>11</td>
</tr>
<tr>
<td>Convert to a Range</td>
<td>11</td>
</tr>
<tr>
<td>ADD AND REMOVE TABLE DATA</td>
<td>12</td>
</tr>
<tr>
<td>Add Table Rows and Columns</td>
<td>12</td>
</tr>
<tr>
<td>Remove Table Rows and Columns</td>
<td>13</td>
</tr>
<tr>
<td>REMOVE DUPLICATES</td>
<td>14</td>
</tr>
<tr>
<td>TOTAL ROWS</td>
<td>15</td>
</tr>
<tr>
<td>Add a Total Row</td>
<td>15</td>
</tr>
<tr>
<td>Change Calculations</td>
<td>15</td>
</tr>
<tr>
<td>SLICERS</td>
<td>16</td>
</tr>
<tr>
<td>Insert a Slicer</td>
<td>16</td>
</tr>
<tr>
<td>Filter with a Slicer</td>
<td>17</td>
</tr>
<tr>
<td>Clear and Remove a Slicer</td>
<td>17</td>
</tr>
<tr>
<td>DATA VALIDATION</td>
<td>18</td>
</tr>
<tr>
<td>Create a Validation Rule</td>
<td>18</td>
</tr>
<tr>
<td>Add an Input Message</td>
<td>19</td>
</tr>
<tr>
<td>Add an Error Message</td>
<td>20</td>
</tr>
<tr>
<td>FLASH FILL</td>
<td>21</td>
</tr>
<tr>
<td>IMPORT DATA</td>
<td>22</td>
</tr>
<tr>
<td>EXPORT DATA</td>
<td>24</td>
</tr>
<tr>
<td>DATA AND TABLES QUIZ</td>
<td>25</td>
</tr>
</tbody>
</table>

COLLABORATE WITH EXCEL .................................................................................................................... 28

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>CELL COMMENTS</td>
<td>29</td>
</tr>
<tr>
<td>Add a Comment</td>
<td>29</td>
</tr>
<tr>
<td>View a Comment</td>
<td>29</td>
</tr>
<tr>
<td>Edit a Comment</td>
<td>30</td>
</tr>
<tr>
<td>Delete a Comment</td>
<td>30</td>
</tr>
<tr>
<td>SHARE WORKBOOKS</td>
<td>31</td>
</tr>
<tr>
<td>Share a Workbook</td>
<td>31</td>
</tr>
<tr>
<td>Stop Sharing a Workbook</td>
<td>31</td>
</tr>
<tr>
<td>TRACK CHANGES</td>
<td>32</td>
</tr>
<tr>
<td>Turn on Track Changes</td>
<td>32</td>
</tr>
<tr>
<td>Track Changes</td>
<td>32</td>
</tr>
<tr>
<td>Review Changes</td>
<td>33</td>
</tr>
<tr>
<td>Save a Change History</td>
<td>34</td>
</tr>
</tbody>
</table>

©CustomGuide 2015
PROTECT A WORKSHEET .................................................................................................................. 35
  Make Cells Editable ...................................................................................................................... 35
  Hiding Formulas .......................................................................................................................... 36
  Protect a Worksheet ...................................................................................................................... 36
PASSWORD PROTECTION .............................................................................................................. 37
SAVE AS WEB PAGES .................................................................................................................... 38
COLLABORATE WITH EXCEL QUIZ .......................................................................................... 39

PIVOTTABLES .................................................................................................................................. 41
  CREATE PIVOTTABLES .................................................................................................................. 42
  USE MULTIPLE PIVOTTABLE FIELDS ......................................................................................... 43
    Add an Additional Field Value ................................................................................................. 43
    Expand or Collapse a Heading ................................................................................................. 43
  CHANGE A PIVOTTABLE’S CALCULATION ............................................................................... 44
  FILTER PIVOTTABLES .................................................................................................................. 45
    Add a Filter Field ...................................................................................................................... 45
    Clear and Remove a Filter ........................................................................................................ 46
  GROUP VALUES ............................................................................................................................ 47
    Group PivotTable Values .......................................................................................................... 47
    Ungroup PivotTable Values ...................................................................................................... 47
TIMELINES ..................................................................................................................................... 48
  Insert a Timeline ......................................................................................................................... 48
  Clear or Remove a Timeline ........................................................................................................ 48
PIVOTTABLE LAYOUT .................................................................................................................... 49
REFRESH A PIVOTTABLE ................................................................................................................ 50
  Manually Update a PivotTable ..................................................................................................... 50
  Automatically Update a PivotTable .............................................................................................. 50
FORMAT A PIVOTTABLE ................................................................................................................ 51
  Use Style Options ....................................................................................................................... 51
  Apply a Built-in Style .................................................................................................................. 51
PIVOT CHARTS ............................................................................................................................... 52
  Insert a PivotChart ....................................................................................................................... 52
  Modify a PivotChart ..................................................................................................................... 53
PIVOTTABLES QUIZ ....................................................................................................................... 54
Introducing CustomGuide Training Manuals

A proven leader in the computer training industry, CustomGuide has been the key to successful training for thousands of students and instructors across the globe.

This manual is designed for computer users of all experience levels. Novice users can use it to learn skills such as formatting text, while advanced users can learn more advanced skills, such as how to create their own templates.

All this information is quickly accessible. Lessons are broken down into basic step-by-step instructions that answer “how-to” questions in minutes. Print a complete training manual or a single page of instructions.

Here’s how a CustomGuide manual is organized:

Chapters
Each manual is divided into several chapters. Not sure what’s in a chapter? Look at the table of contents at the beginning of the manual. It lists each lesson and its subtopics, so you can find exactly what you need.”

Lessons
Each chapter contains lessons on related topics. Each lesson explains a new skill or topic and contains an exercise to provide hands-on-experience. These skills can also be practiced using CustomGuide’s Online Training.

Review
A review is included at the end of the manual. Use these quiz questions and answers to assess the user’s learning. Interactive quizzes are also available online for a more real-life skills assessment with CustomGuide’s software simulation.

© 2015 by CustomGuide, Inc. 3387 Brownlow Avenue; St. Louis Park, MN 55426

This material is copyrighted and all rights are reserved by CustomGuide, Inc. No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language or computer language, in any form or by any means, electronic, mechanical, magnetic, optical, chemical, manual, or otherwise, without the prior written permission of CustomGuide, Inc.

We make a sincere effort to ensure the accuracy of the material described herein; however, CustomGuide makes no warranty, expressed or implied, with respect to the quality, correctness, reliability, accuracy, or freedom from error of this document or the products it describes. Data used in examples and sample data files are intended to be fictional. Any resemblance to real persons or companies is entirely coincidental.

The names of software products referred to in this manual are claimed as trademarks of their respective companies. CustomGuide is a registered trademark of CustomGuide, Inc.
Data and Tables

If you organize data into a range of rows and columns, you can then easily sort the data into a desired order, or filter the data to display specific information, such as records from a specific zip code.

Tables make it even easier to work with ranges of Excel data. By turning an Excel range into a table, you can quickly sort and filter the table columns, add total rows, and apply table formatting to an Excel table. Some examples of things you might track in a table include telephone numbers, clients, and employee rosters. Once you create a table in Excel, you can easily find, organize, and analyze its information with Excel’s rich set of table-management features.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways you may follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that you may “build upon them,” meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Sort Data

Once your data has been organized into columns and rows in Excel, it’s possible to sort the rows by the values in a certain column.

Sort by One Column

1. Select a cell in the column you want to sort.
2. Click the Sort & Filter button on the Home tab.
3. Select a sort order.
   - **Sort A to Z:** Sorts the column in ascending order.
   - **Sort Z to A:** Sorts the column in descending order.

Tip: If a column of data is selected with more data next to it, the Sort Warning dialog box appears. Normally, you need to expand the selection. Otherwise, the selected column of data will be sorted independently of the surrounding data.
Sort by Multiple Columns

To sort by more than one column, use a custom sort.

**Tip:** You can also use a custom sort to sort by colors or icons.

1. Select a cell within the range you want to sort.
2. Click the **Sort & Filter** button.
3. Select **Custom Sort**.
4. The Sort dialog box appears.
5. Select the first column you want to sort by.
   **Tip:** To sort by cell or font color, or by icon, click the **Sort On** list arrow and select an option.
6. Select a sort order.
7. To sort by an additional column, click the **Add Level** button.
   **Tip:** Click the **Delete Level** button to remove a sort level from the sort criteria.
8. Select the next column you want to sort by.
9. Select a sort order.
   **Tip:** Repeat these steps as necessary to sort by additional columns.
10. Click **OK**.
Filter Data

When filtering data, Excel displays only the records that meet the criteria specified—all other records are hidden.

Filter

You can filter by values such as text, numbers, or dates.

1. Click a cell in the range you want to filter.
2. Click the Data tab.
3. Click the Filter button.
4. Click the filter arrow for the column you want to filter.
5. Specify how you want to filter:
   - Use Text Filters.
   - Use the Search box.
   - Select the checkboxes for the values you want to filter.
6. Click OK.

Clear a Filter

1. Click the Filter button on the Data tab.

The filter buttons disappear, the filtering is removed, and all of the data in your worksheet is visible again.
Quick Analysis

The Quick Analysis function helps you quickly format your data into a chart, table, summary formula, sparkline, or highlighted figures with just a few simple steps.

1. Select the cell range you want to summarize.
   
   **Tip:** Be careful when selecting your data. The Quick Analysis button will not appear when using the Ctrl key to make multiple selections.

2. Click the Quick Analysis button.

3. Select an analysis category.
   - **Formatting:** Use conditional formatting to highlight data.
   - **Charts:** Chart the selected data.
   - **Totals:** Create common summary formulas.
   - **Tables:** Summarize data in a table or PivotTable.
   - **Sparklines:** Place mini charts in single cell.

4. Select the analysis tool you want to use.
Tables

Tables make it easier to work with ranges of Excel data. After turning an Excel range into a table it’s easy to find, organize, and analyze its information with Excel’s table features.

Create a Table

1. Click a cell in the range you want to convert to a table.

   **Tip:** Before turning a range of data into a table, remove blank rows and columns, and make sure that a single column doesn’t have different types of data within it.

2. Click the Format as Table button on the Ribbon.

3. Select the table style you want to use.

   **Tip:** You can also, click the Insert tab on the Ribbon and click the Table button in the Tables group.

4. Verify the data range and click OK.

The table is created. Filters are added to each column, and the table is automatically formatted. Under Table Tools on the Ribbon, the Design tab appears.

   **Tip:** Make sure to specify whether or not the table has a header row. If it doesn’t, Excel will add a header row above the table data.
Apply a Table Style

Change the appearance of a table at any time by applying a preset table formatting style.

1. Click a cell in the table.
2. Click the Design tab.
3. Click the Quick Styles button from the Table Style group.
4. Select a style.

Convert to a Range

If a table is no longer needed, turn it back into a normal range of data.

1. Click the Design tab.
2. With the table selected, click the Convert to Range button.
   
   **Shortcut:** Select the table, right-click the table and select Table, then Convert to Range from the contextual menu.
3. Click Yes.

The table converts back to a normal range of cells, but the table formatting is still applied.

**Tip:** If you want to remove the table formatting, click the Quick Styles button and select None before converting the table to a range.
Add and Remove Table Data

Once a table is inserted, it’s easy to add or remove data.

Add Table Rows and Columns

1. Select a cell in the table row or column next to where you want to add data.

   **Tip:** New rows are added above the selected row and new columns are added to the left of the selected column.

   **Tip:** The insert options aren’t available if you select a column header.

2. Click the Home tab on the Ribbon.

3. Click the Insert button list arrow.

4. Select an insertion option.

   A row or column is inserted into the table and data can be added to it.

   **Shortcut:** Right-click a row or column next to where you want to add data, point to Insert in the menu, and select Table Rows Above or Table Columns to the Left.

   **Tip:** When a formula is entered in a blank column of a table, the formula automatically fills the rest of the column, without using the AutoFill feature. If rows are added to the column, the formula appears in those rows as well.
Remove Table Rows and Columns

Remove unwanted table rows and columns by deleting them.

1. Select the table row(s) or columns(s) to delete.
2. Click the Home tab on the Ribbon.
3. Click the Delete button list arrow.
4. Select a deletion option.

The selected row(s) or column(s) are deleted.

Tip: Doing this removes the data from the worksheet completely.

Shortcut: Right-click the row or column you want to delete, point to Delete in the menu, and select Table Columns or Table Rows.
Remove Duplicates

If there are duplicate rows of identical data in the table, Excel can find and remove them.

1. Select a cell in the table.
   Tip: You can remove duplicates from cell ranges outside of a table as well, but in that case, select the entire cell range to examine it.

2. Click the Data tab.

3. Click the Remove Duplicates button.

4. Select the columns to check for duplicates.
   Tip: All columns are selected by default, but it’s possible to select/deselect individual columns in the Columns list. Use the Select All and Unselect All buttons to select columns.

5. Click OK.

The dialog box displays the number of duplicates that were removed and how many values are left.

6. Click OK.
Total Rows

Add a Total Row

With the total row feature, Excel will automatically insert a total row at the bottom of a table and total the last column of the table. The total row can also perform other types of calculations.

1. Select a cell in the table.
2. Click the Design tab.
3. Check the Total Row box.

A total row appears at the bottom of the table and the last column is added together.

Tip: If the last column doesn’t contain numbers, Excel displays a count of the number of items in the column.

Change Calculations

Once a total row has been added, adjust which type of calculation will be performed for each table column.

1. In the total row, select the cell at the bottom of the column.
2. Click the cell’s list arrow.
3. Select the calculation you want to perform.
Slicers

Slicers are a feature in Excel that provide an easy way to filter table data. Slicers label the filters applied, with details, so it’s easy to understand the data that is displayed and filtered in the table.

Insert a Slicer

1. Click any cell in the table.
   Tip: Slicers also work well with PivotTables.
2. Click the Design tab.
3. Click the Insert Slicer button.
   Tip: You can also click the Insert tab, then click Slicer.

The Insert Slicers dialog box appears. All the column headings in the table are listed here.

4. Select the columns you want to use as slicers.
   Tip: A separate slicer will be created for each column that’s selected.
5. Click OK.

The slicer(s) appear in the worksheet. Now you can move or resize it as needed.

Example of Slicers.
Filter with a Slicer

After a slicer is created, it appears on the worksheet alongside the table.

**Tip:** The slicers will be created layered on top of one another if there is more than one. Click and drag to relocate them.

1. Select the values you want to include in the filter.
2. Hold down the **Ctrl** key to select multiple filters.

The table is filtered to show only the selected value(s).

**Tip:** Simply click the value again to stop filtering the selected data.

Clear and Remove a Slicer

1. Click the **Clear Filter** button.
   All of the filters are cleared, but the Slicer remains on the worksheet. To completely remove it...
2. Right-click the slicer.
3. Select **Remove “Filter name.”**

**Shortcut:** Click the slicer and press the **Delete key.**
Data Validation

Help users enter accurate and appropriate information into worksheets by using Excel's Data Validation feature. Data validation can restrict the type of information that can be entered into a cell or provide the user with instructions on entering information in a cell.

Create a Validation Rule

To use data validation, first specify the validation criteria to use.

1. Select the cells you want to validate.
2. Click the Data tab.
3. Click the Data Validation button.
4. Select the type of data you want to allow.
   - **Any value**: No validation criteria applied.
   - **Whole number**: Allows a whole number between the minimum and maximum limits set.
   - **Decimal**: Allows a decimal or a percent entered as a decimal between the set limits.
   - **List**: Allows a value from a list of choices. A list arrow appears in the cell, and users can choose from the list.
   - **Date**: Allows a date within set limits.
   - **Time**: Allows a time within set limits.
   - **Text length**: Allows text containing a certain number of characters.
   - **Custom**: Allows a formula to be entered to calculate what is allowed in the cell.
Specify the data validation rules.

**Tip:** The validation options will vary depending on the option selected in the Allow field.

**6**

Click **OK**.

The data validation is set for the selected cell(s). When a user tries to enter data that is not valid, Excel will prevent the entry and display a message about the cell being restricted.

**Tip:** To find validated data in a worksheet, click the **Find & Select** button in the Editing group on the Home tab and select **Data Validation**. The validated cells are highlighted.

---

### Add an Input Message

Avoid data validation issues by setting up Excel to display a message whenever a cell or range of cells is selected. These messages are useful when other people will be entering data in your worksheet.

1. Click the **Data** tab.
2. Click the **Data Validation** button.
3. Click the **Input Message** tab.

**Tip:** Make sure the “Show input message when cell is selected” box is selected—it should be selected by default.

4. Enter a title and an input message.
5. Click **OK**.

Now when a cell is selected, the title and message display.
Add an Error Message

An error message appears when data is entered that does not match a data validation rule.

1. Click the Data tab.
2. Click Data Validation.
3. Click the Error Alert tab.
4. Select an error alert style.
   - **Stop**: Prevents users from adding invalid data in a cell.
   - **Warning**: Warns that the data entered is invalid, but users can click Yes to accept the invalid entry, No to edit it, or Cancel to remove it.
   - **Information**: Informs users that the data entered is invalid, but users can click OK to accept the invalid entry or Cancel to remove it.
5. Enter a title and error alert message.
6. Click OK.
Flash Fill

Flash Fill is a feature in Excel that automatically enters values in a column when a pattern is recognized. It can save a lot of time when manually entering a long list of data, like consecutive values or dates.

1. Select the first cell in the column you want to work with.
2. Type the first value in the column and press Enter.
3. Begin typing the second value.

When you start typing in the second value, Excel recognizes the pattern and predicts the values for the rest of the column.

4. Press Enter to accept the suggested Flash Fill values.

Excel populates the rest of the column following the same pattern of data.
Import Data

Excel can import data from external data sources including other files, databases, or web pages.

1. Click the **Data** tab on the ribbon.
2. Click **Get External Data**.

   **Tip:** Some data sources may require special security access, and the connection process can often be very complex. Enlist the help of your organization’s technical support staff for assistance.

3. Select the type of file to import.
4. Navigate to and select the file you want to import.
5. Click **Import**.

   **Tip:** If, while importing external data, a security notice appears saying that it is connecting to an external source that may not be safe, click **OK**.

6. Choose a data type for the file.
   - **Delimited:** Characters such as commas or tabs separate each field.
   - **Fixed width:** Fields are aligned in columns with spaces between each field.

   **Tip:** If the data being imported has headers, be sure to check the **My data has headers** box.

7. Click **Next**.
Select the delimiter type.

A delimiter is something that denotes where the cell separation should occur.

**Tip:** The preview at the bottom updates to show how the imported data will look.

Click **Next**.

For each column, specify the type of data it contains, or just leave it set to general.

Click **Finish**.

Specify where to place the data and click **OK**.
Export Data

When you have data that needs to be transferred to another system, export it from Excel in a format that can be interpreted by other programs, such as a text or CSV file.

1. Click the **File** tab.
2. At the left, click **Export**.
3. Click **Change File Type**.
4. Select a file type.
   - **Text (Tab delimited)**: The cell data will be separated by a tab.
   - **CSV (Comma delimited)**: The cell data will be separated by a comma.
   - **Formatted Text (space delimited)**: The cell data will be separated by a space.

**Tip:** The file type you select will depend on what type of file is required by the program in which you are using the exported data.

5. Click **Save As**.
6. Type a name for the new file.
7. Click **Save**.
8. A dialog box appears stating that some of the workbook features may be lost.
   - Click **Yes**.
Data and Tables Quiz

1. Before sorting data, make sure it's organized into...
   A. a chart.
   B. alphabetical order.
   C. a pivot table.
   D. columns and rows.

2. Sort Excel data by any of the following, except by...
   A. font color.
   B. cell icon.
   C. number formatting.
   D. cell color.

3. To sort by multiple columns, use the __________.
   A. Sort dialog box
   B. Column Specifier button
   C. Sort Columns window
   D. drag and drop feature

4. Which one of the following is a way to turn on the filtering buttons?
   A. Click the Insert tab and click the Filter button in the Filter group.
   B. Click the Filter tab and click the Filter button in the Filter group.
   C. Click the Home tab on the Ribbon, click the Sort & Filter button in the Editing group, and click Filter.
   D. Type the formula =Filter(Data) in the first cell of the column to filter.

5. By default, when a total row is added to a table, the last column is summed. (True or False?)

6. Removing duplicates from a table moves the duplicate data to another worksheet. (True or False?)

7. Once a table style is applied to a table, it can't be changed it to a different one. (True or False?)

8. Which of the following is NOT a formatting option in the Table Style Options group?
   A. Header Row
   B. Checkered Rows
   C. Banded Columns
   D. First Column
9. Which of the following statements is NOT true?

   A. It’s possible to provide users with information and feedback using Data Validation.
   B. To use Data Validation, click the Data Validation button in the Data Tools group on the Data tab.
   C. The worksheet must be protected to use the data validation feature.
   D. Data validation allows restriction of which type of information is entered in a cell.

10. When converting a table to a range, the table formatting remains applied to the cells. (True or False?)
Quiz Answers

1. D. Before sorting data, make sure it's organized into columns and rows.
2. C. Sort data by cell icon, cell or font color, but not by number formatting.
3. A. Use the Sort dialog box to sort data by multiple columns.
4. C. To display the filtering buttons, click the Home tab on the Ribbon, click the Sort & Filter button in the Editing group, and click Filter.
5. True. When adding a total row to a table, the last column is summed by default.
6. False. Removing duplicates from a table deletes the data completely.
7. False. Table styles can always be changed.
8. B. Checkered Rows is not an option in the Table Style Options group.
9. C. There's no need to protect the worksheet to use the data validation feature.
10. True. When converting a table to a range, the table formatting remains applied to the cells.
Collaborate with Excel

Excel has come a long way in its abilities to allow you to work collaboratively. In this chapter you will learn how to work with comments, share workbooks, track changes, and protect your worksheets.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways you may follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that you may “build upon them”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Cell Comments

Sometimes notes may need to be added to a workbook to document complicated formulas, question values, or leave a comment for another user. Think of cell comments as Post-It Notes that can attach to any cell.

Add a Comment

1. Click the cell where you want to add the comment.
2. Click the Review tab.
3. Click the New Comment button.

Shortcut: Right-click a cell and select New Comment.

4. Type the comment you want.
5. Click anywhere outside the comment to deselect it.

The comment disappears, but a red triangle appears in the corner of the cell to show that it has a comment.

View a Comment

1. Point to a cell with a red triangle.

Tip: To display a comment all the time, click the cell with the comment, then click the Review tab on the Ribbon and click the Show/Hide Comments button in the Comments group.
Edit a Comment

1. Select a cell that has a comment to edit.
2. Click the Review tab.
3. Click the Edit Comment button.
   The comment box reappears, ready for editing.

Shortcut: Right-click a cell with a comment and select Edit Comment.

4. Update the comment with the new text.

Tip: Change the size of a comment text box by clicking and dragging one of the sizing handles that surrounds the comment.

5. Click anywhere outside the comment to deselect it.

Delete a Comment

1. Select a cell that has a comment to delete.
2. Click the Review tab.
3. Click the Delete button.

Shortcut: Right-click a cell with a comment and select Delete Comment.
Share Workbooks

Sharing a workbook allows several people, who have access to the file, to use the same workbook simultaneously. It also keeps track of any changes made to a shared workbook.

Some features like merged cells, charts, graphics, conditional formats, macros, PivotTables, hyperlinks, and worksheet protection can’t be modified in a shared workbook.

Share a Workbook

1. Click the Review tab.
2. Click Share Workbook.
3. In the dialog box, you'll see anyone who currently has the file open.
4. Check the Allow changes by more than one user check box.
5. Click OK.
6. Click OK.

Tip: Make sure the workbook is saved where it is accessible to other users, like a shared drive.

Stop Sharing a Workbook

1. Click the Review tab.
2. Click the Share Workbook button.
3. Uncheck the Allow changes by more than one user check box.
4. Click OK.
5. Click Yes to confirm the change.
Track Changes

Track changes allows you to see any updates made to the workbook by other users and choose to either accept or reject them. If the workbook is set to track changes, Excel automatically shares the workbook.

**Turn on Track Changes**

1. Click the Review tab.
2. Click the Track Changes button.
3. Select Highlight Changes.
4. Check the Track changes while editing check box.
5. Select the changes you wish to see.
6. Click OK.
7. Click OK to save the workbook.

**Track Changes**

Once Track Changes is enabled, you and others can start making changes.

1. Edit the worksheet as needed.
   
   Because track changes is enabled, cells that have changes appear with a blue border around them.

2. To view a change, point to a cell with a blue triangle.
Review Changes
Once changes have been made in a tracked workbook, decide whether to accept or reject those changes.

1. Click the Review tab.
2. Click the Track Changes button.
3. Select Accept/Reject Changes.
4. Click OK to save your workbook.
5. Select the changes you want to see.
6. Click OK.
7. Select an Accept or Reject option.
   - **Accept**: Keeps the change.
   - **Reject**: Undoes the change, returns to the original state.
   - **Accept All**: Accepts all the changes in the workbook.
   - **Reject All**: Rejects all of the changes in the workbook.
   - **Close**: Exit the check at any time to return to the worksheet.
Save a Change History

Sometimes it’s easier to have a separate list of changes than it is to see them all within the spreadsheet.

1. Click the Review tab.
2. Click the Track Changes button.
3. Select Highlight Changes.
4. Check the List changes on a new sheet box.
5. Click OK.

A new sheet named “History” is added with specific details about all the changes that have been made in the workbook.
Protect a Worksheet

Prevent unauthorized changes to data by protecting worksheets. In a protected worksheet, none of its contents can be changed. However, it’s possible to set up the worksheet so that only certain cells and elements can be changed after it’s protected.

Make Cells Editable

If there are cells that users should be able to change after a worksheet has been protected, make sure to mark them before you protect the worksheet.

1. Select the cells you want to unlock.
2. Click the Format button.
4. Click the Protection tab.
5. Uncheck the Locked check box.
6. Click OK.

Tip: Locking and unlocking cells only takes effect once the sheet is protected.

Shortcut: You can also toggle the lock on and off by clicking the Format button and selecting Lock Cell.

©CustomGuide 2015
Hiding Formulas

If you don’t want other users to see a cell’s formula, you can hide it.

1. Select the cells with formula you want to hide.
2. Click the Format button.
4. Check the Hidden check box, on the Protection tab of the Format Cells dialog box.
5. Click OK.

Tip: Remember, even if cells are locked and hidden here, it doesn’t take effect until the worksheet is protected.

Protect a Worksheet

Once you finish preparing the worksheet, it’s time to protect it.

1. Click the Review tab.
2. Click the Protect Sheet button.
3. Enter a password if desired.
4. Select more protection options.
5. Click OK.
6. Confirm the password and click OK.
Password Protection

When a password is added to a workbook, you can prevent the workbook from being opened or modified.

1. Click the **File tab**.
2. Click **Save As**.
3. Click **Browse**.
4. Click **Tools**.
5. Select **General Options**.
6. Type a password in the **Password to open** and/or **Password to modify** boxes.

**Tip:** Check the **Always create backup box** to save a copy without a password in case the password is forgotten.

7. Click **OK**.
8. Reenter the password.

**Tip:** Type a secure password that can't easily be guessed by other users, and be sure to write down your password in a safe location.

9. Click **OK**.

**Tip:** To change or remove a password, repeat the workbook protection steps and simply change or delete the password in the General Options dialog box.

10. Click **Save**.
Save as Web Pages

When your worksheet has data that needs to be shared on the web, save it as a web page with the .htm or .html file format.

1. Click the File tab.
2. Click Save As.
3. Click the Browse button.
4. Click the Save As Type menu arrow.
5. Select Web Page.
6. Type a name for the file.
7. Click Save.

The worksheet is saved in a web page format that can now be uploaded and shared on the web.
Collaborate with Excel Quiz

1. Cell comments are a lot like Post-It Notes that can attach to any cell. (True or False?)

2. Excel can delete a cell comment but not edit one. (True or False?)

3. You can Share a workbook from the ________?
   A. Page Layout tab
   B. Review tab
   C. View tab
   D. Insert tab

4. Which of these options is NOT an option in the Accept or Reject Changes dialog box?
   A. Reject All
   B. Accept
   C. Skip
   D. Close

5. You can hide a cell’s formulas so that other users cannot see them. (True or False?)
Quiz Answers

1. True. Cell comments are notes that can attach to any cell—like a Post-It.
2. False. Excel can edit or delete a cell comment.
3. B. You can share a workbook from the Review tab.
4. C. Skip is not an available option in the Accept or Reject Changes dialog box.
5. True. You can hide a cell’s formulas so that other users cannot see them.
PivotTables

A PivotTable is usually the best way to summarize and analyze data ranges or tables with large amounts of data. PivotTables are good for grouping or expanding levels of data, switching columns and rows (“pivoting” data), and filtering and sorting. They lend themselves particularly well to summarizing long lists of data that need to be summed.

This chapter explains how to create PivotTables, modify their structure, and create PivotCharts that graphically illustrate PivotTables.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways you may follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that you may “build upon them”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Create PivotTables

PivotTables are usually the best way to summarize and analyze large data ranges. They are good for grouping or expanding levels of data, switching columns and rows, and filtering and sorting. Before creating a PivotTable, decide which fields to include, how the PivotTable will be organized, and what types of calculations it will perform.

1. Select any cell in the data range you want to analyze.

   **Tip:** You can also create a PivotTable from a table. Just select a cell in a table, click the Design tab, and click the Summarize with Pivot button.

2. Click the Insert tab.

3. Click the PivotTable button.

   **Tip:** Select the Use an external data source option to select a data range that isn’t in the current workbook.

4. Make sure the correct data range is selected, then click OK.

   An empty PivotTable appears on a new worksheet along with the PivotTable Fields task pane.

   **Tip:** To change how the PivotTable Field task pane looks, click the Tools menu arrow in the top right corner and select a layout option.

5. Click and drag a field to the Rows area.

6. Click and drag a field to the Values area.

   **Tip:** Drag a field between the Row Labels and Column Labels boxes to change the orientation of the PivotTable.

7. (Optional) Click and drag a field to the Columns area.

   The data and layout of the PivotTable change accordingly.
Use Multiple PivotTable Fields

Add an Additional Field Value

You can add more than one field to each area of the PivotTable.

1. (Optional) If the PivotTable Fields task pane isn’t visible, select any cell in the PivotTable.
2. Click and drag an additional field into any area.

Tip: Drag fields within a table area in the task pane to reorder them.

Tip: If you no longer need a field to display in the PivotTable, just click and drag it outside the task pane.

Expand or Collapse a Heading

When a PivotTable area has multiple fields, the expand and collapse options appear, allowing you to focus in on specific data.

1. Click the + or – symbol by the heading in the PivotTable.
Change a PivotTable’s Calculation

Besides adjusting the layout of a PivotTable data, it’s also possible to change how a PivotTable summarizes values. For example, a PivotTable can display averages instead of totals.

1. Select a cell that has a calculation you would like to change.
2. Click the Analyze tab on the ribbon.
3. Click the Active Field button on the ribbon.
4. Click Field Settings.
5. The Value Field Settings dialog box appears. Select from many calculation options including Sum, Count, Average, or Max, among others.
6. Select the type of calculation you want to use.
7. Click OK.

The summarized data in the PivotTable changes to use the new calculation.
Filter PivotTables

Much like with basic data ranges and tables in Excel, it’s possible to filter data in a PivotTable.

Add a Filter Field

1. Click any cell in the PivotTable.
2. Drag a field to the Filters area on the task pane. The filter field appears at the top of the PivotTable.
3. Click the list arrow for the field you want to filter.
4. Select the item(s) you want to use as a filter.
5. Click OK.

Tip: You can also filter any column heading in a PivotTable by clicking its drop-down arrow.
Clear and Remove a Filter

When you’re done using a filter, clear it to see all the data once again. Or, remove the filter field from the PivotTable altogether.

1. Click the filter icon next to the filter field.
2. Select All.
3. Click OK.

The filter is cleared from the PivotTable, showing all the data once again. To remove the filter field entirely...
4. Click and drag the field out of the Filters area.
Group Values

PivotTables that summarize a lot of information can sometimes be difficult to understand. You can group PivotTable data in order to set apart specific subsets of data, like dates or locations.

Group PivotTable Values

1. Click any cell that has a value you want to group by.
2. Click the Analyze tab on the ribbon.
3. Click the Group Field button.
   **Shortcut:** Right-click a cell and select Group.
4. Specify how you want to group your PivotTable.
5. Click OK.
   **Tip:** To group dates by weeks, select Days in the By area of the Grouping dialog box and enter 7 in the Number of days box.

Ungroup PivotTable Values

When you no longer need to see the values grouped, just ungroup them.

1. Select a cell that contains the value you want to ungroup.
2. Click the Analyze tab on the ribbon.
3. Click the Ungroup button.
   **Shortcut:** Right-click a grouped cell and select Ungroup.

The grouping is removed from the PivotTable and the original values appear once again.
Timelines

Timelines are a special kind of filter that let you see data for a specific time period.

**Insert a Timeline**

1. Click any cell inside the PivotTable.
2. Click the **Analyze tab** on the ribbon.
3. Click the **Insert Timeline button**.
4. Select the date field you want to use the timeline.
5. Click **OK**.
6. The timeline appears on top of your PivotTable.

**Tip:** Hold down the **Shift key** to select multiple months.

**Clear or Remove a Timeline**

If you want to see all the PivotTable data again, clear or remove the timeline.

1. Click the **Clear Filter button**.
   
   The timeline filter is cleared from the PivotTable, showing all the data once again.

   To remove the timeline entirely...

2. Right-click the timeline.
3. Select **Remove Timeline**.

**Shortcut:** Select the timeline and press **Delete**.
PivotTable Layout

Once a PivotTable displays the data you want, you can change which layout elements appear.

1. Click any cell inside the PivotTable.
2. Click the Design tab on the Ribbon.
3. The Layout group holds many tools to help you change which elements appear in your PivotTable.
4. Click the Layout element you want to change.
   - Subtotals
   - Grand Totals
   - Report Layout
   - Blank Rows
5. Select a different display setting.
   The PivotTable layout is updated.
Refresh a PivotTable

If changes have been made to the data that the PivotTable pulls from, update the PivotTable to match the current data.

Manually Update a PivotTable

1. Click any cell inside the PivotTable.
2. Click the Analyze tab on the Ribbon.
3. Click the Refresh button on the ribbon.

The PivotTable updates to include any changes to the source data.

Shortcut: Press Alt + F5.

Automatically Update a PivotTable

You can also have Excel automatically refresh the PivotTable(s) in a workbook when a file opens.

1. Click the Analyze tab on the ribbon.
2. Click the PivotTable button.
3. Click Options.
4. Click the Data tab.
5. Select Refresh data when opening the file.
6. Click OK.

Any PivotTables in the workbook will automatically refresh each time the file is opened.
Format a PivotTable

If you don't like how a PivotTable looks, quickly format it with Excel's built-in styles and style options.

Use Style Options

PivotTable style options make it possible to adjust the format for a specific part of a PivotTable.

1. Click any cell inside the PivotTable.
2. Click the Design tab on the ribbon.
3. Toggle options on or off using the PivotTable Style Options group on the Ribbon.
   - Row Headers
   - Banded Rows
   - Column Headers
   - Banded Columns

Apply a Built-in Style

The PivotTable style options provide consistent formatting for the entire PivotTable.

1. Click any cell inside the PivotTable.
2. Click the Design tab on the ribbon.
3. Click the More button in the PivotTable Styles group.
4. Select the style you want to use.

Tip: Besides using the formatting options on the Design tab, you can also format a PivotTable using the general formatting commands found on the Home tab.
Pivot Charts

A PivotChart is similar to an ordinary chart created in Excel, except that it plots a PivotTable’s information. Like PivotTables, PivotCharts are dynamic, which means a PivotChart’s structure can be changed.

Insert a PivotChart

1. Click any cell inside the PivotTable.
2. Click the Analyze tab on the ribbon.
3. Click the Pivot Chart button on the Ribbon.
4. Select the type of chart you want to use.
5. Click OK.

Tip: Click and drag the PivotChart’s border to move the chart around in the worksheet.
Modify a PivotChart

1. Click and drag a field out of a Task Pane area to remove it from the chart.
2. Click and drag a field into a Task Pane area to add it to the chart.
3. Click the Analyze tab to change the PivotChart’s data.
4. Click the Design tab to change the PivotChart’s layout.
5. Click the Format tab to change the PivotChart’s appearance.

Tip: If the PivotTable is modified, the PivotChart will change as well.
1. Create a PivotTable in its own new worksheet or in one that already exists in the workbook. (True or False?)

2. Specify the data to use in the PivotTable in the ___________ task pane.
   A. Select Fields
   B. Specify Fields
   C. PivotTable Fields
   D. PivotTable Layout

3. Which of the following is NOT a button found in the Layout group on the Design tab?
   A. Header Row
   B. Grand Totals
   C. Report Layout
   D. Blank Rows

4. When making changes to the PivotTable's source data, the PivotTable refreshes automatically to include the edits. (True or False?)

5. Which of the following is NOT an option in the PivotTable Style Options group?
   A. Banded Columns
   B. Banded Rows
   C. Bold Headers
   D. Row Headers

6. When modifying a PivotTable, the PivotChart is updated along with it. (True or False?)

7. You have to first create a PivotTable in order to create PivotChart. (True or False?)
Quiz Answers

1. True. Create a PivotTable in either a new or existing worksheet.
2. C. Specify the data to use in the PivotTable in the PivotTable Field List task pane.
3. A. Header Row is not a button found in the Layout group on the Design tab.
4. False. Manually refresh the PivotTable to include changes made to the source data.
5. C. Bold Headers is not an option in the PivotTable Style Options group.
6. True. When modifying a PivotTable, the PivotChart is updated along with it.
7. False. In Excel 2016, you are able to create a standalone PivotChart without the association of a PivotTable.