Table of Contents

Database Basics .......................................................................................................................... 7
  Introduction to Databases ......................................................................................................... 8
  What’s New in Access 2013 ....................................................................................................... 10
  Understanding the Access Program Screen ........................................................................... 11
  Working with Database Objects ............................................................................................... 12
  Tour of a Table .......................................................................................................................... 14
  Adding, Editing and Deleting Records .................................................................................... 14
  Tour of a Form ............................................................................................................................ 16
  Tour of a Query .......................................................................................................................... 17
  Tour of a Report .......................................................................................................................... 19
  Selecting Data ............................................................................................................................ 20
  Using the Zoom Box .................................................................................................................. 21

Database Basics Review ............................................................................................................. 23

Creating and Working with a Database ..................................................................................... 26
  Planning a Database ................................................................................................................... 27
  Creating a New Database .......................................................................................................... 29
  Creating a Table .......................................................................................................................... 31
  Modifying a Table ...................................................................................................................... 33
  Creating a Query ....................................................................................................................... 35
  Sorting a Query ........................................................................................................................... 37
  Using AND and OR Operators in a Query ............................................................................... 38
  Creating a Form with the Form Wizard .................................................................................... 39
  Creating a Report with the Report Wizard .............................................................................. 41
  Creating Mailing Labels with the Label Wizard ..................................................................... 43
  Converting an Access Database ............................................................................................... 45

Creating and Working with a Database Review ...................................................................... 47

Finding, Filtering, and Formatting Data ................................................................................... 49
  Finding and Replacing Data ....................................................................................................... 50
  Sorting Records .......................................................................................................................... 52
  Using Common Filters ............................................................................................................... 53
  Filtering by Selection .................................................................................................................. 55
  Filtering by Form ......................................................................................................................... 56
  Creating an Advanced Filter ...................................................................................................... 57
  Adjusting and Rearranging Rows and Columns ..................................................................... 59
  Changing Gridline and Cell Effects .......................................................................................... 61
  Changing theDatasheet Font ...................................................................................................... 63
  Freezing a Column ..................................................................................................................... 64
  Hiding a Column ......................................................................................................................... 65

Finding, Filtering, and Formatting Data Review ...................................................................... 66

Working with Tables and Fields ............................................................................................... 68
  Understanding Field Properties ............................................................................................... 69
  Indexing a Field .......................................................................................................................... 71
  Adding a Primary Key to a Table ............................................................................................... 73
  Inserting, Deleting, and Reordering Fields ............................................................................. 75
  Adding Field Descriptions and Captions ................................................................................ 77
  Changing the Field Size ............................................................................................................. 78
  Formatting Number, Currency, and Date/Time Fields ............................................................ 80
  Formatting Number, Currency, and Date/Time Fields by Hand ........................................... 82
  Formatting Text Fields .............................................................................................................. 84
  Setting a Default Value .............................................................................................................. 85
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with Forms Review</td>
<td>86</td>
</tr>
<tr>
<td>Validating Data</td>
<td>87</td>
</tr>
<tr>
<td>Creating an Input Mask</td>
<td>89</td>
</tr>
<tr>
<td>Creating a Lookup Field</td>
<td>91</td>
</tr>
<tr>
<td>Creating a Value List</td>
<td>93</td>
</tr>
<tr>
<td>Modifying a Lookup List</td>
<td>95</td>
</tr>
</tbody>
</table>

| Working with Tables and Fields Review                                | 97   |

| Creating Relational Databases Review                                 | 100  |
| Understanding Table Relationships                                   | 101  |
| Creating Relationships Between Tables                                | 103  |
| Enforcing Referential Integrity                                      | 105  |
| Printing and Deleting Relationships                                  | 107  |
| Understanding Relationship Types                                     | 109  |

| Creating Relational Databases Review                                | 110  |

| Working with Queries Review                                         | 112  |
| Understanding Different Types of Queries                            | 113  |
| Creating a Multiple Table Query                                     | 114  |
| Creating a Calculated Field                                         | 116  |
| Working with Expressions and the Expression Builder                  | 118  |
| Using an If Function                                                | 120  |
| Summarizing Groups of Records                                       | 122  |
| Display Top or Bottom Values                                        | 124  |
| Parameter Queries                                                   | 125  |
| Finding Duplicate Records                                           | 127  |
| Finding Unmatched Records                                           | 128  |
| Crosstab Queries                                                    | 130  |
| Delete Queries                                                      | 132  |
| Append Queries                                                      | 134  |
| Make-Table Queries                                                  | 136  |
| Update Queries                                                      | 138  |

| Working with Queries Review                                         | 140  |

| Working with Forms Review                                           | 143  |
| Creating and Using a Form                                           | 144  |
| Understanding Form Views                                            | 146  |
| Modifying a Form in Layout View                                     | 147  |
| Form Design View Basics                                             | 149  |
| Changing Tab Order                                                  | 151  |
| Working with Control Properties                                     | 152  |
| Control Property Reference                                          | 154  |
| Working with Form Properties                                        | 156  |
| Form Property Reference                                             | 158  |
| Changing a Control’s Data Source                                    | 160  |
| Creating a Calculated Control                                       | 161  |
| Changing a Control’s Default Value                                  | 162  |
| Creating a Subform                                                  | 163  |
| Modifying and Working with Subforms                                  | 165  |

| Working with Forms Review                                           | 166  |

| Working with Reports                                                 | 169  |
| Creating a Report                                                    | 170  |
| Working in Layout View                                               | 171  |
| Adding a Logo                                                        | 174  |
| Working in Design View                                               | 175  |

Introducing CustomGuide Courseware

Thank you for choosing CustomGuide courseware as the solution to your training needs. A proven leader in the computer training industry, CustomGuide has been the key to successful training for thousands of students and instructors across the globe.

This manual is designed for computer users of all experience levels, from novices to advanced users.

All this information is quickly accessible. Lessons are broken down into basic step-by-step instructions that answer “how-to” questions in minutes. You can print a complete 300-page training manual or a single page of instructions.

Here’s how a CustomGuide manual is organized:

**Chapters**
Each manual is divided into several chapters. Aren't sure if you're ready for a chapter? Look at the table of contents that appears at the beginning of each chapter. It will tell you the name of each lesson and subtopic included in the chapter.

**Lessons**
Each chapter contains lessons on related topics. Each lesson explains a new skill or topic and contains an exercise and exercise File to give you hands-on-experience. These skills can also be practiced using CustomGuide Online Learning.

**Review**
A review is included at the end of the manual. Use these quiz questions and answers to assess how much you've learned.

What People Are Saying

“I have saved hundreds of hours of Design time by just picking and choosing what I want from the courseware.”
— Stephanie Zimmerman
Lancaster County Library

“We have been able to customize our training sessions on all Microsoft Office products, at all levels. The ROI of these guides is great.”
— Dawn Calvin
Las Virgenes Municipal Water District

“All in all, the friendliest, most open and easy to understand tutorial of its type that I’ve ever seen.”
— W. Boudville
Amazon.com

“…curriculum that is of high quality, student friendly, and adaptable to the audience.”
— Sherrill Wayland
St. Charles Community College

“…a nice training option for almost any need. Their complete Microsoft Office package is by far the best deal on the market.”
— Technical Assistance Program
Purdue University

“Any instructor teaching classes on Windows or Microsoft Office will definitely want to give serious consideration to this important collection of titles that will definitely fit well into their classroom learning.”
— Dale Farris
Golden Triangle PC Club

“The materials are exceptional – I am so excited about using them! Thanks to you and your team for doing this wonderful work!”
— Shannon Coleman
Learning Post Ltd.
This chapter will introduce you to Access basics. We don’t get into great depth here, but we make sure you understand key Access functionality, such as entering data and the basics of Tables, forms, queries and reports. This chapter will help you build a solid foundation of Access knowledge, and if you’re involved more with data entry than database Design or administration, this chapter may be all you need to do your job.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Introduction to Databases

In its simplest form, a database is a collection of information organized into a list. Whenever you make a list of information, such as names, addresses, products, or invoices, you are, in fact, creating a database.

Technically speaking, you don’t even have to use a database program to create a database. You can make a list of information in all kinds of programs, such as Microsoft Excel or Word.

A database program, however, is much more powerful than a simple list you keep on paper or in a Microsoft Word document. A database program lets you:

- **Store Information:** A database stores lists of information that are related to a particular subject or purpose. A database stores personal information, such as a list of Aunt Mildred’s Home recipes, or business information, such as a list of hundreds of thousands of customers. A database also makes it easy to add, update, organize, and delete information.

- **Find Information:** You can easily and instantly locate information stored in a database. For example, you can find all the customers with the last name “Johnson” or all the customers who live in the 55417 zip code and are older than 65.

- **Analyze and Print Information:** You can perform calculations on information in a database. For example, you could calculate what percent of your total sales comes from the state of Texas. You can also present information in a professional-looking printed report.

- **Manage Information:** Databases make it easy to work with and manage huge amounts of information. For example, with a few keystrokes you can change the area code for hundreds of customers in the (612) area code to a new (817) area code.

- **Share Information:** Most database programs (including Microsoft Access) allow more than one user to view and work with the same information at once. Such databases are called multi-user databases.

Database objects

Databases usually consist of several parts. A Microsoft Access database may contain up to seven different database object types.

Some objects you will use all the time (such as Tables), while others you may hardly ever use (such as Modules).

Table 1-1: Database Objects identifies the database objects you can use when creating a Microsoft Access database.
## Database Basics

<table>
<thead>
<tr>
<th>Table 1-1: Database Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Tables</strong></td>
</tr>
<tr>
<td><strong>Queries</strong></td>
</tr>
<tr>
<td><strong>Forms</strong></td>
</tr>
<tr>
<td><strong>Reports</strong></td>
</tr>
<tr>
<td><strong>Macros</strong></td>
</tr>
<tr>
<td><strong>Modules</strong></td>
</tr>
</tbody>
</table>
**What's New in Access 2013**

Access 2013 has a few great new features. The table below gives you an overview of what to expect.

<table>
<thead>
<tr>
<th><strong>Table 1-2: What's New in Access 2013</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Templates</strong></td>
</tr>
<tr>
<td><strong>Web Apps</strong></td>
</tr>
<tr>
<td><strong>SharePoint</strong></td>
</tr>
<tr>
<td><strong>New Controls</strong></td>
</tr>
<tr>
<td><strong>Import Data</strong></td>
</tr>
<tr>
<td><strong>Permission Improvements</strong></td>
</tr>
<tr>
<td><strong>Drill-through Links</strong></td>
</tr>
<tr>
<td><strong>Action Bar</strong></td>
</tr>
</tbody>
</table>

**Exercise**

- **Exercise File:** None required.
- **Exercise:** Review the new features in Microsoft Office Access 2013.
Understanding the Access Program Screen

The Access 2013 program screen may seem confusing and overwhelming at first. This lesson will help you become familiar with the Access 2013 program screen as well as the new user interface.

- **File tab**: Contains basic File management commands—such as New, Open, Save, and Close—and program options.
- **Quick Access Toolbar**: Contains common commands such as Save and Undo. You can add more commands as well.
- **Title bar**: Displays the name of the workbook you are working on and the name of the program you are using.
- **Close button**: Click the close button in the Title bar to exit the Access program entirely, or click the close button in the Ribbon to close only the current database object.
- **Ribbon**: The tabs and groups on the Ribbon Replace the menus and toolbars found in previous versions of Access.
- **Access Object**: View the content of the various database objects.
Working with Database Objects

Think of the Navigation Pane as the mission control center for an Access database. You use the Navigation Pane to open and manage the different types of objects in your database. The Navigation Pane contains buttons for each type of database object. To display a type of object, double-click the appropriate button.

Navigation Pane

1. Click the arrow button at the top of the Navigation Pane to change how objects are viewed in the pane.
   
   Tip: If the Navigation Pane is minimized, click the Shutter Bar Open/Close button to expand it.
   
   Only Table objects are displayed by default in a new database, but you can display all objects...

2. Select Object Type and make sure there’s a checkmark next to All Access Objects.
   
   Now you can see all the objects in the database.

Tips

✓ In Access 2013, the Navigation Pane replaces the need for switchboards (forms with buttons that helped you navigate older versions of Access). If you’ve converted an old File that has switchboards, you can continue to use them, but some actions may no longer work in Access 2013.

Open a database object

   
   The object appears on the screen as a tabbed item.

   Other Ways to Open a Database Object:
   Right-click the object you want to open in the Navigation Pane and select Open from the contextual menu or, if you want to open it in Design View for editing, select Design View.

Tips

✓ When you open an object in Access 2013, it appears in the window with its own tab. As you open additional objects, they stack on top of each other in the same window. To bring a different object to the top where it’s visible, click its tab.

Exercise

• Exercise File: Employees.accdb
• Exercise: Open the Employees table in the Navigation Pane. View the Employees table in Design View. Close the Employees table (remember, this is different than closing the entire database).
Modify a database object in Design View

You can modify any database object by opening it in Design View. Design View displays the structure of a database object and allows you to make changes to it. You don’t have to know how to make changes to a database object yet, but you will need to know how to open an object in Design View. Here’s how:

1. With an object open, click the Home tab on the Ribbon and click View button list arrow in the Views group.

   Here you have a few different view choices.

2. Select Design View.

   The object appears in Design View where its structure can be modified.

   **Other Ways to Open an Object in Design View:**
   With the object open, right-click the object’s tab and select Design View from the contextual menu.

**Tips**

✓ You’ll learn more about additional types of views as you learn how to work with each type of object.

Close a database object

1. Click an object’s tab to display it, if necessary, then click the object’s Close button in the upper-right corner of the window.

   The object closes.

   **Other Ways to Close a Database Object:**
   Right-click the object’s tab in the window and select Close.

**Tips**

✓ To rename an object, right-click the object in the Navigation Pane and select Rename. Type a new name.

✓ To delete an object, select the object in the Navigation Pane and press <Delete>. Click Yes.
Tour of a Table

Tables are the heart and soul of any database. Tables are where a database stores all of its information. All the other database objects—queries, forms, reports, pages, macros, and modules—are merely tools to analyze and manipulate the information stored in a table. Any of these other database objects are optional, but without Tables, a database wouldn’t be a database.

Each table in a database stores related information. Most databases have more than one table. Each table is used to store a different type of information. For example, one table might contain a list of customers and their addresses, while another table might contain any orders placed by the customers, while yet another table might contain a list of products.

Tables are made up of groups of Fields (columns). A field is a specific type of information, such as a person’s last name, address, or phone number. Together, the related Fields for each individual person, place, or thing make up a single record (row). If your company has ten employees, your employee table would have ten records—one for each employee.

Open a table

1. Double-click the table you want to open in the Navigation Pane.

   The table opens as a tab in the window. Table information is displayed, entered, and modified in a datasheet. A datasheet is a grid that contains all the records in a table. Records are stored in rows and field names are stored in columns.

   Tip: Of course, before you can open a table someone will need to have already created the table, or else you’ll need to be using a database template that already has Tables created for you.

Navigate a table

Let’s take a closer look at the current table. First notice the squares that appear to the left of the table records. Each of these is a record selector, and is highlighted next to the record that you are currently working on.

Next, take a look at the record navigation buttons near the bottom of the screen, as shown in Table 1-3: Table Navigation Using the Record Navigation Bar. The record navigation buttons on the Record Navigation bar display the number of records in the current database and allow you to move between these records.
### Tips

- If a table has been “related” to another table, you will see expand buttons next to the records in the table. Click one to view information from the related table that is related to that record.

  For example, if you have a table containing employee names, and that table is related to another table that lists the computers assigned to each employee, you could click on the expand button next to the employee and see the details of the computer assigned to that employee.

---

**Table 1-3: Table Navigation Using the Record Navigation Bar**

<table>
<thead>
<tr>
<th>Go to:</th>
<th>Navigation buttons</th>
<th>Keyboard</th>
<th>Mouse</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next record</td>
<td>Click the Next record navigation button.</td>
<td>Press the &lt;↓&gt; (down arrow) key.</td>
<td>Click the record you want to select (if displayed).</td>
</tr>
<tr>
<td>Previous record</td>
<td>Click the Previous record navigation button.</td>
<td>Press the &lt;↑&gt; (up arrow) key.</td>
<td>Click the record you want to select (if displayed).</td>
</tr>
<tr>
<td>Last record in the table</td>
<td>Click the Last record navigation button.</td>
<td>Press &lt;Ctrl&gt; + &lt;End&gt; (when not editing record).</td>
<td>N/A</td>
</tr>
<tr>
<td>First record in the table</td>
<td>Click the First record navigation button.</td>
<td>Press &lt;Ctrl&gt; + &lt;Home&gt; (when not editing record).</td>
<td>N/A</td>
</tr>
<tr>
<td>New blank record</td>
<td>Click the New (blank) record navigation button.</td>
<td>N/A</td>
<td>Click in the (New) row at the end of the table.</td>
</tr>
<tr>
<td>Search for record using keywords</td>
<td>Type a keyword in the Search box next to the navigation buttons.</td>
<td>N/A</td>
<td>N/A</td>
</tr>
</tbody>
</table>
Adding, Editing and Deleting Records

You can easily add, change, or delete the records in your table. For example, you might want to add a record to store information about a new employee, change an existing record when an employee’s address changes, or delete a record for an employee who no longer works for the company. In this lesson you’ll learn how to add, edit, and delete a table’s records.

Add a record

1. Click the New Record button on the Record Navigation bar.

   The record selector jumps to the blank row at the end of the table and the blinking insertion point ( | ) appears in the first column.

   Other Ways to Add a New Record:
   If the New record row is in view, simply click in that row.

2. Click a field in the new record and enter your data.

   As you enter data, you don’t have to click a Save button to save the information—Access automatically saves the information as you enter it.

   Tip: Press <Tab> or <Shift> + <Tab> keys to quickly move between Fields in a record.

Edit a record

You can also make changes to the records in a table at any time.

1. Click the field you want to edit and make the changes.

Delete a record

You can permanently delete records that you no longer need from a table.

1. Click the record selector next to the record you want to delete.

2. Click the Home tab on the Ribbon, click the Delete button (X) in the Records group, select Delete Record and click the Yes button.

   Other Ways to Delete a Record:
   Click the record selector next to the record you want to delete. Press the <Delete> key. Click the Yes button.

Exercise

- Exercise File: Employees.accdb
- Exercise: Open the Employees table in Datasheet View. Go to the New record at the bottom of the table and enter your last name in the LastName field. Complete the rest of the Fields in the record with your own information (enter today’s date for the hire date). Then edit the Title field for your record and change it to “Inside Sales Coordinator”. Delete the record you just Created. Close the table.

Figure 1-6: Entering data in a table.

Figure 1-7: Deleting a record by clicking the Delete button in the Records group on the Home tab.
Tour of a Form

Adding, viewing, and modifying information in a database should be straightforward and easy. However, information in a table is often difficult to understand and manage. Access solves this problem by using forms to display table and query data.

The forms in Access are actually quite similar to the ordinary paper type of form you fill out with a pen or pencil. Access forms have several major advantages over the traditional paper type of forms, however—they save you time, effort, and paper.

Forms can include fill-in-the-blank Fields, check-boxes, lists of options—even information and prompts to help users complete the form. Forms can also contain buttons that allow you to perform other actions, such as running macros to print reports or labels. Forms can even validate data entry by automatically checking your entries for errors.

There are a few different kinds of forms in Access 2013:

- **Form**: A traditional form view. In Layout view, you can edit the form Design while also displaying data.

- **Split form**: Creates a split screen that allows you to view information through a Form view and Datasheet view at the same time. You can use the datasheet to locate a record and the form view to edit it.

- **Multiple items form**: Allows you to view multiple records at a time—unlike a regular form where you can only work with one record at a time. Looks much like a datasheet, but allows for more customization.

- **Other forms types**: You may also come across forms that look like datasheets, or Modal Dialog forms that pop out in their own dialog box windows (instead of appearing as tabbed items next to the other database objects in the main database window).

Open a form

1. Double-click the form you want to open in the Navigation Pane.

   The form opens in the window in Form view.
Navigate a form

1. Use the record navigation buttons near the bottom of the screen.

Add a record

1. Click the New Record button on the Record Navigation bar.

   Some forms have only fill-in-the-blank style text Fields and display only one record, while others are more complex and may display multiple records and contain lists, combo boxes, check boxes, or sub-forms. Some forms look just like a table datasheet.

2. Enter data as desired.

Delete a record

1. Click the record selector to the left of the record or form to select it.

2. Click the Home tab on the Ribbon and click the Delete (X) button in the Records group.

   Click Delete Record. A dialog box appears, asking if you’re sure you want to delete the record.

3. Click Yes.

Tips

✓ A simple form may contain only fill-in-the-blank style text Fields, but many forms are more complex and may contain lists, combo boxes, check boxes, and sub-forms.

Figure 1-10: Deleting a record from a form in the Records group on the Home tab.
Tour of a Query

A query, by definition, is a question or inquiry. Queries in Access ask a question of the information in a table and then retrieve and display the results.

For example, if you wanted to know which employees had worked for the company for more than five years, you could create a query to examine the contents of the HireDate field to find all the records in which the hire date is more than five years old. Access would retrieve the information that meets your criteria and display it in a datasheet.

Let’s take a closer look at queries.

Open a query

1. Double-click the query you want to open in the Navigation Pane.

   The query appears in the window in Datasheet view. You’ll notice that the layout of a query doesn’t look any different than a table—records appear in rows, Fields appear in columns, and the record navigation buttons appear at bottom of the window. Some queries even allow you to add, edit, and delete records to and from the underlying Tables. The information in a query isn’t a duplication of the data in a table—it’s just another way of looking at it.

Display a query in Design View

In Design View you can see a query’s underlying Tables, which Fields are included in the query, and the criteria used to specify which records to display.

1. Open the query, click the Home tab on the Ribbon and click the View button in the Views group. Select Design View.

   The query appears in Design View. Here you can change the criteria and Fields that filter the table data.

   Other Ways to Open a Query in Design View:
   Right-click the query object in the Navigation Pane and select Design View. Or, click the Design View button in the Status bar.

Exercise

- Exercise File: Employees.accdb
- Exercise: Open the USA Employees query, which displays only employees from the USA, and display it in Design View. Select the “USA” text in the criteria box and Replace it with “UK”. Display the query in Datasheet View. Notice that only UK employees appear. Close the query but don’t save the changes.

Figure 1-11: A query in Datasheet View.

Figure 1-12: A query in Design View.
Tour of a Report

Managers like paper. Don’t try explaining anything to them—they’ll want to see it in printed hardcopy first. Fortunately, with a report, you can print database information from Tables and queries and satisfy the demands of even the most paper-hungry supervisor.

Although you can print table and query information directly from their datasheets, reports give you many more formatting and display options. Reports can be a simple list of records in a table or a complex presentation that includes calculations, graphics or even charts.

Reports are the most static of all the database objects. Unlike Tables and forms, which allow user interaction, reports just sit there, waiting to be printed.

In this lesson we won’t actually create a report, but you will learn how to use an existing report.

Open a report

1. Double-click the report you want to open in the Navigation Pane.

   The report appears in Report View.

   Tip: To edit a report’s structure, you need to change to Layout or Design View. Click the View button arrow in the Views group on the Home tab and select a view. Most edits can be made in Layout View, but complex tasks require Design View.

   ![Employee List Report](image)

   Figure 1-13: A report in Report View.
Selecting Data

Often, before you can do anything in Access, you must select the data that you want to work with. Many common tasks such as editing, formatting, copying, cutting, and pasting all require you to know how to select information. The procedure for selecting text in Access is no different than selecting text in any other Microsoft Office program.

1. Move the insertion point to the beginning or end of the text you want to select.

2. Click and hold the left mouse button and drag the insertion point across the text, then release the mouse button once the text is selected.

Table 1-4: Data Selection Shortcuts describes several techniques for selecting data in Access.

Other Ways to Select Text:
Press and hold the <Shift> key while using the arrow keys to select the text you want.

Tips
✓ To replace text, select the text you want to replace, then type the new text with which you want to replace it.

Table 1-4: Data Selection Shortcuts

<table>
<thead>
<tr>
<th>To select:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A word</td>
<td>Double click anywhere in the word.</td>
</tr>
<tr>
<td>A cell</td>
<td>Position the mouse over the left edge of the cell you want to select and click to select the cell.</td>
</tr>
<tr>
<td>A record or row</td>
<td>Position the mouse over the record selector and click to select the record. To select multiple records, drag down until you have highlighted all the records you want to select.</td>
</tr>
<tr>
<td>A field or column</td>
<td>Position the mouse over the name of the field you want to select and click to select it.</td>
</tr>
<tr>
<td>An entire table</td>
<td>Click the box to the far left of the field names.</td>
</tr>
</tbody>
</table>

Exercise

Exercise File: Employees.accdb

Exercise: Open the Employees table. In the first row of the Address column, select “Moss Bay Blvd.” (but not 722). Type “East River Road”. Practice using the record selectors to select rows and the field headers to select columns. Select the entire table. Close the table without saving changes.

Figure 1-14: Click, drag, and type to select and Replace text in a table cell.

Figure 1-15: Selecting rows of data in a table.
Using the Zoom Box

When you are viewing and working with data, sometimes a column will not be wide enough to display all the text in a cell or field. This is especially true for notes and memo fields, which may contain several paragraphs of text. Don’t worry—you can summon the Zoom box to make the contents of any field easier to view and edit.

1. Select the field you want to zoom in on and press <Shift> + <F2>.

   The Zoom box appears and displays the contents of the selected field. You can edit the field’s information in the Zoom box. When you’re finished viewing or editing the field…

2. Click OK to close the Zoom box.

   The field will display any changes you made to the data.

Exercise

- Exercise File: Employees.accdb
- Exercise: Open the Employees table. Using the Zoom box, zoom in on the Notes field for any record. Close the Zoom box and the table.

Figure 1-16: Zooming in on the Notes field with the Zoom box.
Database Basics Review

Quiz Questions

1. A database allows you to do which of the following?
   A. Store information
   B. Share information
   C. Find information
   D. All of these

2. Which of the following is NOT a new feature in Access 2013?
   A. Web Apps
   B. SharePoint
   C. New Controls
   D. SmartArt

3. What is the Ribbon?
   A. A string of code that enables XML compatibility.
   B. The path name that refers to where a command is located in the program.
   C. Another name for the title bar.
   D. The command center that replaces menus and toolbars of previous versions.

4. You access database objects using the Navigation Pane. (True or False?)

5. The related fields for each person, place, or thing make up a single _______.
   A. Record
   B. Table
   C. Column
   D. Field

6. To add a new record to a table, you can simply click in the New record row and enter the data. (True or False?)

7. You can view records in a form; however, you cannot change them in any way. (True or False?)

8. A query would be suitable for which of the following?
   A. Displaying invoices that are more than 30 days old.
   B. Calculating last year’s sales
   C. Adding records to a table.
   D. All of these tasks.

9. Which of the following statements is NOT true?
   A. Reports present information from a table or query in printed form.
   B. Reports make it easy to add table information.
   C. You can edit a report’s structure.
   D. You can zoom in and out of a report.

10. Once you have selected some text, you can replace it with new text by:
    A. Simply typing the new text.
    B. Clicking the New Text button on the Home tab.
    C. You can’t replace selected text with new text.
D. Clicking the Replace Text button in the Navigation Pane.

11. To use the Zoom box, select the field you want to zoom and _________.  
   A. Press Shift + F4.  
   B. Press Shift + F2  
   C. Click the Zoom button on the Quick Access Toolbar.  
Quiz Answers

1. D. A database allows you to do all of these functions.
2. D. SmartArt is not a new feature in Access 2013.
3. D. The Ribbon is the command center that replaces menus and toolbars of previous versions.
4. True. You use the Navigation Pane to access database objects.
5. A. The related fields for each individual person, place, or thing make up a single record.
6. True. If the New row is visible at the bottom of the window, simply enter your data.
7. False. You can view, add, edit, and delete records in a form.
8. D. Queries can do all of these tasks.
9. B. You can view table information, but you can't add, edit, or change it.
10. A. Simply type the new text to replace any selected text.
11. B. Press Shift + F2 to zoom in on the field.
Creating and Working with a Database

Planning a Database ................................................. 27
Creating a New Database ........................................ 29
  Create a database from a template ........ 29
  Create a database from a template ........ 29
  Create a new blank database .............. 30
Creating a Table ...................................................... 31
  Create a table using a template .......... 31
  Create a table in Design View ............ 32
  Create a table in Datasheet View ........ 32
Modifying a Table ................................................... 33
  Display a table in Design View .......... 33
  Add a field in Design View ............... 33
  Change a field’s data type ............... 33
  Save table structure changes .......... 33
Creating a Query ................................................... 35
  Create a query in Design View .......... 35
Sorting a Query ...................................................... 37
Using AND and OR Operators in a Query ...... 38
Creating a Form with the Form Wizard ........ 39
Creating a Report with the Report Wizard ...... 41
Creating Mailing Labels with the Label Wizard .............................................. 43
Converting an Access Database ................. 45
  Convert a database to Access 2013 .... 45
  Convert from Access 2013 to an earlier file format ........................................ 46

Stop typing lists of information in Microsoft Word or Excel! In this chapter, you will learn how to create databases that can store names, addresses, and any other type of information that you can think of. You will be pleasantly surprised to find that creating a database isn’t all that difficult. Access even includes several wizards and templates to help you out.

Because there are so many components that constitute a database, this chapter will cover a lot of ground—but thankfully not in great detail. In this chapter, you will learn to Create and modify the major database objects: Tables, forms, queries, and reports. You will also learn how to create mailing labels and how to convert a database to a different version.

If all you need is a simple, easy-to-use database, look no farther than this chapter—more than likely, everything you need to know about creating databases is here.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Planning a Database

Although you can always make changes to a database, a little planning ahead before you create a database can save you lots of time and headaches later on.

Consider Figure 2-1: Examples of database Design. In the first table you can only sort by the name or address field. If you sort the name field, the sort is performed by the first name. If you sort by the address field, the sort is performed by the street—you cannot sort by city, state, or zip code. You couldn’t create a query or filter that only displays people from a particular state because the states are not stored in their own field. The Fields are not flexible.

Now take a look at the second table. Here you can sort records by first name, last name, address, city, state, and zip code. You can also query and filter records using any of these Fields. Here are some guidelines for creating a well-Designed database:

- **Determine the purpose of the database**
  
The best way to do this is to write down a list of the reports and lists that you want to come out of the database. This may seem a little backward at first, but if you think about it, these reports are really the reason you’re creating the database. Make a list of the reports and lists you want to see and then sketch some samples of these reports and lists—be as detailed as possible. This will help determine the Tables and Fields to include in your database.

- **Determine the Fields you need**
  
  This should be an easy step once you have determined the purpose of your database and have sketched some sample reports and lists. Think about the data type for each type of your Fields - Will the field store text information? Numbers? Dates? Write down the data type next to each field.

- **Determine the Tables you need**
  
  Each table in the Database should be based on only one subject. By breaking each subject into its own table you avoid redundant information and make the database more organized. Look at the second database in Figure 2-1: Examples of database Design. It is broken down into two Tables, Customers and Invoices, so there isn’t any duplicated data. When you brainstorm, try to break down your information as much as possible. If your Tables contain Fields like Item 1, Item 2, Item 3, Item 4, and so on, you should probably break the information up into its own table.
Creating and Working with a Database

- **Determine the primary key**
  Each record in a table should have a primary key that uniquely identifies it. When you think about a primary key field, think unique—each primary key value must be the only one of its kind in a table. A customer ID or invoice number would be two good examples of fields that could be used as a table’s primary key.

- **Determine the relationship between Tables**
  Look at Figure 2-1: Examples of database Design. The ID field links the Customers and Invoices Tables together. One of the linked fields should be the table’s primary key.

- **Sketch a diagram of your database**
  Create a diagram of your database. Draw a box for each of your Tables and write the table’s field names inside that box. Draw a line between the related fields in the tables. For example, look at Figure 2-1: Examples of database Design. Each record in the Customers table is related to one or more records in the Invoices table.

---

### Table 2-1: Guidelines for Good Database Design

<table>
<thead>
<tr>
<th>Guideline</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Each field or column should contain the same type of information</td>
<td>This makes the table more meaningful, more organized, and easier to understand.</td>
</tr>
<tr>
<td>Try to break up information as much as possible</td>
<td>This gives you more power to sort, filter, and manipulate the list.</td>
</tr>
<tr>
<td>Use multiple Tables so that you don’t duplicate information in the same table</td>
<td>Organize your information into several Tables—each one containing fields related to a specific subject—rather than one large table containing fields for a wide range of topics.</td>
</tr>
<tr>
<td>Don’t use duplicate field names</td>
<td>Duplicate field names can cause problems when entering and sorting information.</td>
</tr>
</tbody>
</table>
Creating a New Database

When you start Access, you are provided with a range of options to suit your needs. The three most popular are:

- **New Blank Database**: Create a new blank database from scratch for storing information.
- **Templates**: Select a template stored locally on your computer or from Office Online. Several categories of templates are available, including: Assets, Contacts, Business, Projects and Sales. Within the categories are different types of templates—for example: Assets, Contacts, and Projects.
- **Recent Database**: Open an existing database from a list of recently opened databases or click **Computer** to browse your computer or network for more existing databases.

In this lesson, we'll look at how to create a new database from a template, as well as from scratch.

**Create a database from a template**

The easiest way to create a database is by using one of the built-in database templates. A database template saves you time and effort, providing you with ready-to-use Tables, forms, queries, and reports. There are templates available for the most common types of databases, such as contact management, inventory, and order taking. Once you create a database with an Access template you can modify it to better suit your needs.

1. Once Access is open, click one of the options next to **Suggested search** below the Search box.
   
   The templates for that category appear on the page.

2. Click **template** button for the template you want to use.

   A window appears with more information about the database.

   ✔️ **Tip**: Here you can give the new File a name of your choosing. Access displays the File path to the location where your File will be saved, but you can change the location.

3. Click the **Create** button.

   ✔️ **Tip**: If the template isn’t available locally, it will be automatically downloaded.

   The database appears in the window.
Create a new blank database

The advantage of creating a blank database is that it gives you the most flexibility and control over your database design. The disadvantage of creating a blank database is that you have to create every table, form, report, and query yourself.

1. Once Access is open, click the Blank desktop database button in the Available Templates section.
   - **Trap:** You may need to expand your window to see the Blank desktop database button.
   The right side of the screen changes to display information about creating a blank database.
   - **Other Ways to Create a New Blank Database:** Click the File tab and select New.

2. Enter a name for the new database File in the File Name text box.
   Access displays the File path to the location where your file will be saved, but you can change the location.

3. Click the Create button.
   Access creates a new blank database and creates a single blank table where you can start storing data.

**Figure 2-5:** Creating a new blank database.

**Figure 2-6:** A new blank database.
Creating a Table

In Access 2013 you have a number of options when creating Tables. You can create a new blank table from scratch or set up Tables that are connected to SharePoint lists. If you use one of the Quick Start options in the Application Parts to Create a new database, Tables with predefined Fields will be Created.

Create a new blank table

Creating a new blank table allows you to immediately start entering your data into the table.

1. Click the Create tab on the Ribbon and click the Table button in the Tables group.

   The table appears in the window in Datasheet View. In this view, you can start entering data right away. However, it’s usually smart to first add some Fields using the Field Templates pane. The Field Templates pane contains many common Fields that are pre-formatted with the correct data type.

2. To add a new field, click the Click to Add field heading and select the field type for the list that appears.

3. Once you have selected the field type, the new field will automatically be named in numerical order – Field1, Field2, Field3, etc.

   The field name will be selected – simply type in a new, more appropriate name for your data field.

4. Click in the field to enter the correct data for this particular field, or click the next Click to Add field heading to add another field.

Tips

✓ Another method to add a new field is to go to Table Tools and select the Fields tab. In the Add & Delete group, select the appropriate data type for that field. The new field will be added to the left of the currently selected field.

Tips

✓ To change the name of a field header, double-click the field header and type the field name you want to use.

Exercise

• Exercise File: None required.
• Exercise: Open a new blank database and name it Contact List. Create a table in Datasheet View and name the first field Last Name. Create a second table in Design View and add the Last Name field using the Field Templates pane. Close the table you made and save it with the name “Contacts”. Close the rest of the Tables without saving. Close the database.

Create a table...

…in Datasheet View.
…in Design View.
…using SharePoint Lists

Figure 2-7: Creating a table in Datasheet View.
Create a table in Design View

The most straightforward way to build a table from scratch is using Design View, where adding Fields to a table and specifying their data types is not much different than basic data entry.

1. Click the Create tab on the Ribbon and click the Table Design button in the Tables group.

   A new table appears in the window in Design View. Now all you have to do is add the Fields you want included in the table.

2. Enter a field name in the Field Name column. In the Data Type column click in the cell that corresponds to the Field Name you are working on and select the data type from the drop-box. Repeat as necessary.

Create a SharePoint list table

SharePoint lists can be created within Access 2013. To do this, you need to have an existing SharePoint site that you can add the SharePoint list to.

1. Click the Create tab on the Ribbon and click the SharePoint Lists button in the Tables group.

2. Select the relevant type of list you want to Create: Contacts, Tasks, Issues or Events.

   Select Custom if you wish to specify your own Fields or choose Existing SharePoint List if you want to link to a list that has previously been Created on the SharePoint site.

3. Enter the SharePoint URL address, a name for the new list and any further information before clicking OK.
Modifying a Table

Once you have Created a table, you can modify it later by adding, deleting, and modifying its Fields.

In this lesson, we’ll look at how to work with views, Fields and data types.

Display a table in Design View

1. Open the table in Datasheet View. Click the Home tab on the Ribbon and click the View button in the Views group. Select Design View.

Other Ways to Do Something:
Right-click the table in the Navigation Pane and select Design View from the contextual menu.

The table appears in Design View. Here you can add, delete, or modify the table’s structure and Fields.

Add/modify a field in Design View

1. In Design View, enter or edit a field name in the Field Name column, click in the Data Type column for that row, click the Data Type list arrow and select a data type for the field. Repeat as desired.

Change a field’s data type

Because there are so many different types of data, Access offers several different types of Fields. A field’s data type determines the type of information that can be stored in a field. A field’s data type restricts what type of information you can enter in a field. For example, you cannot enter text into a number field.

1. Display the table in Design View.

2. Click the field’s Data Type box, click the list arrow, and select a data type from the list.

The table on the following page provides descriptions of the different data types.

Other Ways to Modify a Table:
You can add Fields and change data types in Datasheet view by using the Add & Delete options on the Fields tab under Table Tools.

Save table structure changes

Access automatically saves your work as you add or edit data, but when you make a change to an object’s structure—such as adding a field to a table—you’ll need to save the change.
1. Click the **Save** button on the Quick Access Toolbar.

   **Tip:** If you try to leave the window before saving, Access will prompt you to save your work. Click **YES**.

   **Other Ways to Save:**
   Press `<Ctrl>` + `<S>`.

---

### Table 2-2: Table Field Data Types

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text</strong></td>
<td>Legal Name: John Doe</td>
<td>Stores text, numbers, or a combination of both, up to 255 characters long. Text Fields are the most common of all data types.</td>
</tr>
<tr>
<td><strong>Memo</strong></td>
<td>Notes: Sally displays a high amount of…</td>
<td>Stores long text entries—up to 64,000 characters long (the equivalent of 18 pages of text!). Use memo Fields to store notes or anything else that requires a lot of space.</td>
</tr>
<tr>
<td><strong>Number</strong></td>
<td>Age: 31</td>
<td>Stores numbers that can be used in calculations.</td>
</tr>
<tr>
<td><strong>Date/Time</strong></td>
<td>Birthday: April 7, 1969</td>
<td>Stores dates, times, or both.</td>
</tr>
<tr>
<td><strong>Currency</strong></td>
<td>Price: $84.95</td>
<td>Stores numbers and symbols that represent money.</td>
</tr>
<tr>
<td><strong>AutoNumber</strong></td>
<td>Invoice Number: 187001</td>
<td>Automatically fills in a unique number for each record. Many Tables often contain an AutoNumber field that is also used as their primary key.</td>
</tr>
<tr>
<td><strong>Yes/No</strong></td>
<td>Employed? Yes</td>
<td>Stores only one of two values, such as Yes or No, True or False, etc.</td>
</tr>
<tr>
<td><strong>OLE Object</strong></td>
<td>Photo:</td>
<td>Stores objects Created in other programs such as a graphic, Excel spreadsheet, or Word document.</td>
</tr>
<tr>
<td><strong>Hyperlink</strong></td>
<td>Web Site: <a href="http://www.customguide.com">www.customguide.com</a></td>
<td>Stores clickable links to Files on your computer, on the network, or to Web pages on the Internet.</td>
</tr>
<tr>
<td><strong>Attachment</strong></td>
<td>Document: Microsoft Word document with related data.</td>
<td>Stores attachments such as a Word document or photo.</td>
</tr>
<tr>
<td><strong>Calculated</strong></td>
<td>Monthly Payments: $1485.50</td>
<td>Automatically calculates a value based on the formula entered in the Expression Builder when first selecting this data type.</td>
</tr>
<tr>
<td><strong>Lookup Wizard</strong></td>
<td>Purpose of trip:</td>
<td>A wizard that helps you Create a field whose values are selected from a table, query, or a preset list of values.</td>
</tr>
</tbody>
</table>
Creating a Query

You can create a simple query in Design View or by using the Query Wizard.

Create a Query in Design View

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.

The Show Table dialog box appears.

Other Ways to Create a Query:
You can also use the Query Wizard to Create a query. Click the Create tab on the Ribbon and click the Query Wizard button in the Queries group. Follow the onscreen instructions to create the query.

2. Select the table you want to add to the query and click Add.

3. Repeat Step 2 as necessary for additional Tables or queries, and click Close.

The Query window appears in Design View. Notice that the window is split. The top half contains a box that displays all the Fields in the table you added to the query. The bottom half of the screen contains a Design grid, which is where you will add the Fields you want to appear in your query.

4. In the field list, double-click each field you want to include in the query.

Often you will have to use the field list’s scroll bar to scroll up or down the list in order to find a field.

Now you need to specify any criteria for the query. You enter the criteria in the Design grid’s Criteria row. For example, you could select to see only records whose City field contains “London”, or you could enter K* to return only results that begin with K.

Table 2-3: Common Criteria Operators displays some common criteria operators you can use.

Other Ways to Add a Field to a Query:
Drag the field from the field list onto the Design grid.

5. In the Design grid, enter any desired search criteria for the field in the Criteria box.

Tip: If you want to use a field in the query, but you don’t want it to be displayed in the query results, uncheck the Show box for that field.

Exercise

- Exercise File: Customers.accdb
- Exercise: Create a new query in Design View to display the first and last name of those employees who are from London. Add the Employees table in the Show Table dialog box. Add the LastName, FirstName, and City Fields to the Design grid. Type “London” in the City column’s criteria row. Click the Show box for the City column to uncheck it. Save the query as “London Query”. Run the query. Display the query again in Design View. Delete the City column and add the Region column. Type “WA” in the Region column’s criteria row. Move the FirstName field in front of the LastName field. Run the query again. Close the query without saving the changes.
6. Click the **Save** button on the Quick Access Toolbar, enter a name for the query in the **Save As** dialog box and click **OK**.

The query is saved and now appears in the Navigation Pane.

Let’s run the query.

7. Click the **Design** tab under Query Tools on the Ribbon and click the **Run** button in the Results group.

The query runs and the results appear in Datasheet View.

**Other Ways to Run a Query:**
Switch to **Datasheet View**.

**Tips**

✓ To delete a query field in Design View, click the top of the field you want to delete and press `<Delete>`.

✓ To rearrange Fields in Design View, click just above the field name in the Design grid to select the field. Then click and drag the field to a new location.

### Table 2-3: Common Criteria Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>=</code></td>
<td>&quot;MN&quot;</td>
<td>Finds records equal to MN.</td>
</tr>
<tr>
<td><code>&lt;&gt;</code></td>
<td>&lt;&gt;&quot;MN&quot;</td>
<td>Finds records not equal to MN.</td>
</tr>
<tr>
<td><code>&lt;</code></td>
<td>&lt;10</td>
<td>Finds records less than 10.</td>
</tr>
<tr>
<td><code>&lt;=</code></td>
<td>&lt;=10</td>
<td>Finds records less than or equal to 10.</td>
</tr>
<tr>
<td><code>&gt;</code></td>
<td>&gt;10</td>
<td>Finds records greater than 10.</td>
</tr>
<tr>
<td><code>&gt;=</code></td>
<td>&gt;=10 AND &lt; &gt;5</td>
<td>Finds records greater than or equal to 10 and not equal to 5.</td>
</tr>
<tr>
<td><strong>BETWEEN</strong></td>
<td>BETWEEN 1/1/07 AND 12/31/07</td>
<td>Finds records between 1/1/07 AND 12/31/07.</td>
</tr>
<tr>
<td><strong>LIKE</strong></td>
<td>LIKE &quot;S**&quot;</td>
<td>Finds text beginning with the letter “S.” You can use LIKE with wildcards such as &quot;.&quot;</td>
</tr>
</tbody>
</table>
Sorting a Query

Tables normally display records in the order they were entered. Instead of working with a table’s jumbled record order, you can create a simple query that sorts the table information and presents it in an ordered, easy-to-read display. You can sort records alphabetically, numerically, or chronologically (by date) in ascending (A to Z) or descending (Z to A) order. You can also sort by multiple Fields—for example, you could sort by LastName and then by FirstName. This lesson will show you how you can use a query to sort information in a table.

1. Display the query in Design View.

2. Add the field you want to use to sort the query to the Design grid, along with any other Fields you want to appear in the query results.

   ✓ Tip: Double-click the asterisk (*) at the top of a field list to add all the table’s Fields to the Design grid at once.

   To sort a query, click the Sort row for the field you want to use to sort the query and select either Ascending or Descending.

3. Click the Sort row of the field you want to use to sort the query. Click the arrow and a list of sort orders will appear. Click the one you want to use to sort the query.

4. Repeat Steps 2-3 for each additional field you want to use to sort the query, bearing in mind that the Fields will be sorted from left to right.

   ✓ Tip: If you want to use a field to sort the table, but you don't want that field to appear, you can uncheck its Show box.

5. Save and run the query.

Exercise

- Exercise File: Customers.accdb
- Exercise: Create a new query in Design View to sort employee information. Use the Employees table. Double-click the asterisk (*) in the Employees field list to add all the Fields to the Design grid. Then add the LastName and FirstName Fields to the Design grid separately (we’ll be using them to sort the query). Click the list arrow in the LastName field’s Sort box and select Ascending. Repeat for the FirstName field. Uncheck the Show box for the LastName and FirstName Fields. Save the query as “AZ Query” and run the query.
Using AND and OR Operators in a Query

The longer you work with Access, the more you will want to analyze your data. Before long you will want to Create queries that match two or more conditions, such as “Which people have bought our products AND live in Michigan?” You might also want to Create a query that matches only one of several conditions, such as “Which people have bought our beach balls OR water rafts?

To that end, this lesson introduces AND and OR operators:

- **AND** narrows your query, making it more restrictive. For example, you could filter for employees who are from Washington AND who have been with the company for more than five years. To Create an AND query, enter the criteria for the Fields on the same Criteria row of the Design grid.

- **OR** relaxes your query, so that more records match. For example, you could filter for employees who are from California OR Minnesota. To Create an OR query, enter the criteria for the Fields on different Criteria rows of the Design grid.

Use AND or OR criteria in queries

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Exercise**

- **Exercise File**: Customers.accdb
- **Exercise**: Open the Customers List query in Design View. Let’s query the customers who are owners AND from France. Click the **ContactTitle** column’s Criteria row and type “Owner”. Click the **Country** column’s Criteria row and type “France”. Run the query. Now let’s query customers from France OR Mexico. In Design View, delete the “Owner” criteria from the **ContactTitle** column’s criteria row. In the **Country** column, click the second criteria row (OR) and type “Mexico”. Run the query. Save the query.

**Use AND or OR criteria in queries**

- **AND** narrows your query, making it more restrictive. For example, you could filter for employees who are from Washington AND who have been with the company for more than five years. To Create an AND query, enter the criteria for the Fields on the same Criteria row of the Design grid.

- **OR** relaxes your query, so that more records match. For example, you could filter for employees who are from California OR Minnesota. To Create an OR query, enter the criteria for the Fields on different Criteria rows of the Design grid.

**Exercise**

- **Exercise File**: Customers.accdb
- **Exercise**: Open the Customers List query in Design View. Let’s query the customers who are owners AND from France. Click the **ContactTitle** column’s Criteria row and type “Owner”. Click the **Country** column’s Criteria row and type “France”. Run the query. Now let’s query customers from France OR Mexico. In Design View, delete the “Owner” criteria from the **ContactTitle** column’s criteria row. In the **Country** column, click the second criteria row (OR) and type “Mexico”. Run the query. Save the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Exercise**

- **Exercise File**: Customers.accdb
- **Exercise**: Open the Customers List query in Design View. Let’s query the customers who are owners AND from France. Click the **ContactTitle** column’s Criteria row and type “Owner”. Click the **Country** column’s Criteria row and type “France”. Run the query. Now let’s query customers from France OR Mexico. In Design View, delete the “Owner” criteria from the **ContactTitle** column’s criteria row. In the **Country** column, click the second criteria row (OR) and type “Mexico”. Run the query. Save the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Exercise**

- **Exercise File**: Customers.accdb
- **Exercise**: Open the Customers List query in Design View. Let’s query the customers who are owners AND from France. Click the **ContactTitle** column’s Criteria row and type “Owner”. Click the **Country** column’s Criteria row and type “France”. Run the query. Now let’s query customers from France OR Mexico. In Design View, delete the “Owner” criteria from the **ContactTitle** column’s criteria row. In the **Country** column, click the second criteria row (OR) and type “Mexico”. Run the query. Save the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.

**Use AND or OR criteria in queries**

1. Display the query in **Design View**.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND**: Enter additional criteria for one or more Fields in the appropriate field’s Criteria box. All AND criteria should appear on the same row.
   - **OR**: Enter additional criteria for one or more Fields in the appropriate field’s OR box, using a different row for each OR criteria.
4. Save and run the query.
Creating a Form with the Form Wizard

You will usually want to use the Form Wizard to create your forms. It’s almost always easier to Create and modify a form Created by the Form Wizard than it is to Create one from scratch. This lesson will show you how to use the Form Wizard to Create a form.

1. Click the Create tab on the Ribbon, and then click the Form Wizard icon in the Forms group.

   The Form Wizard appears. Anytime you create a form, you have to tell Access which table or query you want to use for your form.

2. Click the Tables/Queries list arrow and select the table or query you want to use to Create your form.

   Now that you have specified the table, you need to tell the Wizard which Fields you want to display on the form. To add a field to the form, you can either double-click the field or select the field and click the right arrow button.

3. Double-click the Fields that you want to appear on the form. Click Next.

   Tip: If you selected Fields from more than one table, the Form Wizard would ask how you would like to organize the data on your form (Columnar, Tabular, Datasheet or Justified). Make a selection and click Next.

   Next the Form Wizard asks how you want to lay out the data on the form. Your options will depend on what Fields and Tables you’re using, but may include these options:

   • **Columnar**: Displays one record at a time in an easy-to-read format.
   • **Tabular**: Displays many records at a time.
   • **Datasheet**: Displays many records at a time and looks exactly like a table in Datasheet view.
   • **Justified**: Displays one record at a time in a format similar to a tax return—interesting, but it usually creates complicated forms that are difficult to work with.

4. Select the layout you want to use for the form and click Next.

---

Exercise

- **Exercise File**: Customers.accdb
- **Exercise**: Use the Form Wizard to create a form with the Employees table. Add the **LastName**, **FirstName**, **Title**, **Address**, **City**, **Region**, **PostalCode**, and **Country** Fields to the report. Leave the **Columnar layout** option selected and name the form “**Employees Form**”. View the form.

---

Exercise

- **Exercise File**: Customers.accdb
- **Exercise**: Use the Form Wizard to create a form with the Employees table. Add the **LastName**, **FirstName**, **Title**, **Address**, **City**, **Region**, **PostalCode**, and **Country** Fields to the report. Leave the **Columnar layout** option selected and name the form “**Employees Form**”. View the form.
5. Enter a title for your form in the text box and select to either open the form or modify the form’s Design. Click Finish.

The form appears in the window. In the form, you can add, edit, and delete records, just like in a table—except that you usually only see one record at a time.

Figure 2-18: A form Created with the Form Wizard.
Creating a Report with the Report Wizard

It’s almost always easier to Create and modify a report Created by the Report Wizard than it is to Create one from scratch.

1. Click the Create tab on the Ribbon and click the Report Wizard icon in the Reports group.

2. Click the Tables/Queries list arrow and select the table or query you want to use to create your report.
   
   Now that you have specified the table, you need to tell the Wizard which Fields you want to display on the form. To add a field to the form, you can either double-click the field or select the field and click the right arrow button.

3. Double-click the Fields that you want to appear on the form. Click Next when you’re finished.

   Tip: If you selected Fields from more than one table, the Form Wizard would ask how you would like to organize the data on your form. Make a selection and click Next.

   Then the Report Wizard asks you if and how you want to group the data in your report. For example, you can group all the customers from the same country together in your report. Grouping can help organize and summarize the information in your report. To use a specific field to group data, double-click the field you want to use.

4. Double-click any Fields you want to group, in the order you want to group them. Click Next.

   Tip: Once you’ve added Fields to group by, you can move them around by using the Priority arrow buttons.

   Next the Report Wizard asks if you want to sort the records in your report.

5. Click the list arrows and select Fields to sort by and click Next.

   You can sort by up to four Fields.

   Tip: Click the button to the right of each list to toggle between Ascending and Descending sort orders.
Creating and Working with a Database

Now the Report Wizard asks how you want to lay out the data on the report. You can also specify the page orientation here. Layout options Stepped, Block and Outline. You can select a Layout option to preview it.

6. Select a Layout option and an Orientation option for the report. Click Next.

Finally, you need to give the report a name.

7. Enter a name in the text box and select whether you want to preview the report or modify its Design. Click Finish.

If you chose to preview the report, it appears in Print Preview view. If you chose to modify the report, it appears in Design View, where you can make changes to its structure.

Figure 2-22: A report Created with the Report Wizard.
Creating Mailing Labels with the Label Wizard

For bulk mailings, nothing beats a good stack of mailing labels. The Access Label Wizard helps you quickly create labels using data from your Access database. The Label Wizard supports a huge variety of label sizes and brands. In this lesson, you will use the Label Wizard to create a set of mailing labels.

1. Open the table or query that contains the data for your labels.
   For example, a Contacts table that contains names and addresses is a common table for making labels.

2. Click the Create tab on the Ribbon and click the Labels icon in the Reports group.
   The Label Wizard dialog box appears, listing the various types of labels by product number. Simply scroll down and find the number that matches the one on your label box.
   Tip: If you can’t find your label type, click the Customize button and tell the Label Wizard how to set up your nonstandard labels.

3. Click the Filter by manufacturer list arrow and select your label’s manufacturer, then select the correct label size from the list. Click Next.
   The next window of the Label Wizard lets you change the font used in your label. You can format the font type, size, weight, and color. If you’re satisfied with the default font (Arial 8 point), you can simply click Next.

4. Select the font and font formatting options you want to use for your label and click Next.
   It’s time to tell the Label Wizard which Fields you want to use.
   If you want to place Fields on separate rows, you’ll need to press <Enter> in the Prototype label area to move to the next row before inserting the field.
   Also, if you want certain text to appear on every label—such as comma between the city and state—you can type the text in the Prototype label area.

5. Select each field you want to use from the list and click the arrow button. Click Next.
   Next you can determine the order of your labels by sorting.

Exercise

- **Exercise File:** Customers.accdb
- **Exercise:** Use the Labels Wizard to Create labels using the Customers table. Open the Customers table. Select the default label size, font and color. Add the ContactName, CompanyName, and Address Fields on separate lines of the prototype label. On the next line down, enter the City, Region, and PostalCode Fields. Separate the City and Region with a comma and add necessary spaces between the Fields. Sort the labels by PostalCode and name the label report “Customer Labels”. View the labels on the screen.
6. Select the field you want to sort by from the list and click the right arrow button to add it to the Sort by area. Click Next.

✔ Tip: You can sort by multiple Fields if desired. Finally, you can give your label report a name (when you’re making labels, you’re really just creating a report).

7. Enter a name in the text box and select whether you want to preview the report or modify its Design. Click Finish.

If you chose to preview the report, it appears in Print Preview view. If you chose to modify the report, it appears in Design View, where you can make changes to its structure.

The labels report is saved for you. You can now print the labels at any time by simply loading the printer with labels and printing the report.

Figure 2-25: Labels Created with the Label Wizard.
Converting an Access Database

If you’re working with a database created in a previous version of Access (.mdb), you can convert it to the 2013 File format (.accdb) to take advantage of the new features.

On the other hand, if you’ve created a database with the Access 2013 File type (.accdb), but you want to share it with people using earlier versions of Access, you can usually convert it to an earlier File format by saving it as a different File type.

In this lesson, we’ll look at both scenarios.

Convert a database to Access 2013

To convert a File to the Access 2013 format, you need to open the File in Access 2013 and Save As with the 2013 File format.

⚠️ Trap: An Access 2013 File (.accdb) can only be opened in Access 2013 and not earlier versions of Access so make sure everyone who uses the File is running the correct version before you convert it.

1. In Access 2013, click the File tab and click Open.
   The Open dialog box appears. Here you need to select the database you want to convert to Access 2013 format.

2. Select the database you want to convert and click Open.
   ⚠️ Trap: If you see the Database Enhancement dialog box, the database is in a File format earlier than Access 2013. See the Access Help Files for help converting this type of File.
   The database opens.

3. Click the File tab, click Save As, click Save Database As and select the Access Database (.accdb) File format.

4. Click the Save As button.
   ✔️ Tip: If you have any open database objects, you’ll see a message telling you to close them. Click Yes. If Access is unable to convert the File, you’ll also see that message at this point.
   The Save As dialog box appears.
5. Enter a name for the database in the **File name** box and click **Save**.

A copy of the database is made and the copy is opened. The original database is closed.

**Convert from Access 2013 to an earlier File format**

**Trap:** Not all Access 2013 files can be converted to an earlier format. If the database contains new 2013 features such as attachments, multi-valued Fields, offline data, or links to some external files, Access may not be able to convert the file.


1. Open the Access 2013 File you want to convert, click the **File** tab, click **Save**, and select the **Access 2002 – 2003 Database (.mdb)** or **Access 2000 Database (.mdb)** File format in the **Save Database As** area.

2. Click the **Save As** button.

The **Save As** dialog box appears.

3. Enter a name for the database in the **File name** box and click **Save**.

The Access 2013 database is closed and the converted File opens. The original database still exists—since all you did is save a copy in a different format—but must be opened separately.
Creating and Working with a Database Review

Quiz Questions

1. You should always plan the design and structure of a database before you begin creating it. (True or False?)

2. Once you create a database with an Access template you can modify it to better suit your needs. (True or False?)

3. Which of the following is not a pre-made template for creating a table in Access?
   A. Contacts
   B. Tasks
   C. Issues
   D. Notes

4. Which of the following determines the type of information that can be stored in a field?
   A. A data type
   B. A field size
   C. A primary key
   D. An index property

5. You cannot add a field to a query without displaying the field in the query results. (True or False?)

6. You want to sort a query by a table’s Last Name field. In order to do this, the Last Name field MUST appear in the displayed results of the query. (True or False?)

7. To specify OR criteria in a query, enter everything on the same criteria row. (True or False?)

8. What is the first step in creating a form with the Form Wizard?
   A. Selecting how the form should be formatted.
   B. Reading several screens of mostly useless information and clicking Next.
   C. Selecting the underlying table or query on which you want to base the form.
   D. Selecting the fields you want to appear in the form.

9. The Report Wizard button is found in the ______ group on the Create tab on the Ribbon.
   A. Wizards
   B. Reports
   C. Labels
   D. Documents

10. Microsoft Word is required to print mailing labels with Access. (True or False?)

11. Access 2007 databases use the same file format as Access 2013 databases. (True or False?)
## Quiz Answers

1. True. You should always plan before creating a database.
2. True. You can easily modify a database created from a template.
3. D. Notes is not a table template in Access.
4. A. A data type determines the type of information that can be stored in a field.
5. False. You can include a field in a query without displaying it in the query results by unchecking its Show box.
6. False. You can sort the results of a query without displaying the field you used to sort the query.
7. False. To specify OR criteria, enter it on a different row.
8. C. Selecting the underlying table or query.
9. B. The Report Wizard button is found in the Reports group.
10. False. The Label Wizard is included in Access and makes creating labels easy.
11. False. Access 2013 databases use a new file format, but you can convert previous versions to the new format.
Finding, Filtering, and Formatting Data

Finding and Replacing Data ................................. 50
  Find and Replace ........................................ 50
Sorting Records .............................................. 52
  Sort records .............................................. 52
  Clear a sort .............................................. 52
Using Common Filters ..................................... 53
  Apply a common filter .................................. 53
  Clear a filter ............................................. 54
Filtering by Selection ..................................... 55
Filtering by Form .......................................... 56
Creating an Advanced Filter ............................... 57
Adjusting and Rearranging Rows and Columns ......... 59
  Adjust column width .................................... 59
  Adjust row height ....................................... 59
  Automatically adjust columns ......................... 59
  Rearrange columns .................................... 60
Changing Gridline and Cell Effects ....................... 61
  Change gridlines ....................................... 61
  Apply background colors ............................... 61
  Apply cell effects ..................................... 62
Changing the Datasheet Font .............................. 63
Freezing a Column ......................................... 64
Hiding a Column ........................................... 65

As databases grow larger and larger, finding a specific record or group of records becomes harder and harder. Fortunately, Microsoft Access is equipped with an arsenal of Find, Sort, and Filter commands that can track down and organize a table’s information in record time.

In this chapter you will learn how to use these commands. First, you’ll learn how to use the Find command to look up a specific record. Next, you’ll learn how to sort information in a table—in ascending or descending order. Then, you’ll learn all about filters: How they can find and display only records that meet your criteria, such as customers from the state of Texas.

Once you’ve learned how to organize and sort all that information, you’ll learn how to make it look more professional. This chapter explains how to format a datasheet to change its font and appearance. You will also learn how to freeze and hide columns in a datasheet—an important task if you need to view large amounts of information.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Finding and Replacing Data

Although you can use a query to find data, sometimes you just want to quickly find a small amount of data. The Find feature allows you to quickly search Tables, queries, and forms for specified text. You can also use the Replace command to quickly find and Replace data.

The Find command in Access is similar to the Find command in other Office programs, but it contains some additional features as well. For example, you can choose to match part or all of the data in a field.

Find and Replace

The Find and Replace commands make it very easy to find and Replace specific words and values in your Tables. You can also find and Replace information in forms and find information (but not replace) in queries.

For these steps, we’ll assume you are working in a table’s datasheet. First, you need to put the cursor in the field that contains the data you want to look for.

1. Select the column header for the field you want to search or click in any cell in the field you want to search.

   **Tip:** If you want to search the entire table, click in any cell. Once you open the Find and Replace dialog box, click the **Look In** list arrow and select **Current** document.

2. Click the **Home** tab on the Ribbon and click the **Find** button in the Find group.
   
The Find tab of the Find and Replace dialog box appears.

   **Other Ways to Find:**
   Press `<Ctrl> + <F>`.

3. If you want to replace data, click the **Replace** tab.
   
The Replace tab is displayed.

   **Other Ways to Replace:**
   Press `<Ctrl> + <H>`.

4. Type the text or value you want to find in the **Find what** text box.

   **Exercise**
   - **Exercise File:** EmployeeList.accdb
   - **Exercise:** Open the Employees table. Find “Redmond” in the **City** field. Then, in the **Title** field, find and Replace all instances of “Sales Representative” with “Sales Associate”.

   **Figure 3-1:** The Find tab of the Find and Replace dialog box.

   **Figure 3-2:** The Replace tab of the Find and Replace dialog box.
5. If desired, enter the Replacement text or value in the Replace With box. 
Next, you have a few optional changes you can make to the search.

6. If desired, click the Match list arrow and select an option.
The Match options allow you to broaden or narrow your search. See Table 3-1: Using the Match List Options for a description of the Match options.

7. If desired, check the Match Case box.
If you check the Match Case box, Access finds only text that has the same pattern of uppercase and lowercase characters as the text you entered.

8. Make sure the Search Fields As Formatted box is checked and click the Find Next button.
Access jumps to the first occurrence of the text or value that you entered.

9. Click the Find Next button again to move on to other occurrences or click Replace or Replace All if you want to replace the data. When you're finished, click Close.

Tips
✓ Finding or replacing data in a form works the same way as in a table, except that you select controls to search instead of Fields. When you use the Find command in a form, Access is actually searching the underlying table.
✓ You can find, but not Replace, data in query results.
✓ To find wildcard characters, type an opening bracket ([), the wildcard character you want to find, and a closing bracket (]) in the Find What box. For example, you would type [+] to find all instances of an asterisk.

<table>
<thead>
<tr>
<th>Table 3-1: Using the Match List Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole Field</td>
</tr>
<tr>
<td>Example: John finds John, but not Johnson, or Sue and John.</td>
</tr>
<tr>
<td>Any Part of Field</td>
</tr>
<tr>
<td>Example: John finds John, Johnson, and Sue and John.</td>
</tr>
<tr>
<td>Start of Field</td>
</tr>
<tr>
<td>Example: John finds John and Johnson, but not Sue and John.</td>
</tr>
</tbody>
</table>
Sorting Records

When you enter new records in a table they are added at the end of the table in the order you enter them. Working with information in such a jumbled order can be difficult if not impossible.

Fortunately you can sort, or change, the order of records in a table. You can sort records alphabetically, numerically, or chronologically (by date). Additionally, you can sort information in ascending (A to Z) or descending (Z to A) order.

Tips

✓ If you frequently sort a table the same way, you should consider creating and using a query that automatically sorts the table data for you. A query that sorts a table alphabetically by name would be a good example of such a query.

Sort records

1. Open the table you want to sort and click anywhere in the column (field) you want to use to sort by.

2. Click the Home tab on the Ribbon and click either the Ascending or Descending icon in the Sort & Filter group.

The table is sorted. See Table 3-2: Sort Examples for examples of different types of sorts.

Other Ways to Sort:
Right-click in the field you want to sort by and select a sort option.

Clear a sort

1. Click the Home tab on the Ribbon and click the Remove Sort icon in the Sort & Filter group.

The sorted data returns to its original order.
Using Common Filters

Sometimes you may want to see only certain records in your table. By filtering a table, you display only the records that meet your criteria and hide the records that do not. For example, you could filter a client list to display only clients who live in California.

There are several filter methods:

- **Common Filters**: A number of commonly-used filters are available on a menu, making it easy for you to quickly use these pre-defined filters.

- **Filter by Selection**: Simply find and select the value you want to use as the filter criteria, and then use the Filter By Selection command to find all records with the selected value.

- **Filter by Form**: Here you type your filter criteria into a blank form that contains all the field names in the table. This works well if you have more than one criteria.

- **Advanced Filter/Sort**: The most powerful and complicated filter method. Creating an advanced filter is really not any different from creating a query.

In this lesson, we’ll look at common filters you can access quickly using the contextual menu, as well as how to remove a filter.

**Apply a common filter**

1. Click anywhere in the column you want to filter by, click the **Home** tab on the Ribbon and click the **Filter** button in the Sort & Filter group.

   A contextual menu appears with two ways to filter:

   - Use the check box list. This list contains all the values in that column. Uncheck a box and click **OK** to filter out a particular value. If the box next to a value is checked, it will appear in the filtered table.

   - Click the **Filter** icon in the Sort & Filter group, point to **Text Filters**, and then select an option—such as **Equals** or **Does Not Equal**—on the submenu that appears. Enter a filter criterion in the **Custom Filter** dialog box. For example, if you select Equals and enter Johnson, Access will filter out all records except for those with Johnson in that field.

   **Trap**: These options aren’t available if you selected multiple columns. To filter multiple columns you need to filter each column individually or use an advanced filter.
2. Select a filter option.

The data is filtered.

⚠️ Other Ways to Use Common Filters:
Click the little field arrow on the field want to filter by, point to Text Filters and select one of the filter options from the contextual menu.

Clear a filter

1. Click the Home tab on the Ribbon, click the Advanced Filter Options button in the Sort & Filter group and select Clear All Filters.

All data is once again displayed.

⚠️ Other Ways to Clear a Filter:
Click in a filtered column, click the Filter button in the Sort & Filter group on the Home tab, and select Clear filter from [field name].

✅ Tips
✓ To un-apply or reapply a filter (without clearing it), click the Home tab on the Ribbon and click the Apply/Remove Filter button in the Sort & Filter group (called the Toggle Filter button when all filters have been cleared). Or, click the Filtered/Unfiltered button at the bottom of the window in the Record Selector bar (called the No Filter button when all filters have been cleared).
Filtering by Selection

A quick way you can filter a table is with the Filter by Selection feature.

1. Click the field value on which you want to base the filter.

2. Click the Home tab on the Ribbon and click the Selection button in the Sort & Filter group.

   The menu that appears contains four filter-related commands: you can read more about them in Table 3-3: Filter by Selection Menu Commands.

3. Select an option from the menu.

   Other Ways to Filter by Selection:

   Right-click the field value you want to filter by and select one of the options at the end of the contextual menu.

Table 3-3: Filter by Selection Menu Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equals [selected value]</td>
<td>Displays only records with the selected value.</td>
<td>If John is selected, only records with John in this column are displayed.</td>
</tr>
<tr>
<td>Contains [selected value]</td>
<td>Displays all records that contain the selected value.</td>
<td>If John is selected, John and Johnson are displayed.</td>
</tr>
<tr>
<td>Does Not Equal [selected value]</td>
<td>Displays all records that don’t contain the selected value.</td>
<td>If John is selected, records with John in this column are not displayed, but Johnson is.</td>
</tr>
<tr>
<td>Does Not Contain [selected value]</td>
<td>Displays records that don’t contain the selected value in any form.</td>
<td>If John is selected, neither John nor Johnson is displayed.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** EmployeeList.accdb
- **Exercise:** Use the Filter by Selection feature to filter by the WA value in the Region field. Select the Equal option. Then clear the filter.

Figure 3-8: Filtering a table by selection to display only records where the selected field equals “WA”.

Finding, Filtering, and Formatting Data
Filtering by Form

Filtering by Form makes it easy to create a filter that uses more than one criterion. The Filter by Form window enables you to enter your filter criterion by picking values that you want the filtered records to have. You can filter by form when working in Tables, forms or queries.

1. Click the Home tab on the Ribbon, click the Advanced Filter Options button in the Sort & Filter group, and select Filter by Form.

   The Filter by Form window appears.

   Tabs with the names “Look for” and “Or” appear at the bottom of the Filter by Form window. If you specify more than one criterion on the first tab, Access treats it as an AND criteria statement, meaning a record must match all the criteria in order to be displayed. For example, you could filter for employees who are from Washington AND who had been with the company for more than five years.

   If you specify filter criterion on both tabs, Access treats it as an OR criteria statement, meaning a record has to match the criterion on one tab or the other to be displayed. For example, you could filter for employees from California OR Minnesota. Once you add an OR criteria, another Or tab appears next to it so that you can continue adding OR criteria.

2. Click the empty cell below the field you want to filter, click the list arrow and select the value you want to use to filter the records.

   Other Ways to Enter Filter Criteria:
   Instead of selecting a filter criterion from the list arrow, you can type filter criteria yourself.

3. Repeat Step 2 for each additional field you want to use to specify additional filter criteria.

4. If you want to use OR criteria, click the Or tab at the bottom of the screen and specify additional filter criteria in the same way.

5. Click the Apply Filter button in the Sort & Filter group.

   The data is filtered using the criteria you entered in the form.

Exercise

- Exercise File: EmployeeList.accdb
- Exercise: Use the Filter by Form feature to display only records for employees from London with the title “Sales Manager”. Then add an OR criteria to also display records of any employees with the title “Vice President, Sales”. Clear the filters.
Creating an Advanced Filter

The most powerful type of filter is the Advanced Filter. The Advanced Filter is so powerful that you can think of it as a type of query. In fact, the procedure for creating an Advanced Filter is virtually the same as it is for creating a simple query. You can use an Advanced Filter when working in Tables, forms or queries.

Advanced Filters have many advantages. They have the ability to:

- **Sort by multiple Fields**: You can sort records using several Fields. For example, you could sort a table alphabetically by last name and then by first name.

- **Use complex filter criteria and expressions**: You can use advanced expressions and operators to search for data. For example, you could filter for dates that fall between 1/1/2010 AND 12/31/2012.

- **Use multiple AND/OR statements**: You can use more than one criterion to sift through records. For example, you could filter for employees who are from Washington AND who have been with the company for more than five years.

This lesson explains how to get your own Advanced Filters up and running.

1. Open the table that contains the data you want to filter or sort.

2. Click the **Home** tab on the Ribbon, click the **Advanced Filter Options** button in the Sort & Filter group, and select **Advanced Filter/Sort**.

   The advanced filter window appears. Notice that the window is split—just like a query in Design View. The top half contains a box that displays all the Fields in the table. The bottom half of the screen contains a Design grid, which is where you will add the Fields you want to filter.

   Often you will have to use the field list’s scroll bar to scroll up or down the list in order to find a field.

3. Double-click each field you want to include from the field list.

   **Other Ways to Add Fields to the Design Grid:**
   - Drag the field from the field list onto the Design grid. Or, click the list arrow in the Field row of the Design grid and select a field.

   To sort by a field, you can click the **Sort** row in the column that contains the field that you want to sort and select Ascending or Descending from the list.

---

**Exercise**

- **Exercise File**: EmployeeList.accdb
- **Exercise**: Create an Advanced Filter that sorts the records in Ascending order by **Last Name** and then **First Name**, and also filters for employees from **London** who were hired after 1/1/93. Clear the filter.

---

**Figure 3-10**: Creating an Advanced Filter.

**Figure 3-11**: Filtered results.
4. Click the Sort list arrow for the field and select a sort order (optional).

If you use several Fields to sort a table, Access performs the sort in the order the Fields appear in the Design grid.

Now you need to specify criteria for the filter. Table 3-4: Common Criteria Operators shows some common criteria operators you can add to your criteria to make them more useful.

5. In the Design grid, enter any desired search criteria for the Fields in the Criteria row.

If you specify more than one criterion on the same Criteria row, Access treats it as an AND criteria statement, meaning a record must match all the criteria in order to be displayed. For example, you could filter for employees who are from London AND who were hired after January 1, 2003.

If you specify filter criterion on the Or rows, Access treats it as an OR criteria statement, meaning a record has to match the criterion on one row or the other to be displayed. For example you could filter for employees from London OR Washington.

6. Click the Apply Filter button in the Sort & Filter group.

<table>
<thead>
<tr>
<th>Table 3-4: Common Criteria Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
</tr>
<tr>
<td>&lt; &gt;</td>
</tr>
<tr>
<td>&lt;</td>
</tr>
<tr>
<td>&lt; =</td>
</tr>
<tr>
<td>&gt;</td>
</tr>
<tr>
<td>&gt; =</td>
</tr>
<tr>
<td>BETWEEN</td>
</tr>
</tbody>
</table>
| LIKE | LIKE “S*” | Finds text beginning with the letter “S.” You can use LIKE with wildcards such as *.
Adjusting and Rearranging Rows and Columns

Access is usually pretty smart about how wide to make the columns of a table or query datasheet, so hopefully you won’t have to do much resizing. Sometimes, however, you will discover that some of the columns or rows are not large enough to display the information they contain. This lesson explains how to change the width of a column and the height of a row, as well as how to rearrange columns.

Tips

✔ When you adjust the height of a row, all the rows change, but when you adjust the width of a column, only the selected column(s) change.

Adjust column width

1. Drag the column header’s right border to the left or right.

Other Ways to Adjust Column Width:
Right-click the column header(s), select Field Width from the contextual menu, enter the column width, and click OK. Or, select the column(s) you want to adjust, click the Home tab on the Ribbon, click the More button in the Records group, select Field Width, enter the column width and click OK.

Adjust row height

1. Drag the row header’s bottom border up or down.

Other Ways to Adjust Row Height:
Right-click the row header(s), select Row Height from the contextual menu, enter the row height, and click OK. Or, select any row, click the Home tab on the Ribbon, click the More button in the Records group, select Row Height, enter the row height and click OK.

Automatically adjust columns

You can also have Access automatically adjust the width of a field or column so that it can hold the widest entry. To do this, simply double-click the right edge of the column.

1. Double-click the right border of the column.
Finding, Filtering, and Formatting Data

Rearrange columns

When you first created a table, hopefully, you thought about its field order, so that most of the time your data will appear in the order you want. Sometimes, however, you may want to change the column order of a table.

1. Click the field name of the column you want to move. Then, click it again and hold down the mouse button.

   Now you can drag the column to its new destination. If the destination is too far to the left or right to appear on the screen, drag the column to the left or right of the window—the datasheet will scroll in that direction.

2. Drag the selected column to its new location.

Tips

✓ As you move the column, a bar moves between the columns, showing where the column will go when you release the mouse button.

✓ Don’t worry that altering column order will affect your data—it doesn’t.
Changing Gridline and Cell Effects

There isn’t a lot of formatting you can do to Tables in Access, but you can change how gridlines appear, apply background colors and add 3-D effects to the table’s cells.

Change gridlines

By default, Access displays both horizontal and vertical lines in a table, but you can select to show Horizontal, Vertical, Both, or None.

1. Click the Home tab on the Ribbon, click the Gridlines button in the Text Formatting group, and select the gridline option you want to use.

Other Ways to Change Gridlines:
Click the Home tab on the Ribbon and click the arrow for the Dialog Box Launcher in the bottom right corner of the Text Formatting group to display the Datasheet Formatting dialog box. Check or uncheck the Horizontal and Vertical boxes in the Gridlines Shown area.

Tip: Click the Home tab on the Ribbon and the arrow for the Dialog Box Launcher in the bottom right corner of the Text Formatting group to display the Datasheet Formatting dialog box. Here you can change gridline color, change gridline style (for example, a dotted line), and change the direction of the table columns so that they go from right-to-left.

Apply background colors

1. Click the Home tab on the Ribbon, click the Background Color button arrow in the Text Formatting group, and select a color.

The first row in the table and each alternating row is displayed with the color you selected.

You can also apply a second color to the alternating rows.

2. Click the arrow for the Datasheet Formatting dialog box, and select the color you wish to use for the Alternate rows from the Alternate Row Color box.

The alternate rows are filled with the color you chose.

Other Ways to Apply Background Colors:
Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Text Formatting group. Click the Background Color or Alternate

Exercise

- Exercise File: EmployeeList.accdb
- Exercise: Remove gridlines and change the background color to Light Gray 1. View the Datasheet Formatting dialog box and look at the Cell Effect options. Click Cancel.

Figure 3-14: The Text Formatting group.
Background Color list arrow and select the color you want to use.

**Apply cell effects**

You can also add a 3-D effect to the table cells.

1. Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Text Formatting group. The Datasheet Formatting dialog box appears.

2. Select Raised or Sunken in the Cell Effect area and click OK.

The selected effect is applied to the table cells.

**Figure 3-15:** The Datasheet Formatting dialog box.
Changing the Datasheet Font

Being a practical business program, Access displays its Tables in a no-nonsense, easy-to-read font. However, you can change the font used to display table data. You can make the text appear darker and heavier (bold), slanted (italics), larger, and in a different typeface or color.

**Tips**

✓ The font settings you change apply to the entire table, not just a particular cell, column, or row.

Here’s how to change the font used in a table.

1. Click the **Home** tab on the Ribbon and format the table data using the commands in the Text Formatting group.

<table>
<thead>
<tr>
<th>Table 3-5: Text Formatting group commands</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Font</strong></td>
<td>Click the <strong>Font</strong> list arrow and select a font type—for example, Arial.</td>
</tr>
<tr>
<td><strong>Font Size</strong></td>
<td>Click the <strong>Font Size</strong> list arrow and select a font size.</td>
</tr>
<tr>
<td><strong>Bold</strong></td>
<td>Click the <strong>Bold</strong> button to bold the table text.</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Click the <strong>Italic</strong> button to italicize the table text.</td>
</tr>
<tr>
<td><strong>Underline</strong></td>
<td>Click the <strong>Underline</strong> button to underline the table text.</td>
</tr>
<tr>
<td><strong>Font Color</strong></td>
<td>Click the <strong>Font Color</strong> list arrow and select a font color.</td>
</tr>
<tr>
<td><strong>Text Alignment</strong></td>
<td>Click the <strong>Align Text Left, Center, or Align Text Right</strong> buttons to align text within the table cells.</td>
</tr>
</tbody>
</table>

**Exercise**

- **Exercise File**: EmployeeList.accdb
- **Exercise**: Apply **Bold, Red** formatting, then remove the **Bold** and return the font color to Automatic.

![Font formatting commands in the Text Formatting group.](image)
Freezing a Column

Most Tables have so much information that it won’t all fit on the same screen. When this happens, you have to scroll through the datasheet to add, delete, modify, and view information. The problem with scrolling and viewing data in a large table is that it can be confusing when you can’t see important information such as names or product numbers.

To overcome this problem, you can freeze a column so it stays in the same place while you scroll to the right in a table. Here’s how to freeze a column.

Freeze a column

1. Right-click the header for the column you want to freeze and select Freeze Fields from the contextual menu.

The column is now frozen and is moved to the left side of the table. Here it will always remain visible as you scroll to the right through the rest of the Fields in the table.

Tip: To freeze more than one column, freeze them individually. Or, select all the columns you want to freeze, right-click the field header area and select Freeze Fields.

Other Ways to Freeze or Unfreeze a Column: Select the column you want to freeze, click the Home tab on the Ribbon, click the More button in the Records group, and select Freeze Fields or Unfreeze All Fields.

Unfreeze a column

1. Right-click any column header in the table and select Unfreeze All Fields.

All columns are unfrozen.

Tip: Once you unfreeze the column, you will still need to move the column back to its old position, if desired. Or, simply choose not to save changes when you close the table—when you reopen it, the columns will be in their previous positions.
Hiding a Column

You can temporarily hide a column when you want to reduce the amount of information that is displayed on the screen. Hiding a column doesn’t delete any information—it only hides it. The procedure for hiding and unhiding a column is almost the same as for freezing a column.

Hide a column

1. Right-click the header for the column you want to hide and select Hide Fields from the contextual menu.

   The column is hidden.

   Tip: To hide multiple columns at once, select them all, then right-click one of the selected column headers and select Hide Fields.

Unhide a column

1. Right-click any table header and select Unhide Fields from the contextual menu.

   The Unhide Columns dialog box appears.

2. Click the check box next to each column you want to redisplay. Click Close.

   The column(s) are unhidden.
Finding, Filtering, and Formatting

Data Review

Quiz Questions

1. The Replace command finds a string of text and replaces it with another string of text. (True or False?)

2. How would you sort aDatasheet in ascending order by a date field?
   A. Double-click the top of the Date field column header.
   B. Select any Date field and click the Sort button in the Tools group.
   C. Select any Date field and click the Ascending button in the Sort & Filter group.
   D. Access can’t sort chronological information.

3. Which of the following is not a filtering method in Access?
   A. Filter by Table
   B. Filter by Selection
   C. Filter by Form
   D. Advanced Filter/Sort

4. Filter by Selection is the most difficult and advanced way to filter information. (True or False?)

5. You should only use Filtering by Form when you want to use one filter criterion. (True or False?)

6. How can you add fields to the design grid in an Advanced Filter?
   A. Double-click the field from the Field List.
   B. Select the field from the Add Field List on the Ribbon.
   C. Right-click the grid and select Add Field from Menu.
   D. Press Ctrl + X

7. Double-click the left border of a column to automatically adjust the width of a column to fit the largest cell. (True or False?)

8. By default, Access displays both horizontal and vertical gridlines in a table. (True or False?)

9. Which of the following is not a font-related option you can change in Access?
   A. Font Size
   B. Text Alignment
   C. Bold
   D. Zoom

10. To freeze a column in Access, right-click the column’s header and select ____________.
    A. Freeze Field
    B. Pin Column
    C. Freeze Columns
    D. Hide Column

11. When you hide a column or field, you permanently lose all the information stored in the field. (True or False?)
Quiz Answers

1. True. The Replace command finds a string of text and replaces it with another string of text.
2. C. To sort a Datasheet by a date field select any Date field and click the Ascending button in the Sort & Filter group.
3. A. Filter by Table is not a filtering option in Access.
4. False. Filter by Selection is a fast and easy way to filter information.
5. False. With Filter by Form you can easily filter with several criteria.
6. A. Double-click the fields you want to add from the Field List.
7. False. Double-click the right border of a column.
9. D. Zoom is not a font-related option.
10. C. Select Freeze Columns from the contextual menu.
11. False. The information is still there, it’s just hidden.
Working with Tables and Fields

Understanding Field Properties ..................... 69
Indexing a Field ........................................ 71
Adding a Primary Key to a Table ....................... 73
Inserting, Deleting, and Reordering Fields .......... 75
  Insert a field ......................................... 75
  Change field order .................................. 75
  Delete a field ....................................... 76
Adding Field Descriptions and Captions .......... 77
Changing the Field Size ................................ 78
Formatting Number, Currency, and Date/Time Fields .................................................. 80
  Format number and currency fields ............... 80
  Change the number of decimal places ........... 80
Formatting Number, Currency, and Date/Time Fields by Hand ........................................ 82
Formatting Text Fields .................................. 84
Setting a Default Value ................................ 85
Requiring Data Entry ................................... 86
Validating Data .......................................... 87
Creating an Input Mask ................................ 89
Creating a Lookup Field ................................ 91
Creating a Value List ................................... 93
Modifying a Lookup List ................................ 95
  Modify a lookup list ................................ 95
  Modify a value list .................................. 96

Tables are by far the most important part of any database. Tables are where a database stores all of its information. All the other database objects—queries, forms, reports, pages, and macros—are merely tools to analyze, manipulate, and display the information stored in a table. Any of these other database objects are optional—but without Tables, a database wouldn’t be a database.

If you are interested in creating your own databases, this may be one of the most important chapters in the entire book. Why? Because, at their heart, the most useful and efficient databases consist of well-structured Tables.

This chapter explains just about everything you will ever need to know about Tables and Fields: how to link two or more related Tables, how to create indexes for faster performance, and how to create a primary key field, which uniquely identifies each record in a table. This chapter also explains how to change all the properties and settings for your Tables’ Fields, such as how they are formatted and what kind of information they can store.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Understanding Field Properties

A property is an attribute that defines an object’s appearance, behavior or characteristics. For example, a car’s properties would include its color, make and model, and shape. A property for a numeric field might be the number of decimal places displayed or the maximum number of characters a field can hold.

Just about every object in Access—every heading on a report, every label on a form, every field in a table—has its own set of properties that you can view and change. This property concept might seem a little confusing at first, but it’s something you have to learn if you want to become proficient at using Microsoft Access. Because you can almost always change object properties, you can also think of an object’s properties as its settings.

To view and modify the Field Properties for a table, open the table in Design View.

1. Double-click the table you want to open in the Navigation pane.
   The table opens in Datasheet View.

2. Click the Home tab on the Ribbon and click the View button in the Views group. Select Design View.
   The table is displayed in Design View and the Design contextual tab appears under Table Tools on the Ribbon.

   **Other Ways to Open a Table in Design View:**
   Right-click the table you want to open in the Navigation pane and select Design View from the contextual menu.

As you can see, the table Design window is broken into two sections. The top section contains the table’s field names and the bottom section displays the properties for the selected field. Simply click the field name whose properties you want to view.

3. In the top part of the window, click the field name whose properties you want to view.
   To change a field property…

4. Click the property box you want to change and enter or select the new settings.

   **Table 4-1: Important Field Properties** describes many important field properties. Don’t worry if some of them seem confusing—you’ll get plenty of practice adjusting them in other lessons.

**Exercise**
- **Exercise File:** CustomerTours.accdb
- **Exercise:** Open the tblCustomers table. Click in the LastName field and view the field’s properties in the bottom half of the window.

Figure 4-1: Viewing field properties in Design View.
Tips

- The Property Sheet displays some additional, highly technical table properties. To hide or show the Property Sheet, click the Design tab under Table Tools, and click the Property Sheet button.

- It's important to note that certain types of Fields have their own sets of properties. For example, number Fields have a Decimal Places property while text Fields do not.

<table>
<thead>
<tr>
<th>Field Size</th>
<th>Text Fields: The maximum number of characters (up to 255) that can be entered in the field. The default setting is 50.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Number / Currency Fields: Stores the number as a Byte, Integer, Long Integer, Single, Double, or Replication ID, or Decimal. The default setting is Long Integer.</td>
</tr>
<tr>
<td>Format</td>
<td>How the data in the field will be displayed on the screen.</td>
</tr>
<tr>
<td>Input Mask</td>
<td>Creates a format or pattern in which data must be entered.</td>
</tr>
<tr>
<td>Decimal Places</td>
<td>The number of decimal places in Number and Currency Fields.</td>
</tr>
<tr>
<td>Caption</td>
<td>A label for the field that will appear on forms. If you don’t enter a caption, Access will use the field name as the caption.</td>
</tr>
<tr>
<td>Default Value</td>
<td>A value that Access enters automatically in the field for new records.</td>
</tr>
<tr>
<td>Validation Rule</td>
<td>An expression that limits the values that can be entered in the field.</td>
</tr>
<tr>
<td>Validation Text</td>
<td>The error message that appears when an incorrect or restricted value is entered in a field with a validation rule.</td>
</tr>
<tr>
<td>Required</td>
<td>Specify whether or not a value must be entered in the field. The default is No.</td>
</tr>
<tr>
<td>Allow Zero Length</td>
<td>Specify whether or not the field allows zero-length text strings (a string containing no characters). Zero-length text strings are useful if you must enter data in a field, but no data exists. For example, if a Social Security field requires data, but you don't know the social security number, you would enter a zero-length text string in the field. To enter a zero-length text string type “” in the cell. The cell will appear empty. The default is No.</td>
</tr>
<tr>
<td>Indexed</td>
<td>Specify whether or not you want to index the field to speed up searches and sorts performed on the field. The default is No.</td>
</tr>
</tbody>
</table>
Indexing a Field

Just like an index in a book, when you index a field, it helps Access find and sort information quickly—especially in large Tables. You can index any field in a table to dramatically speed up queries and sorts. When you sort or query a large table using an indexed field, Access finds or sorts the information by consulting the index instead of sifting through the entire table.

Here are some more important notes about indexes:

- Since indexes speed up searching and sorting, you should index the Fields you frequently use to search or sort. For example, if you often search for specific last names, you should create an index for the LastName field.
- Don’t index too many of a table’s Fields. The more Fields you index, the slower your searches and sorts will be—defeating the entire purpose of an index. Only index the Fields you use to search and sort data.
- Any field can be indexed except memo, OLE, attachment, calculated, and hyperlink Fields.
- Primary key Fields are indexed automatically (we’ll discuss primary keys more in future lessons).
- If you choose, indexes can prevent duplicate entries in your table (for example, if you don’t want to allow two customers to have the same social security number).

This lesson will show you how to add indexes to your Tables.

1. Open the table you want to index in Design View.

Indexing a field is a fairly simple operation. First you need to click the name of the field you want to index. You will want to index a field that is frequently used to find and sort information—for example, a Last Name field.

2. Click the field name you want to index in the top part of the screen.

3. Click the Indexed row in the Field Properties section and click its list arrow.

The Indexed list gives you three choices:

- **No**: The field is not indexed. This is the default setting.
- **Yes (Duplicates OK)**: The field is indexed and Access will allow records in this field to have the same value.

**Exercise**

- **Exercise File**: CustomerTours.accdb
- **Exercise**: In the tblCustomers table, index the LastName and ZipCode Fields, choosing the “Yes (Duplicates OK)” option. Save the changes.
• **Yes (No Duplicates):** The field is indexed and Access won’t allow records in this field to have the same value (for example, if you don’t want to allow two customers to have the same social security number).

Most of the time you will want to choose the “**Yes (Duplicates OK)**” option. For example, if you’re indexing a Last Name field, you’ll want to select “**Yes (Duplicates OK)**” since some people may have the same last name.

4. Select an indexing option from the list.

Most of the time Access creates the index in a matter of seconds. If you have a huge table with thousands of records, it will take longer to create the index.

When you’re done indexing, save the changes you’ve made to your table.

5. Click the **Save** button on the Quick Access Toolbar.

The indexing is saved.

**Tips**

- If you need to remove an index from a field, select the field, click the Indexed row’s **list arrow**, and select the **No** option. Access will delete the field’s index.
Adding a Primary Key to a Table

A primary key is a special kind of indexed field that uniquely identifies each record (row) in a table. When you think about primary key Fields, think unique—each primary key value must be the only one of its kind in a table. A customer ID or invoice number would be two good examples of Fields that could be used as a table’s primary key.

Here are some things you need to know about primary keys:

- A table can have only one primary key.
- The values in the primary key Fields must be unique. For this reason, many people use an AutoNumber field as their primary key. AutoNumber Fields automatically add a new, unique number to each record in a table. Another reason to use AutoNumber Fields for your primary keys is because they are “factless”—meaning they don’t contain factual information that describe the row. Factless Fields are better than factual Fields like Last Name because they are less likely to change.
- A primary key field needs to always contain a value and should rarely or never change.
- Every table you create should have a primary key because it helps keep your data organized and easy to work with.
- The primary key field is automatically indexed.
- Memo, OLE, calculated, and attachment Fields can’t be used as the primary key.
- The primary key is normally a single field, but two or more Fields can act together as the primary key, so long as their combined values are unique. Such multi-field keys are usually difficult and confusing to work with, however.
- Primary keys are especially important in creating relationships between Tables.

So what makes a good primary key field? The most important consideration for a primary key is its uniqueness. A primary key field must always be different in every record, so you might be able to use a Customer ID, Invoice Number, or Social Security Number field as your table’s primary key.

Fortunately, in Access 2013 you won’t usually have to worry about assigning a primary key because Access does it for you. When you create a new table, Access automatically creates a primary key with the field name ID and the AutoNumber data type.

Exercise

- Exercise File: CustomerTours.accdb
- Exercise: In the tblCustomers table, add a primary key to the CustomerID field. Save the change.

Figure 4-3: Assigning a primary key to the CustomerID field.
However, if you have an existing table to which you want to add a primary key field, you’ll want to pay close attention to the steps in this lesson, which explain how to add a primary key.

**Tips**

- If a table doesn’t already have a unique field that is suitable as the primary key, add an *AutoNumber* field to your table. The *AutoNumber* field will automatically add a new, unique number to each of the records in a table.

1. Open the table you want to add a primary key to in **Design View**.

2. Click the name of the field you want to use as your primary key in the top part of the screen.

3. Under Table Tools on the Ribbon, click the **Design** tab and click the **Primary Key** button in the Tools group.

   A key symbol appears next to the field, indicating that it is the table’s primary key. Notice that Access also sets the Indexed field to “**Yes (No Duplicates)**.” Access automatically indexes the field so that sorts and queries using the field will be faster and so that you cannot enter duplicate values in the field.

**Tips**

- If a field appears in more than one table and is a primary key in one table, it is called a *foreign key* in the other table (because it is another table’s primary key).

- To remove a primary key, just click the **Primary Key** button again. However, if the primary key is involved in any table relationships, you’ll first need to delete the relationships before you can remove the primary key.
Inserting, Deleting, and Reordering Fields

You can insert, delete, and reorder Fields in your Tables in Design View. Remember that in Design View, each row corresponds to a field in the table. You add a field by inserting a new row and delete a field by deleting its corresponding row.

Tips

✓ You can also insert, reorder, and delete Fields in Datasheet View.

Insert a field

1. Display the table you want to work with in Design View.

   To insert a new field, you must first click the row selector for the field that will appear below the new field you want to insert.

2. Click the row selector for the field that will be below the new field you want to insert.

3. Under Table Tools on the Ribbon, click the Design tab and click the Insert Rows button in the Tools group.

   A new row is added.

   Other Ways to Insert a Field:
   Right-click in the row below where you want to insert the new field and select Insert Rows from the contextual menu.

4. Enter a Field Name for the new field, then click the Data Type list arrow and select a data type.

Change field order

1. In Design View, click the row selector for the field you want to move.

2. Click and drag the selected row up or down to the desired location.

Exercise

- Exercise File: CustomerTours.accdb
- Exercise: In the tblCustomers table in Design View, insert a field called “MI” above the Phone field. Move the MI field down before the City row. Then delete the MI field.

Figure 4-4: The Insert and Delete Rows commands in the Tools group.

Figure 4-5: Inserting a new row in Design View.
Delete a field

1. In Design View, click the row selector for the field and press `<Delete>`.

2. Click Yes.

⚠ Other Ways to Delete a Field:
Right-click the field’s row and select Delete Rows. Click Yes.

✔ Tips
✓ Once you leave Design View, you’ll need to save the changes you’ve made to the table Design.
Adding Field Descriptions and Captions

Descriptions provide extra instructions to users about a field, while captions allow you to create nicknames for Fields, making their names more meaningful to users.

Add a description to a field

Descriptions make your database Fields easier to fill out and use by providing users with onscreen instructions and help. Whenever a user selects a field, anything you type in that field’s Description box will appear in the Status bar.

There really isn’t anything complicated about adding a description to a field—just type the text you want to appear in the field’s Description box.

1. Make sure the table is displayed in Design View, click the field’s Description box, and type the description.

When you return to Datasheet View, and click anywhere in that field, you will see the Description appear in the Status bar.

Add a caption to a field

Think of the Caption property as a field’s pseudonym or stage name. When you view a table in Datasheet View or Create forms and reports, Access uses the field’s Field Name as the field’s heading. When you add a caption to a field, however, it appears as the heading for the field instead of the field name.

Captions are useful when you want to provide more detailed headings for your field names. For example, instead of displaying the rather ambiguous DOB field name, you could add a more meaningful “Date of Birth” caption to the DOB field to make the field name easier to read and understand. The original DOB field name is not affected in any way.

1. Make sure the table is displayed in Design View.

2. Click the field you want to add a caption to.

3. Click the Caption box in the Field Properties section and type the caption.

Exercise

- **Exercise File**: CustomerTours.accdb
- **Exercise**: In the tblCustomers table, change the DOB field’s data type to Date/Time. Add the description “Enter the Customer’s Last Name” to the LastName field, and “Enter the Customer’s First Name” to the FirstName field. Add the caption “Date of Birth” to the DOB field and “Social Security No.” to the SSN field. Save the changes. View the table in Datasheet View and notice the message in the status bar when you click in the LastName and FirstName Fields, and the new headings for the DOB and SSN Fields.

Figure 4-6: Once you enter a description in Design View, it appears in the Status bar in Datasheet View.
Changing the Field Size

The **Field Size** property determines the maximum size of information that can be stored in a text or number field. For example, if you set the size of a text field to 2, you could enter “MN” but not “Minnesota.” There are several reasons why you would want to change the size of a field:

- Changing the field size reduces data-entry errors.
- Access can process smaller field sizes more quickly.
- Smaller field sizes require less hard-drive storage space.

Field sizes work a little differently for text and number fields. In text fields, the **Field Size** property determines the maximum number of characters the field can accept. In numerical type fields, the **Field Size** property determines what type of number the field will accept.

In this lesson you will change the size of a table’s fields.

1. Make sure the table is displayed in **Design View**.
2. Select the field whose size you want to change.
3. Click the **Field Size** box in the Field Properties section.
   
   Now you’re ready to change the field size. If the field is a text field, you can type the field size value, but if it’s a number field, you’ll need to click the list arrow and select an option.
4. Type or select the field size. If prompted, click **Yes** to complete the action.

**Trap:** Be very careful when changing the Field Size of a field that already contains data. Access will truncate or delete data that is larger than the new field size.

Table 4-2: Number Field Sizes describes the field sizes available for use with the **Number** data type.
## Working with Tables and Fields

### Table 4-2: Number Field Sizes

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Example Range</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Byte</strong></td>
<td>Integers from 0 to 255.</td>
<td></td>
<td>Very small – not usually a good choice.</td>
</tr>
<tr>
<td><strong>Integer</strong></td>
<td>Integers from –32,768 to 32,767.</td>
<td></td>
<td>Good for small numbers with no decimals.</td>
</tr>
<tr>
<td><strong>Long Integer</strong></td>
<td>Integers from –2,147,483,648 to 2,147,483,647.</td>
<td></td>
<td>Works for most numbers without decimals.</td>
</tr>
<tr>
<td><strong>Single</strong></td>
<td>Positive or negative numbers up to 38 zeroes and 7 decimal places.</td>
<td></td>
<td>Good for large numbers with decimals.</td>
</tr>
<tr>
<td><strong>Double</strong></td>
<td>Positive or negative numbers up to 308 zeroes and 15 decimal places.</td>
<td></td>
<td>For really big numbers with decimals.</td>
</tr>
<tr>
<td><strong>Replication ID</strong></td>
<td>Long unique codes.</td>
<td></td>
<td>Used when you want to merge copies of a database.</td>
</tr>
<tr>
<td><strong>Decimal</strong></td>
<td>Positive or negative numbers up to 28 zeroes and 28 decimal places.</td>
<td></td>
<td>Good for numbers with lots of decimals.</td>
</tr>
</tbody>
</table>
Formatting Number, Currency, and Date/Time Fields

A field’s **Format** property changes how information appears in the field, not how the data is actually stored in the field. For example, a **Date** field could be formatted to display the same value as 6/10/2000; Saturday, June 10, 2000; or 10-Jun-00. Each field type has its own set of formats. For example, number Fields have a different set of formats than date/time or text Fields.

There are two ways to format a **number**, **currency** and **date/time** field:

- Selecting a ready-made format from the **Format** list (the easy way). For most people, the ready-made formats listed in Table 4-3: Number and Date/Time Formats will be all you will ever need to format your Fields.

- Typing a series of formatting characters by hand in the **Format** box (the hard way).

This lesson explains the first way—how to format **number**, **currency**, and **date/time** Fields by selecting a ready-made format. We’ll also look at how to change the number of decimal places.

**Format number and currency Fields**

1. Make sure the table is displayed in **Design View** and click the field you want to format.

2. Click the **Format** box in the Field Properties section.

   A list arrow appears in the Format box. You can format this field the easy way by clicking the arrow to select from a list of ready-made number formats.

3. Click the **list arrow** and select a number format.

**Change the number of decimal places**

You can also specify how many decimal places you want numbers in a field to display. To change the number of decimal places in a number field, enter the number of decimal places you want displayed in the **Decimal Places** box.

1. Make sure the table is displayed in **Design View** and click the field you want to format.

2. Click the **Decimal Places** box in the Field Properties section.

   A list arrow appears.

### Exercise

- **Exercise File**: CustomerTours.accdb

- **Exercise**: Open the **tblCustomerTours** table in **Datasheet View** and study the formats of the **Date** and **Cost** Fields. Switch to **Design View**. Format the **Date** field to **Medium Date**. Format the **Cost** field so that it has **0** decimal places. Save the changes, then switch back to **Datasheet View** and notice how the formatting has changed in the **Date** and **Cost** Fields.

### Figure 4-8: Formatting the Date field in Design View.

### Figure 4-9: Before and after formatting the Date and Cost Fields.
3. Click the list arrow and select the number of decimal places you want to display.
   
   Now Access will only display the number of decimals you selected.

<table>
<thead>
<tr>
<th>Number Format</th>
<th>Example:</th>
<th>Date/Time Format:</th>
<th>Example:</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Number</td>
<td>1234.567</td>
<td>General Date</td>
<td>6/10/2000 6:35:21 PM</td>
</tr>
<tr>
<td>Currency</td>
<td>$1,234.57</td>
<td>Long Date</td>
<td>Saturday, June 10, 2000</td>
</tr>
<tr>
<td>Euro</td>
<td>€1,234.57</td>
<td>Medium Date</td>
<td>10-Jun-00</td>
</tr>
<tr>
<td>Fixed</td>
<td>1234.57</td>
<td>Short Date</td>
<td>6/10/2000</td>
</tr>
<tr>
<td>Standard</td>
<td>1,234.57</td>
<td>Long Time</td>
<td>6:35:21 PM</td>
</tr>
<tr>
<td>Percent</td>
<td>123456.70%</td>
<td>Medium Time</td>
<td>6:35 PM</td>
</tr>
<tr>
<td>Scientific</td>
<td>1.23E+03</td>
<td>Short Time</td>
<td>18:35</td>
</tr>
</tbody>
</table>
Formatting Number, Currency, and Date/Time Fields by Hand

If none of the ready-made number, currency, or date/time formats meet your needs, you can format Fields the old-fashioned way—by hand. Formatting Fields requires that you tell Access how you want the field to be formatted by typing the appropriate formatting characters in the Format box. Manual formatting is difficult, but it gives you complete flexibility on how the field displays its information.

In this lesson you will learn how to format number, currency, and date/time Fields by hand.

1. Make sure the table is displayed in Design View and click the field you want to format.

2. Click the Format box in the Field Properties section.

   You can use Table 4-4: Number, Currency, and Date/Time Formatting Characters to help you know what characters to enter. You can mix and match any of the characters—for example, you could add "mmmm" (full name of month) to "yy" (last two digits of the year) to get “January 00.”

3. Enter the appropriate formatting characters or symbols for how you want the date or number to be formatted.

<table>
<thead>
<tr>
<th>Date/Time Formatting Characters:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Character</td>
</tr>
<tr>
<td>:</td>
</tr>
<tr>
<td>/</td>
</tr>
<tr>
<td>-</td>
</tr>
<tr>
<td>D</td>
</tr>
<tr>
<td>Dd</td>
</tr>
<tr>
<td>ddd</td>
</tr>
<tr>
<td>dddd</td>
</tr>
<tr>
<td>m</td>
</tr>
<tr>
<td>mm</td>
</tr>
<tr>
<td>mmm</td>
</tr>
<tr>
<td>mmmm</td>
</tr>
<tr>
<td>yy</td>
</tr>
<tr>
<td>yyyy</td>
</tr>
<tr>
<td>h</td>
</tr>
</tbody>
</table>

Exercise

- Exercise File: CustomerTours.accdb
- Exercise: Open the tblCustomerTours table Design View, enter “dd dmmm d” in the Format box for the Date field. Save the change and view the Date field in Datasheet View.
### Table 4-4: Number, Currency, and Date/Time Formatting Characters

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Data</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>hh</td>
<td>Hour in two digits</td>
<td></td>
<td>hh:nn</td>
<td>08:45</td>
</tr>
<tr>
<td>nn</td>
<td>Minute in two digits</td>
<td></td>
<td>hh:nn</td>
<td>13:09</td>
</tr>
<tr>
<td>ss</td>
<td>Second in two digits</td>
<td></td>
<td>hh:nn:ss</td>
<td>10:45:07</td>
</tr>
<tr>
<td>AM/PM</td>
<td>Twelve-hour clock (uppercase)</td>
<td></td>
<td>hh:nn AM/PM</td>
<td>08:45 AM</td>
</tr>
<tr>
<td>am/pm</td>
<td>Twelve-hour clock (lowercase)</td>
<td></td>
<td>hh:nn am/pm</td>
<td>08:45 am</td>
</tr>
</tbody>
</table>

#### Number Formatting Characters:

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Data</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Display a digit or nothing</td>
<td>50</td>
<td>#</td>
<td>50</td>
</tr>
<tr>
<td>0</td>
<td>Display a digit or 0</td>
<td>50</td>
<td>#.00</td>
<td>50.00</td>
</tr>
<tr>
<td>.</td>
<td>Display a decimal separator</td>
<td>50</td>
<td>.</td>
<td>50.</td>
</tr>
<tr>
<td>,</td>
<td>Display thousands separator</td>
<td>5000</td>
<td>#,####</td>
<td>5,000</td>
</tr>
<tr>
<td>$</td>
<td>Display the $ currency symbol</td>
<td>50</td>
<td>$#.00</td>
<td>$50.00</td>
</tr>
<tr>
<td>%</td>
<td>Multiply the value by 100 and add a percent sign</td>
<td>0.5</td>
<td>#%</td>
<td>50%</td>
</tr>
<tr>
<td>E-, E+, e-, e+</td>
<td>Scientific notation</td>
<td>500000</td>
<td>#.00E+00</td>
<td>5.00E+05</td>
</tr>
</tbody>
</table>
Formatting Text Fields

Just like number, currency, and date/time Fields, a text field’s Format property changes how information appears in the field. The Format property only changes how data is displayed on screen, not how the data is actually stored in the field.

Unfortunately, unlike number Fields, text Fields don’t have any ready-made settings built into them and must be formatted manually. Luckily, text Fields don’t have nearly as many formatting options as number, currency, and date/time Fields. The most common of these text formatting characters are the greater than symbol (>) which makes all text in the field appear in uppercase, and the less than symbol (<), which makes all text in the field appear in lowercase, regardless of how it was entered. In both cases, Access actually stores the data exactly as it was typed.

1. Make sure the table is displayed in Design View and click the text field you want to format.

2. Click the Format box in the Field Properties section.

3. Enter the appropriate text formatting symbols.

Tips

✓ Remember that the Format property only changes how data is displayed onscreen, not how the data is actually stored in the field.

---

Table 4-5: General and Text Formatting Symbols

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Text</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>Aligns text from the right</td>
<td>Hello</td>
<td>!</td>
<td>Hello</td>
</tr>
<tr>
<td>&lt;</td>
<td>Lowercase</td>
<td>Hello</td>
<td>&lt;</td>
<td>hello</td>
</tr>
<tr>
<td>&gt;</td>
<td>Uppercase</td>
<td>Hello</td>
<td>&gt;</td>
<td>HELLO</td>
</tr>
<tr>
<td>&quot;ABC&quot;</td>
<td>Always displays quoted text</td>
<td>4</td>
<td>&quot; &amp;&quot;</td>
<td>4 oz.</td>
</tr>
<tr>
<td>@</td>
<td>Character is required</td>
<td>5558000</td>
<td>@</td>
<td>555-8000</td>
</tr>
<tr>
<td>*</td>
<td>Fill available space with next character</td>
<td>Alert</td>
<td>*!</td>
<td>Alert!!!!!!!</td>
</tr>
<tr>
<td>[color]</td>
<td>Displays value in color</td>
<td>Hello</td>
<td>[red]</td>
<td>Hello</td>
</tr>
</tbody>
</table>
Setting a Default Value

You can enter a default value to specify a value that is automatically entered in a field when a new record is created. For example, if most of your clients are from Texas, you could set the default value for the State field to “TX.” When a user adds a record to the table, they can either accept the “TX” default value for the State field or enter their own value.

1. Make sure the table is displayed in Design View and click the field you want to add a default value to.

2. Click the Default Value box in the Field Properties section.

3. Enter the default value you want to appear in the field for new records.

Tips

✓ A common default value used in Date Fields is the current date. To automatically add the current date, type =Date() in the field.

Figure 4-12: A default value is automatically entered in a new record.
Requiring Data Entry

In most Tables, there are usually at least a few Fields that absolutely must contain data in order for the record to be meaningful. For example, at the absolute minimum, a customer record needs to have the customer’s first and last name—otherwise, why bother entering it? You can specify that a field must contain data to prevent users from leaving out important information when they are entering data.

This lesson explains how you can make sure that a field has a value for each record.

1. Make sure the table is displayed in Design View and click the field you want to require data entry for.

2. Click the Required box in the Field Properties section.

Here’s how to prevent a user from leaving out data in a field.

3. Click the list arrow and select Yes.

From now on, if a user tries to add a record without entering a value for this field, Access will display a dialog box stating that the field cannot contain a null value.

Exercise

- **Exercise File:** CustomerTours.accdb
- **Exercise:** In the tblCustomers table, make LastName a required field. Add a new field to the table, leaving the LastName field blank. Try to save the record (Access won’t let you). Delete the new record.

![Figure 4-13: Making the LastName field required.](image-url)
Validating Data

Without a doubt, data validation is the most powerful tool you can use to prevent data-entry errors. With data validation, Access actually tests data to make sure that it conforms to what you want to appear in the table. If the incoming data doesn’t meet your requirements, Access rejects it and displays an error message. For example, in an Employees table you could specify that the DOB field cannot be later than today’s date. (You can’t have employees with birthdays in the future, after all.)

Data validation works best in number, currency, and date/time Fields. You can create a validation rule for text entries, but doing so can be complicated—even if you want to test a lot of text variables.

There are actually two boxes that relate to data validation:

- **Validation Rule box**: Used to specify the requirements for data entered into the field.

- **Validation Text box**: Used to specify the message that will be displayed to the user when data that violates the validation rule is entered.

Creating data validation rules can be a little tricky—you create a data validation using the same hard-to-remember operators that you use in filters and queries. Here’s how:

1. Make sure the table is displayed in Design View and click the field you want to apply a validation rule to.

2. Click the Validation Rule box in the Field Properties section.

3. Enter an expression you want to use to validate the field’s data.

Table 4-6: Data Validation Examples describes some data validations that you can modify and use in your Tables.

Next you have to specify the error message that Access will display if someone tries to break your validation rule by entering a future date.

4. Click the Validation Text box in the Field Properties section.

5. Type the text that Access will display when the user tries to enter incorrect data for the field.

Now whenever a user violates the validation rule, Access will display the validation text.
Consider Table 4-6: Data Validation Examples your data validation “cheat sheet.” It contains samples of the most common types of validation rules. Feel free to copy, modify, or mix and match these examples to create your own validation rules.

<table>
<thead>
<tr>
<th>Validation Rule</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;100</td>
<td>Must be less than 100.</td>
</tr>
<tr>
<td>&lt;=100</td>
<td>Must be less than or equal to 100.</td>
</tr>
<tr>
<td><strong>Between 1 and 10</strong></td>
<td>Must be between 1 and 10.</td>
</tr>
<tr>
<td>&lt;&gt;0</td>
<td>Must not equal 0.</td>
</tr>
<tr>
<td>&lt;1/1/95</td>
<td>Must be a date before 1/1/95.</td>
</tr>
<tr>
<td>&gt;= Date()</td>
<td>Must be today’s date or later.</td>
</tr>
<tr>
<td>&lt;= Date()</td>
<td>Must be today’s date or earlier.</td>
</tr>
<tr>
<td>&quot;Business&quot; Or &quot;Pleasure&quot; Or &quot;Other&quot;</td>
<td>Must be “Business” or “Pleasure” or “Other.”</td>
</tr>
<tr>
<td>Like &quot;??&quot;</td>
<td>Must have two characters.</td>
</tr>
<tr>
<td>Like &quot;####&quot;</td>
<td>Must have four numbers.</td>
</tr>
</tbody>
</table>
Creating an Input Mask

An **Input Mask** limits the amount and type of information that can be entered in a field. You have probably already seen an example of an input mask on an ordinary paper form—the type of form that wants you to write down your phone number or social security number a certain way and thus provides you with a guide like (___) ____-____ or ____-_____. Look familiar? That’s an input mask, pure and simple. There are two ways to create an input mask:

- **Use the Input Mask Wizard** to create the input mask for you (the fast and easy way). The only problem with the **Input Mask Wizard** is that it can only help you create input masks for **phone numbers, social security numbers, Zip Codes**, and **date and time Fields**.

- **Create the input mask** yourself by typing a series of characters in the **Input Mask** box (the hard way). If you want to use this method, refer to **Table 4-7: Input Mask Characters** to see what you have to enter in order to create an input mask.

In this lesson you will learn how to use the **Input Mask Wizard** to add an input mask to a field.

1. Make sure the table is displayed in **Design View** and click the field you want to create an input mask for.

2. Click the **Input Mask** box in the Field Properties area (the bottom half of the window). The Build button appears next to the Input Mask box.

3. Click the Build button to start the Input Wizard.

4. Select an input mask from the predefined list and click Next.

5. Make modifications to the characters in the Input Mask box, if desired. Click the **Placeholder**

---

**Exercise**

- **Exercise File**: CustomerTours.accdb
- **Exercise**: In the tblCustomers table, Create an input mask for the Phone field using the **Phone Number input mask**. Select the “**With the symbols in the mask**” option. Save the change and switch to **Datasheet View**. Go to the **New record** row and click in the **Phone** field to see the input mask.

---

**Figure 4-16**: The Input Mask Wizard.

**Figure 4-17**: An input mask in the Phone field.
**Working with Tables and Fields**

**character** list arrow to select a different placeholder, if desired. Click **Next**.

6. Click **Finish**.

Now whenever you enter data into that field, the input mask will appear to guide you.

Table 4-7: Input Mask Characters

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Numbers 0 to 9 required; plus and minus signs not allowed.</td>
<td>&amp;</td>
<td>Character or space required.</td>
</tr>
<tr>
<td>9</td>
<td>Number or space optional; plus and minus signs not allowed.</td>
<td>C</td>
<td>Character or space optional.</td>
</tr>
<tr>
<td>#</td>
<td>Number or space optional; plus and minus signs not allowed.</td>
<td>&lt;</td>
<td>Converts the following characters to lowercase.</td>
</tr>
<tr>
<td>. , ; : /</td>
<td>Decimal point, thousands, date, and time separators.</td>
<td>&gt;</td>
<td>Converts the following characters to uppercase.</td>
</tr>
<tr>
<td>A</td>
<td>Letter or number required.</td>
<td>!</td>
<td>Displays characters from right to left, rather than left to right.</td>
</tr>
<tr>
<td>a</td>
<td>Letter or number optional.</td>
<td>\</td>
<td>Displays the following input mask character. For example, * would display *.</td>
</tr>
<tr>
<td>L</td>
<td>Letters A to Z required.</td>
<td>Password</td>
<td>Displays an asterisk( * ) for each character you type.</td>
</tr>
<tr>
<td>?</td>
<td>Letter or number optional.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Creating a Lookup Field

Lookup Fields are definitely one of the coolest and most powerful features in Access. A lookup field lets you pick a field’s entry from a list of values. There are two ways that a lookup field can get its list of values:

- **From a Lookup List:** A list of values in a table or query. For example, instead of entering a CustomerID number, you could select it from a list of customers.

- **From a Value List:** A list of values or options that you enter yourself. For example, you could add the values “FedEx,” “UPS,” and “AirBorne” to a Shipping field.

In this lesson, we’ll look at the first way—using a list of values in a table or query.

1. Display the table in **Design View**.

2. Click the field’s **Data Type** box, click the **list arrow**, and select **Lookup Wizard**.

   The Lookup Wizard dialog box appears, asking if you want your lookup field to get its values from another table or query or if you want to type a list of options yourself.

3. Click the **I want the lookup field to get the values from another table or query** option and click **Next**.

   The next step in the Lookup Wizard is to select the table or query that contains the values for your lookup field. Because you can use queries to sort and filter information, consider using them as the source for your lookup Fields.

4. Select the table or query you want to use for the lookup list and click **Next**.

   Now you have to select the Fields that contain the values you want to display in your lookup field.

   This step can be a little confusing at first. You need to add the field that contains the value you want to enter—for example, the CustomerID field—but you also want to add several Fields that will display more meaningful information in the value list, such as the LastName and FirstName Fields.

5. Double-click the Fields you want to add to the lookup field and click **Next**.

   **Other Ways to Add Fields:**
   Select the field in the **Available Fields** list and click the **arrow** buttons to add or remove them from the Selected Fields list.

---

**Exercise**

- **Exercise File:** CustomerTours.accdb
- **Exercise:** Open the tblCustomerTours table in **Design View**. Click the **Data Type** box next to the CustomerID field, click the list arrow, and select **Lookup Wizard**. Select the tblCustomers table, add the CustomerID, LastName, and FirstName Fields to the **Selected Fields** list, and finish the **Lookup Wizard**. Save the changes and switch to **Datasheet View**. Click the CustomerID field for any record, then click the **list arrow** that appears to access a list of customers. Press `<Esc>`.
The next step in the Lookup Wizard dialog box is selecting a sort order for your list. You can sort records by up to four Fields, in either ascending or descending order.

6. Select a sort order for your list (optional) and click Next.

This next step allows you to adjust the width of the columns in your lookup list. To adjust the width of a column, drag its right edge to the width you want, or double-click the right edge of the column heading to get the best fit.

You can also indicate whether or not to include the primary key in the column by checking or unchecking the “Hide key column” check box. Any primary key Fields will be hidden by default to make the lookup field less confusing.

Tip: If the table or query you are working with does not have a primary key, the “Hide key column” check box will not appear. The Lookup Wizard will instead include an additional step where you will be prompted to select the column that uniquely identifies the row.

7. Adjust the width of the columns that will appear in the lookup list and, if necessary, select whether or not to hide the key column. Click Next. If necessary, click Next again.

8. Enter a label for the lookup column and click Finish.

Tip: You can select to Allow Multiple Values. If you check this box, Access allows you to select multiple values from your list and store them in a single field (a multi-value field) For example, if a single product is made in two different countries, you can display both countries.

Now you can use the lookup list.

9. Click the Design tab under Table Tools on the Ribbon and click the View button in the View group to return to Datasheet View. Click Yes to save the table.

10. Click any record in the column where you created the lookup list. Click the list arrow and select a value from the list.

Tip: You can also select an option from a lookup field by typing the first few letters of the entry.
Creating a Value List

Similar to the lookup list, a **value list** displays a list of values in a drop-down list. Unlike a lookup list, which displays data in a table or query, a value list displays a list of options that you manually enter. A value list is useful if you enter the same data in a field again and again. For example, if you ship a product using three different courier services, you could create a value list that displays the three courier services, such as AirBorne, FedEx, and UPS.

Although it’s possible to change the options displayed in a value list, you should only use value lists for values that will not change very often. If you want to display a lot of options, such as a list of state abbreviations or values that may change frequently, you should create a table to store those values and then display them with a lookup list instead. It’s a lot easier to change values in a table than it is to change options in a value list.

This lesson will show you how to create a value list that contains several static options.

1. Display the table in **Design View**.

2. Click the field’s **Data Type** box, click the **list arrow**, and select **Lookup Wizard**.
   
   The Lookup Wizard dialog box appears, asking if you want your lookup field to get its values from another table or query or if you want to type a list of options yourself.

3. Click the **I will type in the values that I want** option and click **Next**.
   
   The next step of the Lookup Wizard appears. This step is pretty easy—simply enter the options you want to be displayed in the value list.

4. In **Col1**, enter the values you want to be displayed in the value list. Resize the column if necessary and click **Next**.
   
   **Tip:** There is only one column of values by default, but you can add more. If you do so, an extra screen will appear after you click **Next**, asking you which part of the column contains the values you actually want to store in the database (the other columns will just be there to give you more information about which value to select).

5. Enter a label for the **lookup** column and click **Finish**.
   
   **Tip:** Here you can select to Allow Multiple Values. If you check this box, Access will allow
you to select multiple values from your list and store them in a single field.

Once you return to Datasheet View and click the list arrow in any record in the column, you’ll be able to see the value list you entered and select a value to populate the field.
Modifying a Lookup List

Modifying an existing lookup field isn’t nearly as straightforward as creating one. You can display and modify the properties for a lookup field by clicking on the Lookup tab in the Field Properties section. There are many different reasons why you would want to modify a lookup field, including:

- To sort the records in a lookup list. For example, to sort the records in a lookup list alphabetically by last name.
- To add, change, or delete the static options in a value list. For example, you could add “U.S. Postal Service” to a Ship Via value list.

Modify a lookup list

1. Display the table in Design View.
   Display and change the properties for a lookup field by clicking the Lookup tab in the Field Properties section.

2. Click the field name for a field that contains a lookup list based on a table or query, then click the Lookup tab in the Field Properties section.
   The properties for the field’s lookup field are displayed. You can learn more about these properties in Table 4-8: Lookup Field Properties.

3. Click the Row Source box.
   The data in this box (which should look something like `SELECT [tblCustomers].[CustomerID]`) is a SQL statement. SQL (Structured Query Language) is a language most database programs use to Create queries; it tells lookup Fields where to get their values. Fortunately, you don’t have to know how to write SQL to modify a lookup field—you can use the familiar query grid to create the SQL statement for you.

4. Click the Row Source button.
   The Query Builder window appears, displaying a query grid. Here you can change the Fields included in the lookup list, or you could add or remove a sort.

5. Make the desired changes and then click the Query Builder window’s Close button. Click Yes to save the changes.

Exercise

- Exercise File: CustomerTours.accdb
- Exercise: View the tblCustomerTours table in Design View. Open the CustomerID field’s lookup field in the Query Builder window and sort Ascending by the LastName field. Close the Query Builder window and save your changes. Then add another option, “US Mail” to the Ship Via field’s value list. Save your changes.
Modify a value list

1. Display the table in Design View.
   Display and change the properties for a lookup field by clicking the Lookup tab in the Field Properties section.

2. Click the field name for a field that contains a value list, then click the Lookup tab in the Field Properties section.
   The properties for the field’s lookup field are displayed.

3. Click the Row Source box.
   The Row Source box contains the value list options. For example, it could contain the text "Airbone","FedEx","UPS". You can add or edit options in the value list by typing in the Row Source box—just make sure that the options are enclosed by quotation marks (" ) and separated by a semi colon (:).

4. Edit the value list options as desired in the Row Source box.

5. Save your changes.

Table 4-8: Lookup Field Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Control</td>
<td>Determines whether the lookup field is a text box, combo box, or list box.</td>
</tr>
<tr>
<td>Row Source Type</td>
<td>Determines how Access provides data to the lookup field: from a table or query, from a list of values specified in the Row Source box, or from a list of field names in a table or query.</td>
</tr>
<tr>
<td>Row Source</td>
<td>Determines what is displayed in the lookup field. The Row Source property setting depends on the Row Source Type property setting.</td>
</tr>
<tr>
<td>Bound Column</td>
<td>The column in the lookup list that contains the value that is actually stored in the field. The bound column is the first column (1) by default.</td>
</tr>
<tr>
<td>Column Count</td>
<td>The number of columns that are displayed in the lookup field list.</td>
</tr>
<tr>
<td>Column Heads</td>
<td>Determines whether the field names, captions or first row of data is used as a column heading.</td>
</tr>
<tr>
<td>Column Widths</td>
<td>The width of each column that is displayed in the lookup field list. Setting a column width to 0 hides the column.</td>
</tr>
<tr>
<td>List Rows</td>
<td>The maximum number of rows that appear in the list box.</td>
</tr>
<tr>
<td>List Width</td>
<td>The width of the list box that is displayed.</td>
</tr>
<tr>
<td>Limit to List</td>
<td>Determines whether a field can accept a value that is not in the lookup list.</td>
</tr>
<tr>
<td>Allow Multiple Values</td>
<td>Determines whether multiple values for this lookup column are allowed.</td>
</tr>
<tr>
<td>Allows Value List Edits</td>
<td>Determines whether the values in the lookup column can be edited.</td>
</tr>
<tr>
<td>List Items Edit Form</td>
<td>Lists a form to open when lookup values are being edited.</td>
</tr>
<tr>
<td>Show Only Row Source Values</td>
<td>Determines whether only values that match the row source are displayed.</td>
</tr>
</tbody>
</table>

Figure 4-24: In Design View, modify a value list on the Lookup tab in the Field Properties area.
Working with Tables and Fields

Review

Quiz Questions

1. To view and modify the Field Properties for a table, open the table in ________ View.
   A. Table
   B. Property
   C. Design
   D. Datasheet

2. Indexing fields speeds up searching and sorting. (True or False?)

3. Which of the following fields would NOT make a suitable primary key?
   A. A memo field
   B. A social security number
   C. An AutoNumber field
   D. An invoice number

4. In Design View, commands for inserting and deleting rows are found on the Design tab in the ________ group.
   A. Show/Hide
   B. Tools
   C. Add
   D. Insert

5. Text entered in a field’s Description box will appear in a pop-up window whenever a user selects that field. (True or False?)

6. The Field Size property works differently, depending on whether the field is a text or number field. (True or False?)

7. Changing the formatting of a field changes how the information is stored in the field. (True or False?)

8. Which of the following Format properties would display the full name of the month?
   A. mmmm
   B. mm
   C. FULLMONTH
   D. MONTH

9. What would adding a > to the Format box of a text field do?
   A. Require all characters entered in the field to be uppercase.
   B. Display the text in the field in uppercase.
   C. Require all characters in the field to be numbers.
   D. Display the text in the field in a larger font.

10. Which of the following can you use to specify a value that is automatically entered in a field when a new record is created?
    A. A lookup value
    B. A numeric value
11. The Required property determines if a user must enter a value in a field or not.

12. There are two properties that relate to validation. (True or False?)

13. An input mask only affects how information is displayed in a field - not how it is actually stored. (True or False?)

14. You want to create a field that lets you add a customer's name by picking it from a list arrow. Which of the following fields would let you do this?
   A. A memo field
   B. An OLE field
   C. A lookup field
   D. A hyperlink field

15. A value list looks up values in a table or query. (True or False?)

16. Where in the Field Properties can you go to modify a Value or Lookup list?
   A. The Lookup tab
   B. The General tab
   C. The Lookup field
   D. The SQL field
Quiz Answers

1. C. Display a table in Design View to see its Field Properties.
2. True. Indexing allows you to search or sort fields faster.
3. A. You can’t use memo fields as primary keys.
4. In Design View, commands for inserting and deleting columns are found on the Design tab in the Tools group.
5. False. Text in the field’s Description box will appear in the Status bar when a user selects that field.
6. True. Text fields and Number/Currency fields have a different set of Field Size properties.
7. False. Formatting a field only changes how the field displays information, not how it stores it.
8. A. mmmm would display the full name of the month.
9. B. Adding a > to a text field’s Format box would display all its text in uppercase.
10. D. A default value lets you specify a value that is automatically entered in a field when a new record is created.
11. True. The required property does determine if a user must enter a value in a field or not.
12. True. The Validation Rule and Validation Text properties both help you create a validation.
13. False. Depending on your preferences, an input mask can store information with or without symbols (i.e. (800) 555-1212 vs. 8005551212).
14. C. A lookup field lets you select a value from a list arrow.
15. False. A value list contains a list of preset values. A lookup list looks up values in a table or query.
16. A. The Lookup tab lets you modify a Value or Lookup list.
This chapter covers what many people agree is one of the most difficult database concepts—how to Create and work with relational databases. A relational database contains two or more Tables that are related to each other in some way. For example, a database might contain a Customers table and an Invoices table that contains the customer’s orders.

In this chapter you will learn how to link Tables in an existing database together in a one-to-many relationship to create a relational database. You will also learn how to enforce referential integrity between those Tables to keep records in related Fields valid and accurate.

Relational databases can be confusing at first, so we’ll take things slowly and explain everything in great detail as we go. Let’s get started!

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Understanding Table Relationships

There are two basic types of databases:

- **Flat File**: Think of a Rolodex when you think of a flat-file database. A flat-file database stores all of its information—names, addresses, etc.—in the same place, just like addresses are stored on a Rolodex card. Flat-file databases are incredibly simple to create and use, but they're not very powerful or well suited to many business tasks.

- **Relational**: A relational database contains multiple tables that are related through matching fields. Figure 5-1 illustrates the design of a relational database. It has two tables—one that stores customer names and addresses, and another that stores customer orders. The two tables are related or linked by a common field. Relational databases are very powerful, but developing one takes a lot of skill, a lot of practice, and a strong understanding of tables and fields.

Microsoft Access can create either type of database—flat file or relational. However, most Access databases tend to be of the relational type.

Still fuzzy about how relational databases work? Look closer at Figure 5-1. To track customers and their orders, the database uses two tables: Customers and Orders. Each table contains fields that store similar information. The Customers table contains only information about customers and their addresses. The Orders table contains only information about any orders that were placed—it doesn't contain any information about the customers. The two tables both have an ID field, and it's this ID field that relates or links the two tables.

Relational databases save storage space by cutting down on duplicate data. For example, the database in Figure 5-1 stores information in two related tables and eliminates the need to reenter a customer’s name and address each time that customer places a new order.

### Planning a relational database

Relational databases require lots of planning ahead. Before you attempt to create one, sit down with a pen and paper and walk through the following steps:

- **Determine the Purpose of the Database**: Write down a list of the reports and lists that you want to come out of the database. This may seem a little backward at first, but these reports are the reason you’re creating the database.
Make a list of the reports and lists you want to see and then sketch some samples of these reports and lists—be as detailed as possible. This will help determine the Tables and Fields to include in your database.

- **Write Down the Fields You Need:** This should be an easy step once you have determined the purpose of your database and have sketched some sample reports and lists.

- **Organize and Group Related Fields into Separate Tables:** Each table in the database should be based on only one subject. By breaking each subject into its own table, you avoid redundant information and make the database more organized. If your table contains Fields like Item 1, Item 2, Item 3, Item 4, and so on, you should probably break each item up into its own table.

- **Identify and Add Fields Common to Each Table:** In Figure 5-1, the Customers table’s ID field links to the Orders table’s ID field. One of the linked Fields should be the table’s primary key.

- **Sketch a Diagram of Your Database:** Create a diagram of your database similar to the one shown in Figure 3-3. Draw a box for each of your Tables and write the table’s field names inside that box. Draw a line between the related Fields. Most table relationships are a one-to-many relationship. This means that a record in one table may be related to one or more records in another table.

  For example, in Figure 5-1, each record in the Customers table is related to one or more records in the Orders table. This makes sense because, hopefully, most customers will place more than one order. You should indicate the two sides of the relationship by drawing a “1” on the “one” side of the relationship line and an infinity symbol on the “many” side of the relationship line.

All this writing and planning may seem like a lot of work, but they’re both critical steps in creating a sound database.
Creating Relationships Between Tables

Once you begin to understand the concept of relational databases, the process of actually linking the Tables in a database is rather simple. You link related Tables by connecting the table’s common Fields in Access’s Relationships window. The Relationships window lets you view, Create, and modify relationships among Tables in a database.

Keep the following rules in mind as you link two Tables:

- Linked Fields should be (almost) identical.
- Related Fields must have the same data type and field size and must contain the same kind of information. Related Fields don’t have to have the same field name but they should, to avoid confusion. The most common problem people have when they try to link two Tables is caused by Fields with different data types and/or sizes.
- The primary key in one table is usually linked with a matching field in the other table.
- Fields related to an AutoNumber primary key field must be Number Fields with the Long Integer Field Size.

Now you’re ready to create a relationship between the Tables in your database. Here’s how:

1. Click the Database Tools tab on the Ribbon and click the Relationships button in the Relationships group.

   The Design contextual tab appears under Relationship Tools and a Relationships window appears.

   Tip: If relationships already exist between the Tables in your database, each of these Tables will appear in a small box with lines connecting the table’s linked Fields.

   First you have to add the Tables that you want to relate using the Show Table dialog box.

2. Click the Show Table button in the Relationships group.

   The Show Table dialog box appears.

3. Click the table you want to add and click Add.

   Repeat as necessary.

   The table appears in the Relationships window.
Creating Relational Databases

4. Click the **Close** button in the Show Table dialog box.

Now you’re ready to start relating the Tables you added. Relating Tables may sound difficult, but it’s really nothing more than dragging and dropping the field you want to use to link one table to the other.

✔ **Tip:** Before you can drag and drop the matching field from one table to the other, you have to make sure the linking Fields in both Tables are visible.

5. Click the related field in the first table and drag it to the related field in the second table.

Dragging a field from one table to another in the Relationships window links the two Tables using the selected field.

✔ **Tip:** Access is very picky about where you point, click, drag, and drop. You need to be very accurate and drag the pointer right next to the field you’re linking to.

The Edit Relationships dialog box appears. What’s especially important here is the Enforce Referential Integrity check box. Referential integrity helps you avoid “orphan” records and maintains database accuracy. For example, checking the Enforce Referential Integrity box would ensure that you could not enter an invoice for a customer in an Invoice table unless that same customer existed in a Customers table. We’ll discuss referential integrity more in another lesson.

6. Check the **Enforce Referential Integrity** (optional), then click the **Create** button to create the relationship.

The Tables are now linked.

7. Click the **Close** button in the Relationships group on the Design tab and click **Yes** to save the changes.

⚠ **Other Ways to Relate Tables:**
Display a table in Datasheet View, click the **Table** tab under Table Tools on the Ribbon, and click the **Relationships** button in the Relationships group to display the Relationships window.

✔ **Tips**

✔ If you can’t see all your table relationships, click the **Relationships** button again in the Relationships group on the Design tab (under Table Tools). Click **All Relationships** and you should see the link.
Enforcing Referential Integrity

When you create a relationship between two Tables, it is usually a good idea to enforce referential integrity. What does that mean? Referential integrity keeps records in related Fields valid and accurate. Referential integrity ensures that you don’t accidentally change or delete related data in one table but not in the other. For example, say you were using two related Social Security Fields to link two Tables. Referential integrity would not allow you to change the Social Security number in one record without changing the Social Security number in the other related records.

Access is very picky about when you can set referential integrity. You can only use referential integrity when all of the following conditions are met:

- One of the linked Fields is a primary key
- The related Fields are the same data type and size. (If you are using an AutoNumber field, you can relate it to a Number field with a Long Integer Field size.)
- Both Tables are in the same Access database.
- You can’t have a record in a related table unless a matching record already exists in the primary table. Orphan data in a related table is the most common problem people encounter when attempting to establish referential integrity.

Once you have established referential integrity, the following rules are set:

- You can’t add a record to a related table unless a matching record already exists in the primary table.
- You can’t change the value of a primary key in the primary table if matching records exist in the related table (unless you select the Cascade Update Related Fields option).
- You can’t delete a record from a primary table if matching records exist in a related table (unless you select the Cascade Delete Related Records option).

In this lesson you will learn how to enforce referential integrity.

1. Click the Database Tools tab on the Ribbon and click the Relationships button in the Relationships group. The Relationships window appears.

2. If necessary, click the Design contextual tab, click the Show Table button in the Relationships group, and add Tables to the Relationships window.

Once you have more than one table added, you can relate the Tables and enforce referential integrity.

Exercise

- Exercise File: Company.accdb
- Exercise: In the Relationships window, link the CustomerID field in the tblCustomers table to the CustomerID field in the tblCustomerTours table, and check the Enforce Referential Integrity, Cascade Update Related Fields and Cascade Deleted Fields boxes. Save the changes.

Figure 5-6: The Edit Relationships dialog box with Referential Integrity enforced.

Figure 5-7: Related Tables.

Creating Relational Databases

One-to-many relationship: The 1 symbol indicates that each CustomerID number can be listed only one time in the tblCustomers table and the infinity symbol indicates that each CustomerID number can be listed many times in the tblCustomerTours table.
3. Click the related field in the first table and drag it to the related field in the second table.

The Edit Relationships dialog box appears.

Other Ways to Display the Edit Relationships Dialog Box:
To edit (instead of Create) a relationship, double-click the line connecting the Tables to display the Edit Relationships dialog box. Or, go to the Tools group on the Design tab and click Edit Relationships.

Now let’s enforce referential integrity.

4. Check the Enforce Referential Integrity box.

If you get an error message, it’s because your Tables and Fields don’t meet all required conditions.

There are two other very important boxes in the Edit Relationships dialog box:

- **Cascade Update Related Fields:** When you change data in the main field of one table, Access will automatically update the matching data in the related table.

- **Cascade Delete Related Records:** When you delete a record in the main table, Access will automatically delete any matching records in the related table.

Think twice before using these powerful options.

5. If you want changes to the primary field of the primary table copied to the related field in the related table, check the Cascade Update Related Fields box.

6. If you want Access to automatically delete orphan records in the related table, check the Cascade Delete Related Records box.

7. Click Create to create the relationship (or click OK if you are editing an existing relationship).

Access creates the relationship between the two Tables and enforces referential integrity between them. Notice that the join line between the Tables looks different than normal. This relationship indicates that referential integrity is being enforced between the two Tables and that the Tables have a one-to-many relationship (more about that in another lesson).

8. Click the Close button in the Relationships group on the Design tab and click Yes to save the changes.
Printing and Deleting Relationships

Sometimes you may want to print a hard copy of the Relationships window or you may want to delete the relationship between two Tables.

Print the Relationships window

1. Click the Database Tools tab on the Ribbon and click the Relationships button in the Relationships group.
   Click the Design contextual tab that appears under the Relationship Tools tab.
2. Click the Relationship Report button in the Tools group.
   A report showing the Tables and relationships appears in Print Preview mode.
   Tip: If you want to modify the report before printing, click the Close Print Preview button and edit the report in Design View.
3. Click the Print button in the Print group on the Print Preview tab.
   The Print dialog box appears.
4. Select desired print settings and click OK.
   The Relationships report is printed.
5. Click the Close Print Preview button in the Close Preview group.
   The report appears in Design View.
6. Click the Relationships report’s Close button and save changes if you want to use the report in the future.

Delete a table relationship

Access is very restrictive about letting you modify a related table, and often you must temporarily delete the relationship between two Tables, modify one of the Tables, and then re-connect them. Here’s how to delete a table relationship.

1. Click the Database Tools tab on the Ribbon and click the Relationships button in the Relationships group.
   The Design contextual tab appears under Relationship Tools.

Exercise

- Exercise File: Company.accdb
- Exercise: Display a Relationship Report in Print Preview. Right-click the join line between the tblTours table and the tblCustomerTours table and select Delete, but then click No to cancel deletion of the link.
Creating Relational Databases

2. Click the join line that connects the Tables and press `<Delete>`.

3. Click Yes to confirm the deletion.

The table relationship is removed.

⚠️ Other Ways to Delete a Table Relationship:
Right-click the join line connecting the related Tables and select Delete. Click Yes.
Understanding Relationship Types

When you link two Tables together, they form one of three possible relationships. This information is rather technical, but it’s good to know if you’re working with related or linked Tables. Look over Table 5-1: Types of Relationships to get a better understanding of table relationships.

Table 5-1: Types of Relationships

<table>
<thead>
<tr>
<th>Relationship</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>One to One</td>
<td>Each record in a table relates to one record in another table. This is the simplest type of relationship, but it doesn’t occur very often because it’s usually easier to store such information in one table instead of two. <strong>Example:</strong> Each customer has one credit report.</td>
</tr>
<tr>
<td>One to Many</td>
<td>Each record in a table relates to one or more records in another table. This is the most common type of relationship. <strong>Example:</strong> Each customer has one or more invoices.</td>
</tr>
<tr>
<td>Many to Many</td>
<td>One or more records in a table relate to one or more records in another table. Many-to-many relationships can be very confusing. To Create a many-to-many relationship, use a third intermediate table that contains the primary keys from each of the two Tables in the relationship. Such an intermediate table is called a junction table. <strong>Example:</strong> Each sales representative sells several products, and each product is sold by several sales representatives.</td>
</tr>
</tbody>
</table>
Creating Relational Databases

Review

Quiz Questions

1. A flatfile database stores information in a single table. (True or False?)

2. You can use fields with different data types to link two tables. (True or False?)

3. If the Cascade Delete Related Records referential integrity option is selected, when you delete a record in the main table, Access will automatically delete any matching records in the related table. (True or False?)

4. Once you create a relationship between tables, that relationship can never be deleted. (True or False?)

5. Which of the following is NOT a type of table relationship in Access?
   A. One to One
   B. One to Many
   C. Infinite
   D. Many to Many
Quiz Answers


2. False. With the exception of AutoNumber and Number fields, related fields must always have the same data type in order to be used to join two tables.

3. True. The Delete Cascade Related Records option automatically deletes records in any related tables.

4. False. You can delete table relationships.

5. C. Infinite is not a type of table relationship in Access.
## Working with Queries

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Understanding Different Types of Queries</td>
<td>113</td>
</tr>
<tr>
<td>Creating a Multiple Table Query</td>
<td>114</td>
</tr>
<tr>
<td>Creating a Calculated Field</td>
<td>116</td>
</tr>
<tr>
<td>Working with Expressions and the Expression Builder</td>
<td>118</td>
</tr>
<tr>
<td>Using an IIf Function</td>
<td>120</td>
</tr>
<tr>
<td>Summarizing Groups of Records</td>
<td>122</td>
</tr>
<tr>
<td>Display Top or Bottom Values</td>
<td>124</td>
</tr>
<tr>
<td>Parameter Queries</td>
<td>125</td>
</tr>
<tr>
<td>Finding Duplicate Records</td>
<td>127</td>
</tr>
<tr>
<td>Finding Unmatched Records</td>
<td>128</td>
</tr>
<tr>
<td>Crosstab Queries</td>
<td>130</td>
</tr>
<tr>
<td>Delete Queries</td>
<td>132</td>
</tr>
<tr>
<td>Append Queries</td>
<td>134</td>
</tr>
<tr>
<td>Make Table Queries</td>
<td>136</td>
</tr>
<tr>
<td>Update Queries</td>
<td>138</td>
</tr>
</tbody>
</table>

Queries are the stars of Microsoft Access. Queries make sense out of all the thousands of jumbled records and display exactly what you need to know. Queries can tell you the average price of tea in China or which customers bought the most parakeet food from your company. Queries can even make widespread changes to the records in your database without wearing out your mouse and keyboard! For example, a delete query can automatically delete a whole bunch of records that meet your criteria.

In this chapter you will learn how to harness the power of queries. First you will learn about all the different types of queries: simple select queries, parameter queries that prompt you for more information, crosstab queries that summarize records in an easy-to-understand format, and action queries that actually modify the records in your database.

All this power comes with a price tag: Many people find that queries are one of the more difficult database objects, and learning how to fully utilize queries isn’t something you can learn in an afternoon. By the time you finish this chapter, however, you will be on your way toward understanding and mastering queries.

### Using Exercise Files

This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Understanding Different Types of Queries

Up until now, when you thought of a query, you were actually probably thinking of a select query—a particular type of query. Select queries are by far the most common and useful type of query in Access; however, there are other types of queries that are also important. Table 6-1: Types of Queries provides a quick overview of different types of queries you’ll find in Microsoft Access.

<table>
<thead>
<tr>
<th>Table 6-1: Types of Queries</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select Query</strong></td>
</tr>
<tr>
<td><strong>Parameter Query</strong></td>
</tr>
<tr>
<td><strong>Crosstab Query</strong></td>
</tr>
<tr>
<td><strong>Make Table Query</strong></td>
</tr>
<tr>
<td><strong>Append Query</strong></td>
</tr>
<tr>
<td><strong>Delete Query</strong></td>
</tr>
<tr>
<td><strong>Update Query</strong></td>
</tr>
<tr>
<td><strong>Union Query</strong></td>
</tr>
<tr>
<td><strong>Pass-Through Query</strong></td>
</tr>
<tr>
<td><strong>Data Definition Query</strong></td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File**: None required.
- **Exercise**: Study and understand the different query types.

Figure 6-1: The Query Type group on the Design tab.
Creating a Multiple Table Query

In Access you will often need to look at and analyze information that comes from not one but several different Tables. Since Access is a relational database, it’s easy to establish a relationship between two or more Tables and look at the information that goes together.

Just like it sounds, a multiple-table query blends together information from two or more related Tables. Working with a multiple-table query usually isn’t much different from working with a single-table query. You tell Access which Tables you want to use in your query and specify the Fields and criteria you want to see. The main difference between a multiple-table query and a single-table query is that with multiple-table queries, Access creates a link between related Tables. When the query is displayed in Design View, this link (called a join) appears as a line that connects two or more Tables.

When you create a multiple-table query, Access will usually link or join the Tables automatically. Sometimes, however, you will have to manually join two Tables in the query Design window. You can manually join two Tables by dragging a field from one table’s field list to the matching field in the other table’s field list. If the Tables don’t have any Fields in common, you must add another table to act as a bridge between them.

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.

   The Show Table dialog box appears. Here you need to choose the Tables or queries you want to use for the query.

2. Select the table or query you want to use and click Add.

3. Repeat Step 2 as necessary for additional Tables or queries. Click Close when you’re finished.

   If two Tables are related, Access will automatically connect their common Fields with a join line. If the Tables aren’t related you will have to manually join the Tables by dragging a field from one table’s field list to the matching field in the other table’s field list.

   Tip: To remove a join line, click the join line and press <Delete>.

4. If Access doesn’t automatically join the Tables, click the related field in the first table and drag it to the

Exercise

• Exercise File: Query.accdb

• Exercise: Create a multiple table query with limiting criteria:

   Create a query in Design View. Add the tblEmployees, tblCustomerTours, and tblTours Tables to the query. Link the EmployeeID field in the tblEmployees table with the Employee field in the tblCustomerTours table. Add the following Fields to the Design grid:

<table>
<thead>
<tr>
<th>tblEmployees</th>
<th>tblTours</th>
<th>tblCustomerTours</th>
</tr>
</thead>
<tbody>
<tr>
<td>LastName</td>
<td>FirstName</td>
<td>TourName</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cost</td>
</tr>
</tbody>
</table>

   Add the criteria “Between 1/1/00 and 3/31/00” to the Date column. Sort the Date column Ascending. Save the query as qryFirstQuarterTours. Run the query.
related field in the second table. Repeat as necessary to connect all the Tables.

Next you need to specify the Fields you want to appear in the query results. Because field lists don’t have much room to display their contents, you may have to scroll up or down the list in order to find the field you want.

5. Double-click each field you want to include in the query from the field list.

   **Other Ways to Add a Field to a Query:**
   - Drag the field from the field list onto the Design grid.

Next you need to specify any criteria for the query.

6. In the Design grid, enter any desired search criteria for a field in the **Criteria** row.

7. If desired, click in the **Sort** box for a field, click the **list arrow**, and select a sort order.

8. Click the **Save** button on the Quick Access Toolbar, enter a name for the query, and click **OK**.

9. Click the **Run** button in the Results group.

   The query results appear in Datasheet View.

10. Click the query window’s **Close** button.

![Figure 6-2: Creating a multiple table query in Design View.](image-url)
Creating a Calculated Field

Normally, when you create a database, you should only have to enter the information you need, and not have to worry about data or values that Access calculates based on information that is already stored in the database. A calculated field performs some type of arithmetic on one or more Fields in a database to come up with a completely new field. For example, if your database has an Order Total field and a Tax Rate field, Access can calculate these two Fields to find out the Sales Tax for each order:

\[ \text{Order Total} \times \text{Tax Rate} = \text{Sales Tax} \]

You must create an expression (or formula) to perform a calculation. To enter Fields in an expression, type the field name in brackets ([Order Total]). If a field name exists in more than one table, you will need to enter the name of the table that contains the field in brackets ([tblCustomerTours]) followed by an exclamation mark (!). Then type the field name in brackets, such as [Order Total]. For example if an Orders table and a Shipping table both contain a Date field, you would tell Access which of the two Date Fields you want to use by typing the table name ([Orders]), an exclamation mark (!), and then the field name ([Date]) or, in other words, [Orders]![Date].

This lesson will show you how to add a calculated field to a query.

1. Display the query in Design View.
2. Click the Field row of a blank column in the Design grid.
3. Enter the field name for the field that will display the results of the calculation, followed by a : (colon).
4. Enter the expression you want Access to calculate, using the proper syntax.

For example, the expression

**Bonus:** [Cost]*[Commission] \[ \text{Bonus} \] will Create a new calculated field named “Bonus” that will display the results of the Cost field from one table multiplied by the Commission field from another table.

**Tip:** Use arithmetic operators such as multiplication (*), addition (+), subtraction (-), division (/), and exponentiation (^) to Create your expressions.

---

**Exercise**

- **Exercise File:** Query.accdb
- **Exercise:** Create a calculated field to calculate employee bonuses:
  Open the qryEmployeeSales query in Design View. Create a calculated field that multiplies the Cost field in the tblCustomerTours table by the Commission field in the tblEmployees table (hint: Bonus: [Cost]*[Commission]). Run the query and save it as qryEmployeeBonus (hint: use the Save Object As command on the File tab).
5. Click the **Design** tab under Query Tools on the Ribbon and click the **Run** button in the Results group.

Access displays the results of the query. The “**Bonus**” calculated field multiplies the **Cost** field by the **Commission** field in each record and displays the results.

If you’ve been modifying an existing query, you can save the changes as a new query.

6. Click the **Save** button in the Quick Access Toolbar. Enter a query name and click **OK**.

Access saves your changes in a new query.

**Other Ways to Create a Calculated Field:**
You can also use the Expression Builder—covered further in another lesson—to help you Create your calculated Fields.
Working with Expressions and the Expression Builder

You can add calculations to queries, forms, and reports by typing an **expression**. An expression is simply a formula that tells Access exactly what to calculate. An expression can be any combination of values, identifiers (such as the value in a field), and operators that result in a value.

Here’s an example of an expression that calculates profit from two Fields called Income and Expenses:

**Profit**: `[Income] – [Expenses]`

You can also use constants in an expression, such as:

**Commission**: `[Sales] * .15`

Number Fields aren’t the only types of Fields that you can use in expressions—you can also perform calculations with dates, times, and text data. Here’s an example of an expression that combines text:

**Agent**: `[FirstName]&" "&[LastName]`

In this example, the ampersand (&) symbol is used to combine or concatenate (string together) two or more text Fields. The " " adds a space between the `[FirstName]` and `[LastName]` Fields.

The trick with creating expressions is that you have to enter a formula so that Access understands it. For example, when you create an expression, some types of information must be enclosed between special characters so that Access knows what type of information it is—table names and field names must be enclosed in [brackets], text strings in "quotation marks," and so on.

Table 6-2: How Types of Data Should Look in an Expression has more information about how to use various elements in an expression.

If you know what you want an expression to do but not how to write it, you can try using the Expression Builder. The Expression Builder lets you pick the Fields, mathematical symbols, and functions you can use to create an expression.

**Use the Expression Builder**

1. Display the query in **Design View**.

   ✅ Tip: In this lesson, we’ll look at how to use the Expression Builder with a query, but you can also use it to create expressions in Tables, forms, and reports.
2. Click the Field row of a blank column in the Design grid.

   Now you need to enter the expression. You can enter it manually, but let’s look at how to use the Expression Builder tool to make it easier.

3. Click the Design tab under Query Tools on the Ribbon and click the Builder button in the Query Setup group.

   The Expression Builder appears. The Expression Builder contains an area where you can build the expression, buttons you can use to build the expression, and the Fields and controls in the current query, report, or form.

   **Other Ways to Open the Expression Builder:**
   Right-click an empty field in the Design grid and select Build from the contextual menu.

4. Select a field to use in the calculation, click the button that corresponds to the calculation you want, and then click or type any other Fields or values you want to use.

5. Click OK.

   The Expression Builder closes. Add a meaningful label to the new calculated field.

6. In the new calculated field, replace the Expr1: label with a more meaningful field name.

7. Save and run the query.

   Microsoft Access is very strict about how you write your expressions. If your expressions aren’t written in the correct syntax, they won’t work. Use the following table as a guideline for adding Fields, text, and constants to your expressions.

### Table 6-2: How Types of Data Should Look in an Expression

<table>
<thead>
<tr>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>&quot;Minneapolis&quot;</td>
</tr>
<tr>
<td>Date/Time</td>
<td>#20-Mar-99# (Access will add the # symbols)</td>
</tr>
<tr>
<td>Field Name</td>
<td>[Price]</td>
</tr>
<tr>
<td>Field Name in a Specific Table</td>
<td>[Products]!![Price]</td>
</tr>
<tr>
<td>Concatenated (Combined) Text and Fields</td>
<td>[Last]&amp; &quot;, &quot;,&amp;[First]</td>
</tr>
<tr>
<td>Calculated Field (Using Two Fields)</td>
<td>[SalePrice]-[Cost]</td>
</tr>
<tr>
<td>Calculated Field (Using a Field and a Constant)</td>
<td>[SalePrice]*0.1</td>
</tr>
</tbody>
</table>
Using an If Function

Functions are used to create complicated calculations or expressions. For example, the **SUM** function adds several values together, and the **IPmt** function calculates the loan payments based on an interest rate, the length of the loan, and the principal amount of the loan.

There are several hundred functions in Access, but all of them are used in a similar way: the name of the function, followed by the arguments in parentheses. An argument in Access is the value a function uses to perform its calculation. For example, the argument in the formula \( \pi r^2 \) would be \( r \), or the radius, used to find the area of a circle.

This lesson introduces a very useful database function: the **IIf** function. The **IIf** function is a conditional function or logical function because it evaluates a condition and returns one value if the condition is true and another value if the condition is false. For example, you could use the **IIf** function in an invoice to create a formula that would subtract a 5-percent discount from the invoice if the total were more than 500 dollars—otherwise, the **IIf** function wouldn’t subtract anything. Or, you could create an **IIf** function to create a field that gives passengers a 50-dollar rebate if they fly first class and a 25-dollar rebate if they fly coach.

The **IIf** function contains three arguments, but since you can use the Expression Builder to help you Create **IIf function** formulas, you really don’t need to memorize the syntax of the function.

1. Display the query in **Design View**.
2. Click the **Design** tab under Query Tools on the Ribbon and click the **Builder** button in the Query Setup group.

The Expression Builder appears. In the bottom-left of the window, the Expression Builder displays a list of several folders that contain information.

For example, if you click the Query folder, you will see a **Tables** folder that contains a list of all the Tables in the current database. These folders are displayed in a hierarchical view. A plus symbol or a minus symbol next to a folder means a folder contains several subfolders. Normally, these subfolders are hidden. You can display the hidden folders within a folder by double-clicking the folder. To see the contents of a folder, simply select the folder—its contents will appear in the middle and left windows.

![Figure 6-8: The syntax for the IIf function.](image)

![Figure 6-9: Here the IIf function evaluates the value in the First Class field and returns 50 if the First Class field is True and 25 if the First Class field is False.](image)

**Exercise**
- **Exercise File**: Query.accdb
- **Exercise**: Use the **IIf function** to provide a $50 rebate to first class passengers and a $25 rebate to coach passengers: Open the qrySales query in **Design View**. In the Design grid, click in the first open **Field** column and display the **Expression Builder**. Add the **IIf function** to the expression box. Replace the **expression** argument with the **First Class** field from the tblCustomerTours table. Append **"=True"**. Replace **«truepart»** with 50 and **«falsepart»** with 25. Click OK. In the new calculated field, Replace **“Expr1”** with **“Rebate”**. Run and save the query.
3. Double-click the **Functions** folder in the bottom-left window.

   The Functions folder expands and displays its contents. The Built-In Functions folder contains several hundred functions that are included in Access.

4. Click the **Built-In Functions** folder, scroll down the middle window and click the **Program Flow** category, double-click the **IIf function** in the right column.

   Access adds `IIf («expression», «truepart», «falsepart»)` to the expression box. Now that you know the proper syntax of the **IIf function**, you need to replace the argument names with the data values. You can double-click to select any argument name so that you can replace it with your own value.

5. Replace the argument placeholders with the Fields and values you want to use.

   **Tip:** Use the folders in the Expression Builder to replace the «expression» field with the field to which you want to apply the logical test. Replace the «truepart» and «falsepart» arguments with the values you want to use if the **IIf statement** is true or false.

6. Click **OK**.

   The Expression Builder closes. Now you can give the new calculated control a more meaningful name.

7. In the new calculated field, replace the **Expr1: label** with a more meaningful field name.

8. Save and run the query.

   **Other Ways to Use the IIf Function:**
   To enter the **IIf function** manually, without using the Expression Builder, click the **Field** row of a blank column in the Design grid. Enter the field name followed by a : (colon). Type the expression using the syntax **IIf(«expr», «truepart», «falsepart»)**.
Summarizing Groups of Records

When you work with queries, you will often be less interested in the individual records and more interested in summarized information about groups of records. A query can calculate information about a group of records in one or more Tables. For example, you could create a query that finds the total amount of tea your company sold to China in 2007 or how much all that tea cost. The Total row lets you group and summarize information in a query. The Total row is normally tucked away from view in the query Design window—you can make the Total appear by clicking the Totals button in the Show/Hide group on the Design tab under Query Tools on the Ribbon. Once the Total row is displayed, you can tell Access how you want to summarize the Fields.

1. Display the query in Design View.

2. If necessary, click the Design tab under Query Tools on the Ribbon and click the Totals button in the Show/Hide group.

   The Total row appears in the Design grid.

   First you need to add the field that you want to group data by onto the Design grid. If, for example, you sell tours and want to calculate the total sales and number of tickets sold for each tour package, you might group the query by the TourName field.

3. Move the field that you want to group data by onto the Design grid. Make sure Group By appears in that field’s Total row.

   Tip: The field(s) you want to group by must appear first in the Design grid and have Group By in their Total row.

   Next you need to select the Fields you want to summarize.

4. Move the field that you want to summarize and perform calculations on onto the Design grid.

   Now you need to choose the type of calculation that you want to perform.

5. Click the field’s Total row, click the list arrow, and select a calculation from the list.

   Table 6-3: Total Options describes the calculations that are available.

Exercise

- **Exercise File:** Query.accdb
- **Exercise:** Use the Total row to calculate the total sales and number of tickets sold for each tour during a certain period:

  Display the qryTourSales query in Design View. Add the following Fields to the Design grid:

<table>
<thead>
<tr>
<th>tblTours</th>
<th>tblCustomerTours</th>
</tr>
</thead>
<tbody>
<tr>
<td>TourName</td>
<td>Number of Tickets</td>
</tr>
</tbody>
</table>

  Display the Total row on the Design grid and sum the Number of Tickets and Cost columns. Select “Where” in the Total row of the Date column. Enter Between 4/1/00 and 6/30/00 in the Date column’s Criteria row. Save the query as qryTourTotals (hint: use the Save Object As command on the File tab) and run the query.

Figure 6-10: Summarizing records in a query using the Total row.
You can specify criteria to limit the records you want to be calculated—simply enter the criteria in the **Criteria row** of any grouped or calculated Fields. For example, you could calculate only records from the second quarter of the year by adding criteria to the **Date** field.

If the field you want to use for the criteria isn’t one of the grouped or calculated Fields, you must use the “**Where**” option in the field’s **Total row**.

 réuss: The “Where” option is used only to limit records—its results cannot be displayed in the results of the query. Access automatically unchecks the “Show” check box.

6. If desired, add criteria to the **Criteria** row of any of the Fields. If the field isn’t grouped or calculated, click the field’s **Total row**’s list arrow and select the **Where** option.

7. Save and run the query.

Access displays the results of the query.

### Table 6-3: Total Options

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Group By</strong></td>
<td>Groups the values in the field so that you can perform calculations on the groups.</td>
</tr>
<tr>
<td><strong>Sum</strong></td>
<td>Calculates the total (sum) of values in a field.</td>
</tr>
<tr>
<td><strong>Avg</strong></td>
<td>Calculates the average of values in a field.</td>
</tr>
<tr>
<td><strong>Min</strong></td>
<td>Finds the lowest value in a field.</td>
</tr>
<tr>
<td><strong>Max</strong></td>
<td>Finds the highest value in a field.</td>
</tr>
<tr>
<td><strong>Count</strong></td>
<td>Counts the number of entries in a field, not including blank (Null) records.</td>
</tr>
<tr>
<td><strong>StDev</strong></td>
<td>Calculates the standard deviation of values in a field.</td>
</tr>
<tr>
<td><strong>Var</strong></td>
<td>Calculates the variance of values in a field.</td>
</tr>
<tr>
<td><strong>First</strong></td>
<td>Finds the values from the first record in a field.</td>
</tr>
<tr>
<td><strong>Last</strong></td>
<td>Finds the values from the last record in a field.</td>
</tr>
<tr>
<td><strong>Expression</strong></td>
<td>Tells Access that you want to Create your own expression to calculate a field.</td>
</tr>
<tr>
<td><strong>Where</strong></td>
<td>Specifies criteria for a field to limit the records included in a calculation.</td>
</tr>
</tbody>
</table>
Display Top or Bottom Values

If all you care about is the highest or lowest values produced by a query, you can display only these records. For example, you could display the ten largest or smallest orders in the Invoices table. If you’re working with dates, you can display the most recent or oldest results.

This lesson explains how you can use the Top Values list to display the top or bottom values in a query.

1. Display the query in Design View.

2. Add the Fields you want to see in your query.

Now you need to sort the field that you want to display the top or bottom values for. The Sort row works a little differently when you’re using top or bottom values:

- **Ascending:** Displays bottom values.
- **Descending:** Displays top values.

3. Click the appropriate Sort field, click the list arrow, and select either Ascending or Descending.

Next you have to use the Return list to specify the number of top values you want to be displayed in your query results.

4. Click the Design tab under Query Tools on the Ribbon and click the Return list arrow in the Query Setup group. Select an option from the list.

Table 6-4: Return List explains the options in the Return list.

**Tip:** If you don’t like any of the options, you can type your own in the Return box.

5. Save and run the query.

Access displays the query results.

**Exercise**

- **Exercise File:** Query.accdb
- **Exercise:** Display the five most expensive nonsmoking tours:
  Display the qryTourSales query in Design View. Add the following Fields to the Design grid:

<table>
<thead>
<tr>
<th>tblTours</th>
<th>tblCustomerTours</th>
</tr>
</thead>
<tbody>
<tr>
<td>TourName</td>
<td>Cost</td>
</tr>
<tr>
<td>Smoker</td>
<td></td>
</tr>
</tbody>
</table>

Enter the criteria “False” in the Smoker column. Sort the Cost column in Descending order and choose to display the top 5 values. Run the query.

Modify the query so that it calculates the total sales of nonsmoking tours. Display the Total row in the Design grid and sum the Cost column. Select Where in the Total row of the Smokers column. Sort the cost column in Ascending order. Save the query as qryTopValues and run the query.

**Figure 6-11:** A query that displays the five tours with the lowest total sales.

<table>
<thead>
<tr>
<th>TourName</th>
<th>SumOfCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Western Canada</td>
<td>£75,625.00</td>
</tr>
<tr>
<td>African Safari</td>
<td>£81,795.00</td>
</tr>
<tr>
<td>Yucatan</td>
<td>£87,285.00</td>
</tr>
<tr>
<td>Europe 10 Days</td>
<td>£105,090.00</td>
</tr>
<tr>
<td>Historical USA</td>
<td>£131,950.00</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 6-4: Return List</th>
</tr>
</thead>
<tbody>
<tr>
<td>Do This…</td>
</tr>
<tr>
<td>Click 5, 25, or 100 from the Return list</td>
</tr>
<tr>
<td>Type a number, such as 15 in the Return box</td>
</tr>
<tr>
<td>Click 5% or 25% from the Return list</td>
</tr>
<tr>
<td>Type a percentage, such as 20%, in the Return box</td>
</tr>
<tr>
<td>Click All from the Return list</td>
</tr>
</tbody>
</table>
Parameter Queries

Getting tired of modifying a query every time you want to use a new criterion? A parameter query is your answer. A parameter query prompts the user for the query’s criteria. For example, you could create a Regional Sales query that would ask for the name of the state you want to filter by.

Creating a parameter query is easy. All you have to do is click the Criteria row for the field that you want to use as a parameter and type a message, enclosed in [brackets], that you want Access to display when you run the query.

1. Display the query in Design View.

2. Add the Fields you want to use onto Design grid.

For example, if you want to create a query that summarizes total employee sales, you might add the FirstName, LastName, State, Cost, and Date Fields.

Tip: Depending on the goal of your query, you may need to tell Access to group and summarize some of the query Fields. This is covered in another lesson.

In our example, you may want to use the Date field as the criteria to limit records to those that fall between two dates. Instead of entering a criteria expression with two fixed date values, such as “Between 1/1/07 and 3/31/07,” you could create two parameters that will prompt the user to enter the two date values each time they run the query.

3. Click the Criteria row for the field you want to use for your parameter criteria and enter the text of the prompt, surrounded by square brackets [ ].

For example, you could enter Between [Enter start date] and [Enter end date] in the Date field’s criteria row.

Tip: If you are using Total rows and are only using a field—such as the Date field—as a criteria field, you’ll also want to select the Where option from its Total row so that the field won’t appear in the query results.

4. Save and run the query.

Access prompts you to enter the parameter(s).

5. Enter a criteria value in response to the prompt and click OK. Repeat for additional parameters.

Access displays the results of the parameter query.
Tips

Some advanced Access developers use custom-made forms to provide parameter queries with their information. If developers bind a parameter to the controls on a form (such as [frmCustomers]![Name]), users can fill out one dialog box instead of having to fill out five or six pop-up dialog boxes.
Finding Duplicate Records

The Find Duplicates Query Wizard helps you find records that have the same value in one or more Fields. So when would you need to use a Find Duplicates Query? Here are a few scenarios:

- To search for duplicate values in an Orders table to find out which customers have placed more than one order.
- To search for duplicate values in several Fields to locate any data-entry errors. For example, if you and another user accidentally entered the same customers into a table, you could search for duplicate values in the LastName and FirstName Fields to find and delete the duplicated records.

Access provides a wizard to make creating a query that finds duplicate information in a snap.

1. Click the Create tab on the Ribbon and click the Query Wizard button in the Queries group.

   The New Query dialog box appears, displaying different kinds of query wizards.

2. Select Find Duplicates Query Wizard and click OK.

   Next, choose the table or query that you want to sift through for duplicate records.

   Tip: To change the options displayed in the list, click the Tables, Queries, or Both option in the View area.

3. Select the table or query you want to search and click Next.

   Now you need to tell Access which field or Fields might contain the duplicate information.

4. Double-click the field(s) that may contain the duplicate values and click Next.

   Next you can select any field (other than the ones you just specified as possible duplicates) that you want to be displayed in the query.

5. Double-click any additional Fields that you want to appear in the query results and click Next.

6. Give the query a name and click Finish.

   Access saves the query with the name you specified and displays the results of the query.

Exercise

- Exercise File: Query.accdb
- Exercise: Create a new query using the Find Duplicates Query Wizard: Use the tblCustomers table and add the LastName and FirstName Fields to the Duplicate-value Fields list. In addition, display the City and State Fields. Save the query with the default name and view the query.
Finding Unmatched Records

The **Find Unmatched Query Wizard** helps you find the records in one table that do not have matching records in another table. Some scenarios when you might need to create such a query include:

- To find customers who have never placed an order.
- To find products that have never been purchased.
- To find “orphan” records. If you haven’t enforced referential integrity in your related Tables, deleting a record in one table could leave one or more orphan records in a related table. For example, if you delete a customer record from a **Customer** table, you may leave several unmatched records for that customer in an **Order** table.

1. Click the **Create** tab on the Ribbon and click the **Query Wizard** button in the Queries group.

   The New Query dialog box appears, displaying different kinds of query wizards.

2. Select **Find Unmatched Query Wizard** and click **OK**.

   Now you need to choose the table or query whose values you want to display in the query. For example, if you ran a tour company and wanted to find customers without any tour packages, you would select the **tblCustomers** table.

3. Select the table whose values you want to display and click **Next**.

   Here you have to tell Access which table contains the related records. In our example, you might select the **tblCustomerTours** table.

4. Select the table that contains the related records and click **Next**.

   Here you have to specify the related field to join the records in the first table to the records in the second table. To do this, you need to select the same field in both lists.

5. Select the same field in both Tables, then click the **<=>** button to join the two Tables and click **Next**.

   Now you have to specify which Fields you want to see in the query.

---

**Exercise**

- **Exercise File**: Query.accdb
- **Exercise**: Use the **Find Unmatched Query Wizard** to Create a query to find customers who have never booked a tour: Select to display the **tblCustomers** table, then select the related **tblCustomerTours** table. Verify that the **CustomerID** field is selected in both Tables and join the Tables. Add the **LastName**, **FirstName**, **City**, and **State** Fields to the query, save the query with the default name and view the results.

---

**Figure 6-18**: Joining Tables in the Find Unmatched Query Wizard using matching Fields
6. Double-click any additional Fields that you want to appear in the query results and click Next.

7. Give your query a name and click Finish.
   Access saves the query with the name you specified and displays the results.
Crosstab Queries

There are many ways that queries can help you summarize and analyze the information in your database. A **crosstab query** displays summarized information in a table format that makes it easy to analyze and compare data.

You can create a crosstab query in **Design View** or by using the Crosstab Query Wizard. The Crosstab Query Wizard is usually much easier, but it does have some limitations:

- If you need to use more than one table or query in the crosstab query, you will first need to create a separate query that contains the Tables you want to use.
- You can’t specify any limiting criteria when using the Crosstab Query Wizard. (But you can always modify the crosstab query in Design View and add the criteria yourself.)

In this lesson we’ll look at using the Crosstab Query Wizard.

1. Click the **Create** tab on the Ribbon and click the **Query Wizard** button in the **Queries** group.

   The New Query dialog box appears, displaying different kinds of query wizards.

2. Select **Crosstab Query Wizard** and click **OK**.

   The first step of the Crosstab Query Wizard appears. Here you need to select the table or query that contains the values you want to use.

   **Tip:** If you want to include Fields from multiple Tables, you’ll first need to create a query containing all those Fields, and then select that query during this step in the Crosstab Query Wizard.

3. Select the table or query you want to use and click **Next**.

   The second step of the Crosstab Query Wizard requires you to select which field you want to use as the row headings for the crosstab.

4. Select the field you want to use as the row heading, click the **right arrow** button and click **Next**.

   The next step is to determine which field you want to use for your column headings.

---

**Exercise**

- **Exercise File:** Query.accdb

- **Exercise:** Use the **Crosstab Query Wizard** to Create a query that summarizes monthly ticket sales by tours: Use the **qryToursByName** query as the source. Use the **TourName** field for row headings and the **Date** field for column headings. Specify a monthly interval. Choose to calculate the sum of the **Number of Tickets** field. Save the query as “**qryTicketsByDate**” and view the query.

---

**Figure 6-19:** Specifying the crosstab query’s calculation.

**Figure 6-20:** The results of a crosstab query.
5. Select the field you want to use as the column heading and click Next.

   Tip: If you select a date field, the Wizard will also ask you how you want to group the dates.

Probably the most important step in the Crosstab Query Wizard is determining which field you want to calculate where columns and rows intersect and the type of calculation you want to use to summarize the Fields.

6. Select the field you want to summarize from the Fields list, select the type of calculation you want to use to summarize the field from the Functions list, and click Next.

7. Enter a name for the crosstab query and click Finish.

Access saves the query with the name you specified and displays the results.

   Tip: Once you’ve created the Crosstab query, you can display it in Design View to make modifications such as adding limiting criteria to certain Fields.
Delete Queries

A delete query is the most dangerous of all queries. Once you have deleted records using a delete query, you cannot undo the results—the records are gone forever! Creating a delete query is no different than creating a simple select query—with one very important difference: While a select query displays the records that match your criteria, a delete query deletes those records.

If you want to delete records from multiple Tables—for example, a customer and all of that customer’s orders—you need to do a few things first:

- Define relationships between the Tables.
- Establish referential integrity for the join(s) between the Tables and turn on the “Cascade Delete Related Records” option.

In this lesson you will learn how to create a delete query.

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.

   The query Design window and Show Table dialog box both appear. Now you have to select the Tables and/or queries you want to use in the delete query.

2. Select the Tables and queries you want to add and click Add. When you’re finished, click Close.

   If the Tables are related, Access automatically connects their common Fields with a join line. If the Tables aren’t related, you will have to manually join them by dragging a field from one table’s field list to the matching field in the other table’s field list.

3. Connect any unrelated Tables.

   Next, tell Access that this is a delete query.

4. Click the Design tab under Query Tools on the Ribbon and click the Delete button in the Query Type group.

   Access converts the select query to a delete query and displays the Delete row in the query Design grid. Now you have to tell Access what you want to delete.

5. Drag the asterisk (*) from the top of the table field list for the table from which you want to delete information onto the Design grid.

   Notice that From appears in the Delete cell for the asterisk field, indicating that the records will be deleted from this table. Unless you want the delete query to delete each and every record in the table, you will need to add some limiting criteria.

Exercise

- Exercise File: Query.accdb
- Exercise: Create a new delete query in Design View to delete all the tours sold by LeAnne Chang: Add the tblEmployees, tblCustomerTours, and tblTours Tables to the query. Link the EmployeeID field in the tblEmployees table to the Employee field in the tblCustomerTours table. Click the Delete button in the Query Type group on the Ribbon. Drag the asterisk (*) from the top of the tblCustomerTours table onto the Design grid. Also add the LastName field from the tblEmployees table. Enter the criteria “Chang” in the LastName column. Preview the query in Datasheet View. Return to Design View and run the query. Close the query without saving.
For example, if you're deleting information from a Customers table, you could use the Last Name field as a limiting criterion to delete only records with a certain last name.

6. Drag the field you want to use as the limiting criteria onto the Design grid.

   This time Where appears in the Delete cell for the field you added, indicating that the field will be used as the criteria to select which records will be deleted from the table you added earlier.

   Next you need to tell Access the specific data to delete. For example, if you were using the Last Name field as your criteria, you could enter the name “Smith” to delete all records that contain “Smith” in the Last Name field.

7. Click the field’s Criteria row and type the specific data you want to delete and press <Tab>.

   Access will add the “quotation marks” around the text string Chang for you. That’s all there is to creating a delete query.

   Tip: Before you run a delete query, always preview the results in Datasheet View first.

8. Click the View button in the Results group on the Design tab to display the delete query in Datasheet View.

   The delete query displays the results of the delete query. Let’s switch back to Design View.

9. Click the View button in the View group on the Home tab to display the delete query in Design View.

   Now run the delete query to delete the records.

10. Click the Run button in the Results group on the Design tab.

    Access asks if you really want to delete the records.

11. Click Yes.

    Access silently deletes the records.

12. Close the query without saving.
Append Queries

An append query takes a group of records from one or more Tables or queries in your database and adds them to another existing table. Append queries are especially useful for importing information into a table. For example, you could use an append query to import several dozen customer records from an Excel spreadsheet into an existing table. Of course, you would have to know how to import the Excel spreadsheet first—and that’s another lesson in itself.

There are several rules that you must follow when using an append query:

- The appended data must meet the data validation and referential integrity rules of the table to which it is being added.
- The appended data must have its own unique primary-key values. If the primary-key field in the table to which the data is being added is an AutoNumber field, do not append that field—Access will generate new numbers for the new records.
- The type of data in the records you’re adding must match the type of data in the table to which you’re adding them.

In this lesson you will learn how to Create an append query.

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.

   The query Design window and Show Table dialog box both appear. Here you have to select the Tables and/or queries containing the data you want to append to another table.

2. Select the Tables and queries you want to add and click Add. When you’re finished, click Close.

   Now you need to make the query an append query.

3. Click the Design tab under Query Tools on the Ribbon and click the Append button in the Query Type group.

   The Append dialog box appears. Here you need to select the table to which you want the results of the query to be added. First, though, you need to select the database where the table is located. You have two options:

   - Current Database: If the table is in the currently open database.
   - Another Database: And browse to the other database.
Working with Queries

4. Select the **Current Database** or **Another Database** option.
   
   Now select the table.

5. Click the **Table Name** list arrow and select the table to which you want to add the results of the query.
   
   Click **OK**.
   
   The append query will add the results of its query to the table you just specified. Notice that an Append To row appears in the Design grid. Now you have to specify the Fields you want to append.

6. Add to the Design grid the Fields you want to append to another table.
   
   If the field(s) you added are present in the destination table, Access automatically fills in the Append To row. If the field is not present in both Tables, you will have to select the name of the field to which you want to append.

7. If Access doesn’t automatically match a field, click the **Append To** row for that field and select the field in the destination table to which you want to append.

   **Trap:** As with any action query, you should always preview the results in Datasheet View first.

8. Click the **View** button in the Results group on the Design tab to display the append query in Datasheet View.
   
   The append query displays the records it will add or append. Let’s switch back to Design View.

9. Click the **View** button in the Views group on the Home tab to display the append query in Design View.
   
   Now run the append query to append the records.

10. Click the **Run** button in the Results group on the Design tab.
    
    Access asks you to confirm the addition of the records to the table.

11. Click **Yes**.
    
    Access adds the records.

12. Close the query without saving.
Make-Table Queries

Like all queries, a make-table query asks a question regarding the information in one or more Tables and then retrieves the results. Instead of displaying the results, however, a make-table query creates a new table with the results of the query. Make-table queries are useful for:

- Exporting a table to another database or application.
- Creating a backup copy of a table.
- Creating an archive table that stores old records.
- Creating a table that includes information or Fields from more than one table.

In this lesson you will create a make-table query.

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.

   The query Design window and Show Table dialog box both appear. Here you have to select the Tables and/or queries containing the data you want to include in your new table.

2. Select the Tables and queries you want to add and click Add. When you’re finished, click Close.

   Now add the Fields you want to use in your new table.

3. Add to the Design grid the Fields you want to use to create the new table.

4. As desired, add any limiting criteria in the Criteria row.

   Now you need to change the query type to make it a make-table query.

5. Click the Design tab under Query Tools on the Ribbon and click the Make Table button in the Query Type group.

   Access displays the Make Table dialog box. Here you need to tell Access the name of the new table.

6. Enter a name in the Table Name box and click OK.

   **Tip:** In the Table Name box, you can also choose to replace an existing table instead of creating a new one. To do this, click the Table Name list arrow and select a table. If the table you’re replacing is in another database, first select the Another Database option and browse to the database.

---

**Exercise**

- **Exercise File:** Query.accdb
- **Exercise:** Create a make-table query to Create a table containing information regarding all China tour records: Open the qryTourSales query in Design View. Add the following Fields to the Design grid:

<table>
<thead>
<tr>
<th>tblTours</th>
<th>tblCustomerTours</th>
<th>tblEmployees</th>
</tr>
</thead>
<tbody>
<tr>
<td>TourName</td>
<td>Number of Tickets</td>
<td>Date</td>
</tr>
</tbody>
</table>

  Enter the criteria “China” in the TourName column. Make the query a Make Table Query and enter tblChinaTours as the name of the new table. Preview the query results in Datasheet View, then return to Design View and run the query. Close the query without saving.

   Open the new tblChinaTours table to see the result.

---

Figure 6-25: The make-table query will Create a table using the Tables, Fields, and criteria you specify.

Figure 6-26: Type the name of the table you’re creating in the Make Table dialog box.
Working with Queries

Now you’re ready to have the make-table query
Create the new table. Preview the results of the query first.

7. Click the View button in the Results group on the Design tab to display the make-table query in Datasheet View.
   The make-table query displays the records it will use to create the new table.

8. Click the View button in the Views group on the Home tab to display the make-table query in Design View.
   Now let’s run the query to create the new table.

9. Click the Run button in the Results group on the Design tab.
   Access asks you to confirm the creation of the table.

10. Click Yes.
    Access Creates the new table based on the results of the make-table query.

11. Close the query without saving.
    Now you can open and view the new table, which contains the results of the make-table query.
Update Queries

You can use an update query to change a bunch of records at the same time. For example, you could create an update query to lower prices by eight percent or to change the sales representative for all your clients in Oregon from “Ralph Potter” to “George Bailey.” Just like other action queries, you create an update query by first creating a select query and then converting the select query to an update query.

In this lesson you will create an update query.

1. Click the Create tab on the Ribbon and click the Query Design button in the Queries group.

   The query Design window and Show Table dialog box both appear. Here you have to select the Tables and/or queries you want to use in the update query.

2. Select the Tables and queries you want to add and click Add. When you’re finished, click Close.

   Now you need to convert the select query to an update query.

3. Click the Design tab under Query Tools on the Ribbon and click the Update button in the Query Type group.

   Access converts the select query to an update query. Notice an Update To row appears in the Design grid. Now you have to specify the Fields you want to update.

4. Add to the Design grid the Fields you want to update.

   The next step is a little bit tricky—you have to tell Access which Fields to update and how to update them. For example, if you wanted to raise the price of the Normal Price field by 10 percent you would write an expression—like [Normal Price]+([Normal Price]*.1)—in the field’s Update To row to make this happen.

5. Click the Update To row for the field you want to update and type an expression.

   Next you need to specify any limiting criteria. For example, if you wanted to raise prices for only certain products, you would need to enter a limiting criterion, such as a product number, in the field that identifies the products.

6. As desired, add any limiting criteria in the Criteria row.

   Now let’s run the query.
7. Click the **Run** button in the Results group on the Design tab.
   
   Access asks you to confirm the update.

8. Click **Yes**.
   
   Access updates the records.

9. Close the query without saving.
   
   Now you can open the updated table and view the update data.
Working with Queries Review

Quiz Questions

1. Which type of query makes it easy to read and compare information by summarizing data in a table format?  
   A. A Crosstab Query  
   B. A Union Query  
   C. An Append Query  
   D. A Parameter Query

2. Access will automatically join related tables when they are added to a query. (True or False?)

3. Which of the following expressions is NOT written in the correct syntax?  
   A. [Order Total]*[Tax Rate]  
   B. (Order Total)*0.1  
   C. [tblCustomerTours]![Cost]*[tblEmployees]![Commission]  
   D. 100+10

4. If you are having trouble remembering how to write expressions using the correct syntax, you can use the Expression Builder to help you create the expression. (True or False?)

5. Rebate: IIf([Age]>65,Senior,Adult) This expression is an example of:  
   A. A conditional expression.  
   B. Something I learned back in high school algebra and thought I would never see again.  
   C. A financial expression.  
   D. Something that belongs in Microsoft Excel training.

6. The field(s) you want to group by must appear first in the design grid and have Group By in their Total row. (True or False?)

7. A query must be ______ before you can display the top values.  
   A. Filtered  
   B. Saved  
   C. Sorted  
   D. Destroyed

8. A parameter query could prompt a user for a date and then display only records that contain the specified date. (True or False?)

9. To find duplicate records, use the Find Duplicates Query Wizard. (True or False?)

10. The find unmatched records query helps identify duplicate records in a table. (True or False?)

11. You can’t specify any limiting criteria when using the Crosstab Query Wizard. (True or False?)

12. You can restore the records a delete query erases by using the Undo command. (True or False?)

13. An append query can extract records from one table and copy them into another existing table. (True or False?)

14. Make-table queries are NOT useful for which one of the following tasks?
A. Creating a backup copy of a table.
B. Creating an archive table that stores old records.
C. Creating a table with information from more than one table.
D. Updating a bunch of table records at once.

15. You could use an update query to change all 612 area codes in a table to 952. (True or False?)
Quiz Answers

1. A. A Crosstab Query makes it easy to read and compare information by summarizing data in a table format.
2. True. Access automatically joins related tables when they are added to a query.
3. B. (Order Total)*0.1 is incorrect. Fields should be enclosed in [ ] brackets, not parentheses.
4. True. The Expression Builder helps you create expressions in your queries (and in forms, reports, and macros too!)
5. A. This is a conditional expression.
6. True. The field(s) you want to group by must appear first in the design grid and have Group By in their Total row.
7. C. A query must be sorted before you can display the top values.
8. True. A parameter query could prompt a user for a date and then display only records that contain the specified date.
10. False. The find unmatched records query helps find the records in one table that do not have matching records in another table.
11. True. In order to add criteria, you have to modify the query after creating it in the Wizard.
12. False. A delete query permanently deletes any records, so be careful!
13. True. An append query lets you copy records from one table and add them to another table.
14. D. Make-table queries are not useful for updating a bunch of table records at once.
15. True. An update query changes batches of records at the same time.
A form Created in Access is similar to the ordinary paper forms that you fill out with a pen or pencil—only you don’t have to worry about trying to read poor penmanship. In Access, forms provide an easy way to enter and view data in a table. Here are just a few examples of how forms make working with data easier.

**Easier to View and Use:** Instead of scrolling back and forth in a table’s datasheet, a form lets you focus on one record at a time.

**See Data Any Way You Want:** You can Design forms to present information any way you like.

**Combine Data from Linked Tables:** One form can display data from several related Tables or queries—and your users will never know that they are working with two sources!

And that’s just for starters. No doubt about it—forms make your database easier to use. Just like a Windows dialog box (which is really what a form is), Access forms can include fill-in-the-blank Fields, check boxes, drop-down lists, and more.

Let’s start working with forms.

**Using Exercise Files**
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Creating and Using a Form

A fast and easy way to create a form in Access is by using one of the **AutoForm** tools. Autoforms automatically create a form by arranging all the Fields from a table or query.

The AutoForms are fast and easy to use, but limited—there are only a few kinds of them. Of course, you can always modify the forms once you’ve created them.

Create a form with AutoForms

1. In the Navigation Pane, click the table or query that contains the data you want the new form to use.

   Now you’re ready to select an AutoForm. Table 7-1: Forms describes the different types of AutoForms that are available.

2. Click the **Create** tab on the Ribbon and click the **Form** button in the Forms group.

   Access creates the form for you using the data from the table or query you specified.

Use a form

Once you Create a form, you can use the buttons on the Record Navigation bar (**First**, **Previous**, **Next**, **Last**, or **New**) to display or add records.

1. Click a button on the **Record Navigation** bar to display or add a new record.

   Other Ways to Display a Certain Form:
   Enter a keyword in the **Search** box to locate the record you want to display.

---

**Table 7-1: Forms**

<table>
<thead>
<tr>
<th>The Forms group on the Create tab under the Ribbon</th>
<th>Form Design</th>
<th>Blank Form</th>
<th>More Forms</th>
<th>Form Wizard</th>
<th>Navigation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Form</td>
<td>Displays only one record at a time. If the form has a related child table, that data will be displayed as well.</td>
<td>Also allows you to place controls anywhere you want them, but opens the form in Form View.</td>
<td>Allows you to place controls anywhere you want them. Opens the form in Design View, where you can work with it.</td>
<td>Asks you a series of questions and then Designs the form based on your answers.</td>
<td></td>
</tr>
</tbody>
</table>

---

**Exercise**

- **Exercise File:** Form.accdb
- **Exercise:** Create a regular form with data from the Customers table.

---

**Figure 7-1:** An Access form.
### Table 7-1: Forms

<table>
<thead>
<tr>
<th>Form Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple Items</td>
<td>Displays all records in a datasheet format. Each field is a column.</td>
</tr>
<tr>
<td>Datasheet</td>
<td>Looks like a table’s datasheet view. Allows you to customize the datasheet—for example, you could view only certain columns.</td>
</tr>
<tr>
<td>Split Form</td>
<td>Displays all records in datasheet format on half the screen, and a form displaying the currently selected record on the other half, useful for data entry.</td>
</tr>
<tr>
<td>Modal Dialog</td>
<td>Instead of displaying data from a table, this form allows you to Create a dialog box that pops up and asks the user a question. Used with macros.</td>
</tr>
<tr>
<td>PivotChart</td>
<td>Creates a dynamic and interactive chart.</td>
</tr>
<tr>
<td>PivotTable</td>
<td>Dynamically analyzes information and summarizes it into a datasheet-like table.</td>
</tr>
</tbody>
</table>
Understanding Form Views

Before modifying a form, you need to know that forms can be viewed several different ways in Access:

**Form View:** The normal view where you can view, add, and edit records. You can’t modify the form’s structure in this view.

**Layout View:** Layout View allows you to apply formatting and rearrange Fields while also displaying data.

**Design View:** Use for in-depth modification and customization of your form. Live data is not visible—you’re only working with the structure of the form.

**Datasheet, Pivot Table, Pivot Chart:** These views are available only for certain types of forms.

**Print Preview:** Displays a form as it would look when printed, although you’ll rarely need to print a form—that’s why you have reports.

**Change Form views**

Make sure the form is displayed, then follow these instructions:

1. Click the **Home** tab on the Ribbon, click the **View** button list arrow and select a view option.

   **Other Ways to Change Views:**
   - Click a **view** button on the right side of the Status Bar.

   ![Figure 7-2: Selecting a form view.](image1)

   ![Figure 7-3: A form displayed in different views.](image2)
Modifying a Form in Layout View

You can modify forms in either Layout View—for simple modifications—or in Design View—for more complex changes where you want total control over form elements.

Unless you need to make detailed modifications, you’ll want to use Layout View. Layout View is easy to use because, for the most part, you can simply click and drag items around the form, and you can see your live data while you work.

Tips

✓ The modifications in this lesson can also be performed in Design View, but using Layout View is easier.

Understand controls

Any graphic object that appears on forms and reports is called a control. A text box used to enter and display information, a text label, and a button you click to print a report would all be examples of controls.

Move a control

1. Click and drag a control to move it to a new location.

Resize a control

1. Select the control you want to resize, then click and drag the edge of the control to resize it.

Edit a label

1. Select the label you want to edit.

2. Select the text within the label control.
   A cursor appears in the label.

3. Edit the text as desired.

4. Click outside the label.
   The edit is confirmed.

Exercise

• Exercise File: Form.accdb
• Exercise: Display the frmCustomers form in Layout View. Delete the DOB text box and label. Then add the DOB field using the Field List pane. Move the Phone field after the ZipCode field and move the DOB field after the Phone field. Change the DOB label to BirthDate. Resize all the text boxes until they are half as wide. Save the changes.

Figure 7-4: Add a field using the Field List pane.
Delete a control

1. Select the control you want to delete, then press the <Delete> key.

Add a field

1. Make sure the Field List pane is displayed.

   ✅ Tip: If you don’t see the Field List pane, click the Design tab under Form Layout Tools on the Ribbon and click the Add Existing Fields button in the Tools group.

2. Click and drag the field you want to add from the Field List onto the form.

   The field is added to the form wherever you placed it, and Access automatically moves the other Fields to accommodate it.

   ✅ Tip: The Field List pane can be used in either Layout or Design View.
Form Design View Basics

Don’t let Design View scare you. It looks more complicated than it really is. In some ways, Design View is similar to many Paint programs. Think of the form as your canvas and the control buttons as paintbrushes for adding Fields, text boxes, and buttons to the form.

Any graphic object that appears on forms and reports is called a control. A text box used to enter and display information, a text label, and a button you click to print a report would all be examples of controls. Let’s look at how to add controls in Design View.

Add a control

1. In Design View, click the Design tab under Form Design Tools.

Form controls are located in the Controls group. As you will notice, there are lots of different controls to choose from.

Tip: Some controls, such as buttons or lists, have a wizard that helps you set them up. By default the Use Control Wizards button should be selected in the More button in the Controls group.

2. Click the control button you want to add.

The cursor changes its look.

3. Click and drag on the form in the location where you want to place the control.

If the control you added uses a Control Wizard, the wizard appears at this point. Or, if you added a label, you’ll need to enter text.

4. If necessary, enter text into a label or follow the Control Wizard to set up the control.

Tip: You can copy, cut and paste controls using the buttons in the Clipboard group on the Home tab.

5. In the Property Sheet pane, change settings for the control as desired.

For example, if the intent of a control is to display a database field’s value, you’d select the desired source from the Control Source box on the Property Sheet.

Tip: If the Property Sheet pane isn’t already displayed, click the Property Sheet button in the Tools group on the Design Tab.

Table 7-2: Controls provides more information about controls.

Exercise

- Exercise File: Form.accdb
- Exercise: Add a Combo Box control to the frmCustomers form using the Control Wizard. Place the control on the right side of the form’s header, and make it 1 inch tall by 2 inches wide. Select the “Find a record on my form based on the value I select in my combo box” option. Add the CustomerID, LastName, and FirstName Fields to the combo box. Give the combo box a label named “Lookup Name”. Save the changes, then try out the combo box in Form View.

Figure 7-5: A form in Design View.

Figure 7-6: A form with a combo box control.
Working with Forms

**Resize the form area**
Sometimes you may need to make the form area larger in order to fit a new control.

1. Click the top edge of the **Detail** divider or **Form Footer** divider and drag the divider to resize the desired form area.

<table>
<thead>
<tr>
<th>Table 7-2: Controls</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select</strong></td>
</tr>
<tr>
<td><strong>Text Box</strong></td>
</tr>
<tr>
<td><strong>Label</strong></td>
</tr>
<tr>
<td><strong>Button</strong></td>
</tr>
<tr>
<td><strong>Tab Control</strong></td>
</tr>
<tr>
<td><strong>Hyperlink</strong></td>
</tr>
<tr>
<td><strong>Web Browser Control</strong></td>
</tr>
<tr>
<td><strong>Navigation Control</strong></td>
</tr>
<tr>
<td><strong>Option Group</strong></td>
</tr>
<tr>
<td><strong>Insert Page Break</strong></td>
</tr>
<tr>
<td><strong>Combo Box</strong></td>
</tr>
<tr>
<td><strong>Chart</strong></td>
</tr>
<tr>
<td><strong>Line</strong></td>
</tr>
<tr>
<td><strong>Toggle Button</strong></td>
</tr>
<tr>
<td><strong>List Box</strong></td>
</tr>
<tr>
<td><strong>Rectangle</strong></td>
</tr>
<tr>
<td><strong>Check Box</strong></td>
</tr>
<tr>
<td><strong>Unbound Object Frame</strong></td>
</tr>
<tr>
<td><strong>Attachment</strong></td>
</tr>
<tr>
<td><strong>Option Button</strong></td>
</tr>
<tr>
<td><strong>Subform/Subreport</strong></td>
</tr>
<tr>
<td><strong>Bound Object Frame</strong></td>
</tr>
<tr>
<td><strong>Image</strong></td>
</tr>
</tbody>
</table>
Changing Tab Order

If you add, remove, or move Fields on a form, you'll want to change the form's *tab order*. A form's tab order determines the order in which you advance from one field to the next when you press the `<Tab>` key. When a form is first created, the order of the Fields determines the initial tab order. Even when you reposition the Fields on a form, the form’s tab order remains the same.

In this lesson, we’ll look at how to change the tab order.

**Tips**
- Tab order can only be changed in **Design View**.

**Change a form’s tab order**

1. In Design View, click the **Design** tab under Form Layout Tools on the Ribbon and click the **Tab Order** button in the Tools group.

   The Tab Order dialog box appears. The order of the Fields in the list is the order in which you will advance from one field to the next when you press the `<Tab>` key. There are a couple of ways to change the tab order. The fast and easy way is to click the **Auto Order** button, which automatically rearranges the tab order to correspond with the order in which controls appear on the form.

   **Tip:** If you don’t see the Fields listed, you may need to click **Detail** in the Section area of the dialog box.

2. Click the **Auto Order** button. Click **OK**.

   Access looks at the order in which Fields appear on the form and adjusts the tab order accordingly.

   **Other Ways to Change Tab Order:**
   - In the Tab Order dialog box, click the row select for the field you want to move and drag it to the desired location. Repeat as necessary.

---

**Exercise**

- **Exercise File:** Form.accdb
- **Exercise:** Display the **frmCustomers** form in **Form View**. Press the `<Tab>` button to move the cursor through all the text boxes (notice that SSN is out of order). Change to **Design View** to change the tab order. Open the **Tab Order** dialog box and use the **Auto Order** feature to make the tab order match the physical order on the form. Save the changes.

![Figure 7-7: The Tab Order dialog box.](image-url)
Working with Control Properties

Every control on a form—every text box, every label, and every check box—has a set of properties that you can modify. A property is an attribute that defines an object’s appearance, behavior, or characteristics. For example, the properties of a house would be its color, square footage, and shape. A property for a field on a form might be the number of decimal places displayed or the default value for the field. Because you can almost always change an object’s properties, you can think of them as the object’s settings.

Different types of controls have different properties. For example, label controls have a Caption property that determines the text that is displayed in the label, while text box controls have a Control Source property that determines which field is displayed in the control. Most controls have several dozen different properties or settings. Fortunately, Access organizes these properties on different tabs, as shown in Table 7-3: Tabs in the Property Sheet.

This lesson explains how to view and change a control’s properties.

View and edit properties

1. Display the form in Design View.
   
   Tip: You can also work with properties in Layout View.

   Properties are displayed and edited in the Property Sheet pane.

2. If the Property Sheet isn’t displayed, right-click the control and select Properties from the contextual menu.

   Other Ways to Display the Property Sheet:
   - In Design View, click the Design tab under Form Design Tools on the Ribbon and click the Property Sheet button in the Tools group.
   - In Layout View, click the Design tab under Form Layout Tools on the Ribbon and click the Property Sheet button in the Tools group.

3. Select a control.

   The Property Sheet displays the properties for the selected control.

   Other Ways to Select a Control:
   - Click the Selection type list arrow at the top of
the Property Sheet and select the control whose properties you want to view or edit.

Tip: To select multiple controls to edit at once, press and hold down the <Shift> key as you click each control that you want to select.

Now let’s look at how to edit a property.

4. In the Property Sheet pane, click the appropriate property box and make the changes.

Some property boxes will display one of the following buttons when clicked:

- Click to display a list of options to change the settings for the selected property.
- Click to invoke a Wizard or display a dialog box that you use to change the settings for the selected property.

Tip: Most controls have dozens and dozens of properties. You will often have to click the appropriate tab and then do some scrolling to find the property box that you’re looking for.

<table>
<thead>
<tr>
<th>Table 7-3: Tabs in the Property Sheet</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Format</strong></td>
</tr>
<tr>
<td><strong>Data</strong></td>
</tr>
<tr>
<td><strong>Event</strong></td>
</tr>
<tr>
<td><strong>Other</strong></td>
</tr>
<tr>
<td><strong>All</strong></td>
</tr>
</tbody>
</table>
Control Property Reference

Every control on a form or report has dozens of different control properties or settings—so how do you keep them all straight? Here’s how—this lesson is really a cheat sheet that you can use whenever you’re not sure what exactly a particular control property is or does. The most important properties are marked with a ★.

### Table 7-4: Common Form and Report Control Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ★</td>
<td>Format</td>
<td>Displays a descriptive caption for a form or text label.</td>
</tr>
<tr>
<td>Format ★</td>
<td>Format</td>
<td>Customizes the way numbers, dates, times, and text are displayed and printed.</td>
</tr>
<tr>
<td>Decimal Places ★</td>
<td>Format</td>
<td>Determines the number of decimal places displayed.</td>
</tr>
<tr>
<td>Visible ★</td>
<td>Format</td>
<td>Shows or hides a control. Useful if you want to use information on the form without it being visible. For example, you could use the value in a hidden control as the criteria for a query.</td>
</tr>
<tr>
<td>Display When</td>
<td>Format</td>
<td>Determines whether a section or control always appears or only appears when it is displayed on screen or printed.</td>
</tr>
<tr>
<td>Scroll Bars</td>
<td>Format</td>
<td>Determines whether scroll bars appear in the control.</td>
</tr>
<tr>
<td>Left ★</td>
<td>Format</td>
<td>Determines the horizontal position of the control.</td>
</tr>
<tr>
<td>Top ★</td>
<td>Format</td>
<td>Determines the vertical position of the control.</td>
</tr>
<tr>
<td>Width ★</td>
<td>Format</td>
<td>Determines the width of a control.</td>
</tr>
<tr>
<td>Height ★</td>
<td>Format</td>
<td>Determines the height of a control.</td>
</tr>
<tr>
<td>Back Style</td>
<td>Format</td>
<td>Determines whether a control is transparent or not.</td>
</tr>
<tr>
<td>Back Color</td>
<td>Format</td>
<td>Determines the color of a control. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Special Effect</td>
<td>Format</td>
<td>Applies a 3-D effect to a control.</td>
</tr>
<tr>
<td>Border Style</td>
<td>Format</td>
<td>Determines the line style of a control’s border—select from transparent lines, solid lines, dashed lines, etc.</td>
</tr>
<tr>
<td>Border Color</td>
<td>Format</td>
<td>Determines the color of a control’s border. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Border Width</td>
<td>Format</td>
<td>Determines the width of a control’s border (in points).</td>
</tr>
<tr>
<td>Fore Color</td>
<td>Format</td>
<td>Determines the color of text in a control or the fill color of an object. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Font Name</td>
<td>Format</td>
<td>Determines the font used in a control (such as Arial or Times New Roman).</td>
</tr>
<tr>
<td>Font Weight</td>
<td>Format</td>
<td>Determines the thickness (boldface) of text in a control.</td>
</tr>
<tr>
<td>Font Italic</td>
<td>Format</td>
<td>Determines whether the text in a control appears in italics.</td>
</tr>
<tr>
<td>Font Underline</td>
<td>Format</td>
<td>Determines whether the text in a control is underlined.</td>
</tr>
<tr>
<td>Text Align</td>
<td>Format</td>
<td>Determines how text should be aligned in a control.</td>
</tr>
<tr>
<td>Control Source ★</td>
<td>Data</td>
<td>Determines the data that appears in the control.</td>
</tr>
<tr>
<td>Input Mask ★</td>
<td>Data</td>
<td>Limits the amount and type of information that can be entered in a field, such as (___) ___ ___ for a phone number. Click the button to Create an input mask using the Input Mask Wizard.</td>
</tr>
<tr>
<td>Default Value ★</td>
<td>Data</td>
<td>Specifies a value that is automatically entered in this field for new records.</td>
</tr>
</tbody>
</table>

**Exercise**

- **Exercise File:** Form.accdb
- **Exercise:** Display the frmCustomers form in Design View. Make sure the Property Sheet pane is displayed. Select different controls and explore the tabs and properties on the Property Sheet.
## Table 7-4: Common Form and Report Control Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validation Rule ★</td>
<td>Data</td>
<td>Allows you to enter an expression that is evaluated when data in the field is added or changed.</td>
</tr>
<tr>
<td>Validation Text ★</td>
<td>Data</td>
<td>Allows you to enter a message that is displayed when data doesn’t meet the Validation Rule property.</td>
</tr>
<tr>
<td>Locked ★</td>
<td>Data</td>
<td>Determines whether changes can be made to a field’s data.</td>
</tr>
<tr>
<td>Event Tab</td>
<td>Event</td>
<td>Allows you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Name ★</td>
<td>Other</td>
<td>Specifies the name of the control that identifies it in expressions, macros, and Visual Basic procedures.</td>
</tr>
<tr>
<td>Status Bar Text</td>
<td>Other</td>
<td>Specifies a message to display in the Status bar when the control is selected.</td>
</tr>
<tr>
<td>Enter Key Behavior</td>
<td>Other</td>
<td>Determines if pressing the &lt;Enter&gt; key adds a new line of text in a control or if it moves to the next field.</td>
</tr>
<tr>
<td>Allow AutoCorrect</td>
<td>Other</td>
<td>Determines if AutoCorrect (i.e., “teh” &gt; “the”) is used in a control.</td>
</tr>
<tr>
<td>AutoTab</td>
<td>Other</td>
<td>Used with the Input Mask property. Determines whether an automatic tab to the next field occurs when the last character permitted by a text box control’s input mask is entered.</td>
</tr>
<tr>
<td>Tab Stop</td>
<td>Other</td>
<td>Determines whether users are able to tab to the control.</td>
</tr>
<tr>
<td>Tab Index</td>
<td>Other</td>
<td>Determines the tab order.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specifies a user-Created shortcut menu that appears when the control is right-clicked.</td>
</tr>
<tr>
<td>ControlTip Message</td>
<td>Other</td>
<td>Specifies a brief message that appears when a user points at the control for a couple of seconds.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specifies an identifier number for a user-Created Help File that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Specifies extra, user-defined information that is stored in the object.</td>
</tr>
</tbody>
</table>
Working with Form Properties

In this lesson you will learn how to view and change the properties and settings not for controls, but for the form itself. That’s right—just like controls, forms also have their own set of properties that you can view and manipulate. So why would you want to change a form’s properties? Modifying a form’s properties can be especially important if you are creating a database that will be used by novice users. For example, by modifying a form’s properties you can:

- Allow users to edit exiting records in a table or query—but not add any additional records.
- Display one record at a time on each form or display many records at once.
- Determine the size and location of the form.

In this lesson you will learn how to work with a form’s properties.

**Change form properties**

1. Display the form in **Design View**. Double-click the **Form Selector**.

   Access displays the properties for the form.

   **Other Ways to View Form Properties:**
   
   You can also view and edit form properties in **Layout View**. Click the **arrow** button that runs along the left side of the form to select the entire form in **Layout View**.

2. Click the appropriate property tab and property box and make the desired changes.

**Change the form’s Default View property**

One of the most important form properties is the Default View property, which determines how many records a form can display at once. Let’s take a closer look at this property...

1. Click the **Format** tab on the Property Sheet, click the **Default View** box, and click the down arrow.

   Here you have six options. They are:

   - **Single Form**: Displays one record at a time on a form.
   - **Continuous Forms**: Displays multiple records on a form. The main difference between Datasheet and Continuous Forms is that a continuous form can be customized.
• **Datasheet:** Displays multiple records in a table, using one line per record. Tables and queries display information in datasheets.

• **Split Form:** Displays a single record on a form and multiple records on a datasheet at the same time.

2. Select a different Default View option, if desired.

You’re probably wondering how you are going to get a handle on all these form properties. Don’t worry—you will probably never touch 95 percent of them.
Form Property Reference

Here’s a “cheat sheet” that lists the various form properties. Some of the most important properties are marked with a ★.

Table 7-5: Important Form Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ★</td>
<td>Format</td>
<td>Displays a descriptive caption in the form’s title bar.</td>
</tr>
<tr>
<td>Default View ★</td>
<td>Format</td>
<td>Determines the view the form is in when opened.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Single Form: Displays one record at a time.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Continuous Forms: Displays multiple records in a form.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Datasheet: Displays multiple records in a Datasheet.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PivotTable: Dynamically analyzes data, summarizes into a table.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PivotChart: Dynamically analyzes data, summarizes into a chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Split Form: Displays a single record on a form and multiple records on a datasheet at the same time.</td>
</tr>
<tr>
<td>Allow Form View</td>
<td>Format</td>
<td>Determines if users can switch to this view.</td>
</tr>
<tr>
<td>Allow Datasheet View</td>
<td>Format</td>
<td>Determines whether scroll bars appear on the form.</td>
</tr>
<tr>
<td>Allow PivotTable View</td>
<td>Format</td>
<td>Determines whether a form contains a record selector.</td>
</tr>
<tr>
<td>Allow PivotChart View</td>
<td>Format</td>
<td>Determines whether a form has navigation buttons.</td>
</tr>
<tr>
<td>Allow Layout View</td>
<td>Format</td>
<td>Determines if lines appear between records in continuous forms.</td>
</tr>
<tr>
<td>Scroll Bars ★</td>
<td>Format</td>
<td>Resizes the form automatically to display a complete record.</td>
</tr>
<tr>
<td>Record Selectors ★</td>
<td>Format</td>
<td>Determines the type of window the form appears in: None, Thin, Sizable, or Dialog.</td>
</tr>
<tr>
<td>Navigation Buttons ★</td>
<td>Format</td>
<td>Determines if a control menu appears in the form.</td>
</tr>
<tr>
<td>Dividing Lines</td>
<td>Format</td>
<td>Determines if minimize and/or maximize buttons appear in the form.</td>
</tr>
<tr>
<td>Auto Resize</td>
<td>Format</td>
<td>Determines if a close button appears on the form.</td>
</tr>
<tr>
<td>Border Style ★</td>
<td>Format</td>
<td>Determines the width of the form.</td>
</tr>
<tr>
<td>Close Button</td>
<td>Format</td>
<td>Determines the height of the form.</td>
</tr>
<tr>
<td>Picture</td>
<td>Format</td>
<td>Adds a graphic or picture for the form or report background. Click the Build button to browse for the folder and File.</td>
</tr>
<tr>
<td>Picture Type</td>
<td>Format</td>
<td>Determines if the picture is embedded or linked.</td>
</tr>
<tr>
<td>Picture Size Mode</td>
<td>Format</td>
<td>Determines how the contents of a picture frame are displayed: Clip, Stretch, or Zoom.</td>
</tr>
<tr>
<td>Picture Alignment</td>
<td>Format</td>
<td>Determines the alignment of a picture within a frame.</td>
</tr>
<tr>
<td>Picture Tiling</td>
<td>Format</td>
<td>Determines whether a picture is tiled within a frame.</td>
</tr>
<tr>
<td>Grid X</td>
<td>Format</td>
<td>Determines the number of subdivisions (horizontal) in a grid.</td>
</tr>
<tr>
<td>Grid Y</td>
<td>Format</td>
<td>Determines the number of subdivisions (vertical) in a grid.</td>
</tr>
<tr>
<td>Layout for Print</td>
<td>Format</td>
<td>Determines whether the form uses printer fonts.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** Form.accdb
- **Exercise:** Display the frmCustomers form in **Design View**. Make sure the **Property Sheet** pane is displayed and the **Form Selector** is selected. Select different controls and explore the tabs and properties on the **Property Sheet**.

Working with Forms
## Table 7-5: Important Form Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Palette Source</td>
<td>Format</td>
<td>Specifies the path and File name for the graphic File used as a palette.</td>
</tr>
<tr>
<td>Record Source</td>
<td>Data</td>
<td>Specifies the table or query whose data will be used in the form.</td>
</tr>
<tr>
<td>Filter</td>
<td>Data</td>
<td>Specifies a filter that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Order By</td>
<td>Data</td>
<td>Specifies a sort order that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Allow Filters</td>
<td>Data</td>
<td>Determines whether filters may be applied to the form.</td>
</tr>
<tr>
<td>Allow Edits</td>
<td>Data</td>
<td>Determines whether records can be modified in the form.</td>
</tr>
<tr>
<td>Allow Deletions</td>
<td>Data</td>
<td>Determines whether records can be deleted in the form.</td>
</tr>
<tr>
<td>Allow Additions</td>
<td>Data</td>
<td>Determines whether records can be added in the form.</td>
</tr>
<tr>
<td>Data Entry</td>
<td>Data</td>
<td>Allows you to select “Yes” if you only want to use the form to add new records.</td>
</tr>
<tr>
<td>Event Tab</td>
<td>Event</td>
<td>Allows you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Pop Up</td>
<td>Other</td>
<td>Determines whether the form appears in a pop-up window that remains on top of all other windows.</td>
</tr>
<tr>
<td>Modal</td>
<td>Other</td>
<td>Determines whether the form keeps the focus (you can’t switch to any other windows or forms) until it is closed.</td>
</tr>
<tr>
<td>Cycle</td>
<td>Other</td>
<td>Determines how the tab key should cycle.</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>Other</td>
<td>Allows you to select a custom menu bar that you Created that should appear when the form is active.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Other</td>
<td>Allows you to select a custom toolbar that you Created that should appear when the form is active.</td>
</tr>
<tr>
<td>Shortcut Menu</td>
<td>Other</td>
<td>Determines if right mouse button contextual menus are permitted in the form.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specifies a user-Created shortcut menu that appears when a user clicks the right-mouse button.</td>
</tr>
<tr>
<td>Help File</td>
<td>Other</td>
<td>Specifies the name of the custom Help File for the form.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specifies an identifier number for a user-Created Help File that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Has Module</td>
<td>Other</td>
<td>Specifies if the form has Visual Basic code behind it.</td>
</tr>
<tr>
<td>Fast Laser Printing</td>
<td>Other</td>
<td>Print the form using optimized laser-printer formatting.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Specifies extra user-defined information that is stored in the form.</td>
</tr>
</tbody>
</table>
Changing a Control’s Data Source

There are three types of controls that you can add to your forms. They are:

- **Bound Controls:** Bound controls are bound or connected to an underlying field in a table or query. You use bound controls to display, enter, and update field values in your database. The Fields that you can add to a form using the Field List are all examples of bound controls.

- **Unbound Controls:** Unbound controls are not bound or connected to an underlying field in a table or query. You use unbound controls to display information. Labels, text boxes, and buttons can all be inserted on a form as unbound controls.

- **Calculated Controls:** Calculated controls are based on an expression and are used to calculate values in a form, such as arithmetic problems. Technically, calculated controls are unbound controls because they do not update any table Fields.

A control’s **Control Source property** determines what is displayed in a control:

- A bound control’s Control Source property contains the name of the underlying database field to which it is bound.

- An unbound control’s Control Source property does not contain the name of an underlying database field.

- A calculated control’s Control Source property contains an expression that calculates the values displayed in the control.

This lesson explains how you can change a control’s Control Source property.

1. Display the form in **Design View** or **Layout View** and make sure the **Property Sheet** is displayed.

2. Select the desired control.

   You can find the Control Source property on the Data tab on the Property Sheet.

3. Click the **Data** tab on the Property Sheet.

   Set the Control Source property to determine what is displayed in the control. You can bind the control to a field in the form’s underlying query or table by clicking the arrow button, or you can type text or an expression directly into the Control Source box.

4. Click the **Control Source** box and edit the source as desired.

---

**Exercise**

- **Exercise File:** Form.accdb
- **Exercise:** Delete the First Class label and text box. Add a check box control below the Smoker label. Bind the check box to the First Class database field using the Control Source box on the Data tab of the Property Sheet. Change the check box’s label so it reads “First Class”. View the form in **Form View** and try checking and unchecking the First Class box. Save and close the form.

---

![Figure 7-10: Adding a check box control to a form.](image1)

![Figure 7-11: Binding a control to an underlying database field.](image2)
Creating a Calculated Control

A calculated control is an unbound control that displays totals and other arithmetic computations on a form. You create calculated controls by entering an expression (or formula) to perform the calculation in the control’s Control Source property.

In forms, expressions start with the equal sign (=), which tells Access that you want to perform a calculation. After the equal sign, you must specify two more types of information: the values you want to calculate and the arithmetic operator(s) or function name(s) you want to use to calculate the values. Expressions can contain explicit values, such as the numbers “4” or “5” or can reference the values contained in database Fields. For example, the formula = [Cost] * [Commission] would multiply the values in the Cost and Commissions Fields. To enter Fields in an expression, type the field name in brackets ([Order Total]). If a field name exists in more than one table, you will need to enter the name of the table that contains the field in brackets ([Customer Tours]) followed by an exclamation mark (!) and then the field, such as [Order Total].

In this lesson we’ll look at how to create a calculated control.

1. Display the form in Design View or Layout View and make sure the Property Sheet is displayed.

2. Select the desired control.

3. Click the Data tab on the Property Sheet and click in the Control Source box.

4. Type the expression, using proper Access syntax.

   Other Ways to Enter an Expression:
   Click the button in the Control Source box and use the Expression Builder to Create the expression.

   Tips
   ✓ You can also use expressions to create calculated controls and Fields in queries and reports.
   ✓ If a database field name exists in more than one table, you will need to enter the name of the table that contains the field in brackets, followed by an exclamation mark (!). For example, = [tblTours]! [Cost] * 0.15.
Changing a Control's Default Value

You can enter a default value to specify a value that is automatically entered in a field when a new record is created. For example, if most of your clients are from Texas, you could set the default value for the State field to “TX.” When users add a record using a form, they can either accept the “TX” default value for the State field or enter their own value.

1. Display the form in Design View or Layout View and make sure the Property Sheet is displayed.

2. Select the desired control.
   For example, you could select the State text box to create a default value that enters the state.

3. Click the Data tab on the Property Sheet.

4. Click in the Default Value box and type the default value you want to appear for new records.

   Now when you add a new record to the form, the default value will appear automatically. You can always replace the default value with your own data if desired.

**Tips**

- Control properties in a form are inherited, or passed down, from the original properties in the underlying table or query. For example, if you set the Default Value property for a table’s State field to “TX,” the “TX” Default Value property will be passed on to a related State control on a form by default.

---

**Exercise**

- **Exercise File:** Form.accdb
- **Exercise:** Display the frmCustomers form in Design View. Enter the default value “MN” for the State text box. Change to Form View, add a new blank record, and notice that MN is already filled in. Save your changes.

---

**Figure 7-14:** Setting the Default Value property for a control.

**Figure 7-15:** The default value appears in the control when you add a new record with the form.
Creating a Subform

A subform is a form within a form. The primary form is called the main form, and the form within the form is called the subform. Subforms are especially useful when you want to show data from Tables or queries with a one-to-many relationship. For example, a Customer form might have a subform that displays each customer’s Orders.

The main form and subform are linked so that the subform displays only records that are related to the current record in the main form. For example, when the main form displays a particular customer, the subform displays only orders for that customer.

Let’s look at how to create a subform.

1. Open the form you want to use in Design View. Usually you will want to have the Control Wizard assist you when you add a subform.

2. On the Design tab in the Controls group, click the drop-box and select Use Control Wizards. Before you add a subform, make sure that you have enough room for it on the main form.

3. Resize the form if necessary. Now you’re ready to add the subform.

4. Click the Design tab on the Ribbon and click the drop-box in the Controls group. Find the Subform/Subreport button and select it. The mouse pointer changes to a +, indicating that you can click and drag the subform onto the main form.

5. In the form, click and drag where you want the subform to appear. The Subform Wizard appears and asks if you want to use an existing form for your subform or if you want to build a new form, using Tables or queries. In this lesson, we will have the Wizard build us a new form using Tables and queries to use as our subform.

6. Click Next. The next step of the Wizard appears. Here you have to select the table or query and Fields that you want to display in your subform.

Exercise

- **Exercise File**: Form.accdb
- **Exercise**: Display the frmEmployees form in Design View. Make sure the Control Wizards button has been pressed. Add a subform to display the tours that each employee has sold. Resize the form area to add about 3 inches of space below the current data. Add the subform in this new space (make it about 2 inches tall by 5 inches wide. In the Wizard, select Query: qryCustomerTours as the source for the subform and select the EmployeeID, Date, TourID, CustomerID, and Number of Tickets Fields to the Selected Fields list. Finish the Wizard. Save your changes and display the form in Form View.

Figure 7-16: Selecting the table or query and Fields that you want to include on your subform.
7. Click the Tables/Queries list arrow and select the table or query you want to use for the subform.

Now you need to select the Fields you want to appear in the subform. You must select the related field used to join the main form and subform. This related field must appear on both the main form (where it is called the parent field) and on the subform (where it is called the child field).

**Tip:** It’s very important that the underlying Tables or queries of the main form and subform have a related field and that the related field appears somewhere on both forms.

8. Select the Fields you want to appear in the subform and click Next.

The next step in the Wizard is to define the Fields that link the main form and the subform. The Subform Wizard is often smart enough to recognize the field and use it to link the two forms. If not, you will have to click the Define my own option and select the two related Fields.

9. If necessary, specify the parent and child Fields that link the main form and subform.

10. Click Next, then click Finish.

Access creates the subform and adds it to the main form.

11. Save your changes to the form.

Subforms Created with the Subform Wizard are usually a little rough around the edges and may require a little clean-up work.
Modifying and Working with Subforms

Subforms rarely come out the way you want them to the first time: They may be too small or too large and must be resized so that the main form and subform fit together nicely. Or, if you’re using an existing form as a subform, you may need to change the subform layout.

This lesson covers the basics of modifying and working with subforms.

Modify a subform

1. Click anywhere in the subform.
   To edit the subform’s structure or size, you need to be in Design View.

2. Edit the subform as needed.

   Tips

   ✓ The main form and subform each have their own set of navigation buttons that you can use to add and move between records.
   ✓ If you have set referential integrity between two or more related Fields in a subform’s underlying table or query, you will have to obey those referential integrity rules in order to add or edit a record in the subform. For example, you can’t enter a number in the TourID field unless that number exists in the qryCustomerTours query.

Display a subform’s properties

1. In Design View, double-click the subform’s Form Selector.
   The subform’s properties are displayed in the Property Sheet.

Exercise

- Exercise File: Form.accdb
- Exercise: Display the frmEmployees form that you modified in the previous lesson open in Form View. Practice clicking back and forth between the main and subforms. Then add a new record to the subform using the following information:

<table>
<thead>
<tr>
<th>EmployeeID</th>
<th>Date</th>
<th>TourID</th>
<th>CustomerID</th>
<th>Number of Tickets</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>9/2/07</td>
<td>China</td>
<td>Ali</td>
<td>2</td>
</tr>
</tbody>
</table>

Change to Design View and delete the subform’s label. Select the subform’s Form Selector and view its properties on the Property Sheet. Change the subform’s Default View to Continuous Forms. View the form in Form View and save your changes.

Figure 7-18: Modifying a subform in Design View.
Working with Forms Review

Quiz Questions

1. Once you create a form, you can use the buttons on the __________ bar to display or add records.
   A. Record Navigation
   B. Status
   C. Title
   D. Task

2. Which of the following is NOT a view for viewing forms?
   A. Form View
   B. Layout View
   C. Design View
   D. Table View

3. Layout View is most useful for making very detailed modifications to form structure. (True or False?)

4. Form controls are located in the ______ group on the Design tab on the Ribbon.
   A. Gridlines
   B. Controls
   C. Commands
   D. Form

5. If you move a control on a form, the Tab Order by which you advance from one field to the next when you press the Tab key is automatically updated. (True or False?)

6. Which of the following is NOT a tab on the Property Sheet?
   A. Format
   B. Properties
   C. Data
   D. All

7. The Caption property is found on the Data tab of the Property Sheet. (True or False?)

8. To display form properties, double-click the __________.
   A. Form Selector
   B. Property Selector
   C. Form button
   D. Form Header

9. Which of the following is NOT a Default View option?
   A. Single Form
   B. Continuous Forms
   C. Datasheet
   D. Subsheet

10. Which property determines what appears in a control?
    A. Data property
    B. Control Source property
11. A calculated control is bound to a field in a table or query. (True or False?)

12. A control's Default Value determines what appears in the control by default when you add a new record. (True or False?)

13. Which of the following sets of tables would benefit from a subform?
   A. A Customer table and the Customer Orders table.
   B. A Customer table and Products table.
   C. A Customer table by itself.
   D. A Customer table and Foreign Currency table.

14. The main form and sub form each have their own set of navigation buttons that you can use to add and move between records. (True or False?)
Quiz Answers

1. A. You can use the Record Navigation bar to display a certain record or add a new one.
2. D. Table View is not an available view for viewing forms.
3. False. Layout View is best for making simple modifications.
4. B. Form controls are found in the Controls group.
5. False. If you add or move a control on a form, you would have to change the form's tab order yourself. Access won’t do it for you.
6. B. Properties is not a tab on the Property Sheet.
7. False. Caption is found on the Format tab.
8. A. Double-click the Form Selector box in the upper-left corner of the form to view a form’s properties.
9. D. Subsheet is not a Default View option.
10. B. The Control Source property determines the information that is displayed in a control.
11. False. A calculated control is NOT bound to a field in a table or query.
12. True. A control’s Default Value determines what appears in the control by default when you add a new record.
13. A. Because subforms are great at displaying information from one-to-many relationships, a Customer table and the Customer Orders table would benefit from being displayed in a subform.
14. True. Main and sub forms have their own navigation buttons.
# Working with Reports

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a Report</td>
<td>170</td>
</tr>
<tr>
<td>Create a report with the Report button</td>
<td></td>
</tr>
<tr>
<td>Working in Layout View</td>
<td>171</td>
</tr>
<tr>
<td>Change report view</td>
<td>171</td>
</tr>
<tr>
<td>Understanding controls</td>
<td>171</td>
</tr>
<tr>
<td>Work with report layouts</td>
<td>171</td>
</tr>
<tr>
<td>Resize, move, and delete controls or</td>
<td>172</td>
</tr>
<tr>
<td>columns</td>
<td></td>
</tr>
<tr>
<td>Add a field</td>
<td>172</td>
</tr>
<tr>
<td>Adding a Logo</td>
<td>174</td>
</tr>
<tr>
<td>Working in Design View</td>
<td>175</td>
</tr>
<tr>
<td>Display a report in Design View</td>
<td>175</td>
</tr>
<tr>
<td>Controls</td>
<td></td>
</tr>
<tr>
<td>Adjusting Page Margins and Orientation</td>
<td>177</td>
</tr>
<tr>
<td>Adjust page margins</td>
<td>177</td>
</tr>
<tr>
<td>Adjust orientation</td>
<td>177</td>
</tr>
<tr>
<td>Adding Page Numbers and Dates</td>
<td>178</td>
</tr>
<tr>
<td>Add a page number</td>
<td>178</td>
</tr>
<tr>
<td>Add a date and time information</td>
<td>179</td>
</tr>
<tr>
<td>Grouping and Sorting</td>
<td>180</td>
</tr>
<tr>
<td>Group or sort on a field</td>
<td>180</td>
</tr>
<tr>
<td>Work with the Group, Sort, and Total pane</td>
<td></td>
</tr>
<tr>
<td>Summarize Data using Totals</td>
<td>182</td>
</tr>
<tr>
<td>Total a field</td>
<td>182</td>
</tr>
<tr>
<td>Understanding Report Sections</td>
<td>184</td>
</tr>
</tbody>
</table>

It’s easy to print a simple list of records in a table or query. But if you want your printed hard copies to look professional, you’ll need to create a report. Reports present information from Tables and queries in a format that looks great when printed.

Reports can also summarize and analyze the information in your database. For example, a report might tell you which of your employees have used the most sick days for the past year.

This chapter explains how to Create and work with reports.

**Using Exercise Files**

This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Creating a Report

There are two quick ways to create a report:

- **The Report Wizard** is a good choice if you want to create a report from more than one table, or if you want to influence the Design of the report while you create it.

- **The Report button** instantly creates a report based on the currently selected table or query.

We’ve covered the Report Wizard in another lesson, so we’ll look at the **Report button** here.

Create a report with the Report button

You can instantly create a report with the **Report button**.

1. Select the table or query you want to base the report on.
   
   You can select the table or query either in the Navigation pane or, if the table or query is already open, in the database window.

2. Click the **Create** tab on the Ribbon and click the **Report** button in the Reports group.

   A report is instantly created based on the active table or query, and appears in Layout View.

Other Ways to Create a Report:

You can also Create a blank report. Click the **Create** tab on the Ribbon and click either the **Blank Report** button (to Create and display the report in Layout View) or the **Report Design** button (to Create and display a blank report in Design View).

Exercise

- **Exercise File**: Report.accdb
- **Exercise**: Use the **Report button** to Create a report based on the **qryCustomers** query. Save the report as **“rptCustomers”**.
Working in Layout View

Much like with forms, you can modify reports in either Layout View (for simple changes) or Design View (for more complex changes). One advantage of Layout View is that it displays the report much as it will look when printed—unlike Design View, which displays all the messy, behind-the-scenes report structure. Layout View does still display field, row, column, header, footer, and page borders so you can easily work with the layout. In this lesson, we’ll look at some of the simple modifications you can make in Layout View.

Tips

✓ The modifications in this lesson can also be performed in Design View, but using Layout View is usually easier.

Change report view

1. Click the Home tab on the Ribbon and click the View button list arrow in the View group.
   Here you have view options such as Report View, Print Preview, Layout View, and Design View.

2. Select a view.

   Other Ways Change Report View:
   Click one of the view buttons on the Status bar.

Understanding controls

Just like with forms, any object that appears on a report is called a control. A text box, used to display record information (usually Fields from a table or query), or a column label are both examples of controls.

Work with report layouts

You can easily change the layout of the report using the commands on the Arrange tab.

1. In Layout View, click the Arrange tab on the Ribbon.
   The Table group contains some quick and easy commands for changing your layout:

   Tabular, Stacked: Click these buttons to change the way controls are arranged on your report—in a spreadsheet-like tabular format, or a vertically stacked Arrangement. Experiment to find the best layout for your report.

   The Rows & Columns group allows you to modify your Tables and databases by clicking the button relevant to the changes you wish to make.

Exercise

• Exercise File: Report.accdb
• Exercise: Change the rptCustomers report to Report View, then back to Layout View. In the Position group on the Arrange tab, change the Control Padding to None. Change to a Stacked layout, then undo that action. Delete the CustomerID, ZipCode, DOB, SSN, Smoker, and First Class columns. Delete the Date and Time Fields from the top of the report and the page number field from the bottom of the report. Add the DOB field back to the report as the last column. Manually resize each column to make the report one page wide (use the dotted page lines for guidance). Edit the “qryCustomer” title label so it reads “Customers”. Save.

Table 8-1: Report Views

<table>
<thead>
<tr>
<th>Report</th>
<th>Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Report View" /></td>
<td><img src="image2" alt="Layout View" /></td>
</tr>
<tr>
<td><img src="image3" alt="Design View" /></td>
<td><img src="image4" alt="Print Preview" /></td>
</tr>
</tbody>
</table>

Figure 8-2: The Arrange tab.
Insert Below, Insert Left/Right, Select Column, Select Row: Click these buttons to insert rows or columns where you need them to be.

The Merge / Split group gives you options to merge or split cells or controls.

Merge, Split Vertically, Split Horizontally: Use these buttons when you want to merge or split controls within a field.

The Move group gives you buttons that allow you to move individual controls up or down.

Move Up, Move Down: Click the appropriate button so that you can shift a control higher or lower.

In the Position group, you will see commands for changing the format of the Fields and the data within those Fields:

Control Margins, Control Padding: Click these buttons to change the location of data within Fields, and also the distance betweenFields.

Tip: If you decide you don’t like a change you’ve made to your report’s layout, you can always use the Undo feature to return to where you started.

Resize, move, and delete controls or columns

You can easily move and resize columns of data or individual controls such as labels or logos simply by clicking and dragging them with the mouse. You can also delete these items with the press of a key.

Tips

✓ In Layout View, data is grouped together in columns and rows by Access so that it can be easily modified together.

Resize: Click and drag the right or left border of a column or control to make it larger or smaller.

Move: Click and drag a column’s heading to a new location to move a column, or simply click and drag a control to a new location.

Delete: Select a column or control and press the <Delete> key.

Add a field

If you create a form with the Report button, the report will already contain all the Fields from the table or query on which you based the report. But if you’ve created your report with the Report Wizard, by using the Blank report option, or if you’ve deleted some Fields, you may want to add more Fields at some point. Here’s how:
1. Make sure the **Field List** pane is displayed.

   ✔ **Tip:** If you don’t see the Field List pane, click the **Design** tab under Report Layout Tools on the Ribbon and click the **Add Existing Fields** button in the Tools group.

2. Click and drag the field you want to add from the **Field List** onto the report.

   The field is added to the report wherever you placed it, and Access automatically moves the other Fields to accommodate it.

   ✔ **Tip:** To change a field label’s text, double-click on the label, then edit or Replace the text.

---

**Figure 8-4:** Adding a field to a report.
Adding a Logo

In this lesson, we’ll look at how you can easily add your logo to a report in Layout View.

**Tips**

- If you created your report using the Report button, a logo placeholder will already be inserted in the upper-left corner of the report. When you insert your own logo, it will replace it automatically.
- You can also add a logo in Design View.

1. Display the report in **Layout View**.

2. Click the **Design** tab under Report Layout Tools on the Ribbon and click the **Logo** button in the Header/Footer group.

   The Insert Picture dialog box appears.

3. Browse to the logo’s File and double-click the image you want.

   The logo is added to the report’s header.

**Tips**

- Once you’ve added the logo, you can move it or resize it like any other field or control.

---

**Exercise**

- **Exercise File**: Report.accdb, Logo.jpg
- **Exercise**: Add a logo to the **rptCustomers** report (insert the **Logo.jpg** File). Save.

---

**Figure 8-5**: The Header/Footer group on the Design tab.

**Figure 8-6**: Selecting a logo File in the Insert Picture dialog box.

**Figure 8-7**: A logo inserted into a report.
Working with Reports

Working in Design View

To make more complex report modifications, you’ll want to work with your reports in Design View. If you have already worked with forms in Design View, you should be in familiar territory—Design View is remarkably similar for both forms and reports.

Display a report in Design View

1. Right-click the report in the Navigation Pane and select **Design View**.

   The report opens in Design View.

   ❗ **Other Ways Display a Report in Design View:**
   
   If the report is already open in the database window, click the **Home** tab on the Ribbon, click the **View** button list arrow in the Views group, and select **Design View**.

Controls

1. Click the **Design** tab under Report Design Tools on the Ribbon.

   Control commands are found in the Controls group.

✅ **Tips**

✓ For more details about controls, see the lesson about adding controls to forms.

Table 7-2: Controls provides more information about controls.

<table>
<thead>
<tr>
<th>Table 8-2: Controls</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select</strong></td>
<td>Click this button and then click the control you want to select. To select multiple controls, click this button and hold down the &lt;Shift&gt; key as you click each control, or drag a rectangle around all controls you want to select.</td>
</tr>
<tr>
<td><strong>TextBox</strong></td>
<td>Creates a text box that displays information from a table and query. You can also use text boxes to simply enter text.</td>
</tr>
<tr>
<td><strong>Label</strong></td>
<td>Creates a static text label that is the same for every record, such as a heading. Most controls already have a text label attached.</td>
</tr>
<tr>
<td><strong>Button</strong></td>
<td>Creates a button that runs a macro or Visual Basic function.</td>
</tr>
<tr>
<td><strong>Tab Control</strong></td>
<td>Enables you to Create tabs (like the ones found in some dialog boxes) to include more than one page of controls on the report. This control is normally used in forms, not reports.</td>
</tr>
<tr>
<td><strong>Hyperlink</strong></td>
<td>Inserts a link to a Web page or File.</td>
</tr>
<tr>
<td><strong>Option Group</strong></td>
<td>Creates a box around a group of option buttons so that the user is only allowed to make one selection from the group box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><strong>Insert Page Break</strong></td>
<td>Inserts a page break.</td>
</tr>
<tr>
<td><strong>Combo Box</strong></td>
<td>Creates a drop-down box that lets the user enter text or select an item from a list of options. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><strong>Chart</strong></td>
<td>Inserts a Chart.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File**: Report.accdb
- **Exercise**: Display the **rptCustomers** report in **Design View** and familiarize yourself with the parts of the screen and the controls in the **Controls** group.

Figure 8-8: A report displayed in Design View.
### Table 8-2: Controls

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>Enables you to draw a line.</td>
</tr>
<tr>
<td>Toggle Button</td>
<td>Creates a toggle button that allows you to display and enter data from a Yes/No field. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>List Box</td>
<td>Creates a box that lets the user select an item from a list of options. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Enables you to draw a rectangle.</td>
</tr>
<tr>
<td>Check Box</td>
<td>Creates a box that is checked or unchecked. Use to enter data from a Yes/No field. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>Unbound Object Frame</td>
<td>Inserts an OLE object that is not bound to a field in the current database. Use an Unbound Object Frame to display information from an external source or program, such as a spreadsheet, graphic, or other File.</td>
</tr>
<tr>
<td>Attachment</td>
<td>Displays any attachments linked to the record.</td>
</tr>
<tr>
<td>Option Button</td>
<td>Creates an option button (or radio button) that allows the user to make a single selection from two or more choices. Option Buttons are normally used with the Option Group control. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>Subform/Subreport</td>
<td>Inserts another report within the main report. Use when you want to show data from a one-to-many relationship.</td>
</tr>
<tr>
<td>Bound Object Frame</td>
<td>Inserts an OLE object that is bound to a field in the database. Use Bound Object Frames to display pictures or other OLE information in the database.</td>
</tr>
<tr>
<td>Image</td>
<td>Displays a picture or graphic File that you specify.</td>
</tr>
</tbody>
</table>
Adjusting Page Margins and Orientation

You’re probably already aware that margins are the empty space between the text and the left, right, top, and bottom edges of a printed page. The default margins for a report are .25 inches at the top, bottom, left, and right. If you don’t already know how to adjust a page's margins, you will after this lesson. You will also learn how to change the page orientation.

Adjust page margins
There are many reasons to change a report’s margins: To make room for more data, to add some extra space if you’re binding a document, or to leave a blank space to write in notes.

1. Display the report in Layout or Design View.

2. Under Report Layout Tools on the Ribbon, click the Page Setup tab and click the Margins button in the Page Size group.

   Here you have a few choices for margin size: Normal, Wide, or Narrow (the default choice).

3. Select the option you want to use.

   Tip: If you want to fine-tune the margin size, click the Page Setup button in the Page Layout group, click the Print Options tab, and enter the exact top, bottom, left, and right margin sizes you want to use.

Adjust orientation

Everything you print uses one of two different types of paper orientations: portrait and landscape. In Portrait orientation (the default for Access reports), the paper is taller than it is wide—like a painting of a person’s portrait. In Landscape orientation, the paper is wider than it is tall—like a painting of a landscape.

1. Display the report in Layout or Design View.

2. Under Report Layout Tools on the Ribbon, click the Page Setup tab and click the Landscape or Portrait button in the Page Layout group.

   The page’s orientation changes.

Tips

✓ You can also change the size of the page from the default Letter size. Click the Size button in the Page Size group and select a size.
Adding Page Numbers and Dates

Reports that are several pages long often have information such as the page number or the date located at the top (header) or bottom (footer) of every page. In this lesson you will learn how to use the Page Number command and Date and Time command to add page numbers and/or the current date to your report.

Tips

✓ When you create a report based on a table or query using the Report button, Access automatically adds Fields for the date, time and page number to the report. If you use the Report Wizard, only the date and page number are included by default.

Add a page number

1. In Layout View, click the Design tab under Report Layout Tools on the Ribbon and click the Page Numbers button in the Header/Footer group.

The Page Numbers dialog box appears, giving you several choices for formatting the page numbers:

- **Page N**: Prints only the page number (for example, “Page 5.”)

- **Page N of M**: Prints the page number and the total number of pages (for example, “Page 5 of 15.”)

**Other Ways to Add a Page Number:**
You can add a page number or date the same way in Design View.

2. Select the option you want to use in the Format section.

Next you need to specify where on the page you want the page number to appear—at the top or bottom of the page—and how you want the page numbers aligned.

3. Select the option you want to use in the Position section, then click the Alignment list arrow and select an alignment option. Click OK.

The Page Numbers dialog box closes, and Access adds a text box with a page number expression.

Exercise

- **Exercise File**: Report.accdb
- **Exercise**: Display the rptCustomers report in Layout View. Add a page number in “Page N of M” format to the bottom of the page (center alignment). Add the date in “xx/xx/xxxx” format but don’t include the time. View the report in Print Preview to see the page number and date displayed. Save and close the rptCustomers report.

Figure 8-11: The Page Numbers and Date and Time buttons in the Header/Footer group.

Figure 8-12: The Page Numbers dialog box.
Add date and time information

1. In Layout View, click the **Design** tab under **Report Layout Tools** on the Ribbon and click the **Date and Time** button in the Header/Footer group.

   The Date and Time dialog box appears. You can specify to add the date, time, or both to your reports.

2. Check or uncheck the **Include Date** and **Include Time** check boxes as desired.

   Just like the Page Number dialog box, the Date and Time dialog box gives you several choices for how the date and/or time can be formatted.

3. Select desired formatting options, then click **OK**.

   The Date and Time dialog box closes and Access adds the date or time as you specified.

   ✔ **Tip:** Access may place the date, time, or page numbers on top of an existing control. If so, click and drag the text box to move the control to a new location on the report.
Grouping and Sorting

If you create a report using the Report Wizard, you specify which Fields you want to use to group and/or sort your report by. If you’re modifying an existing report or creating a report from scratch, you’ll need to use the methods presented in this lesson.

There are two ways to group and sort:

- **Right-click Fields in Layout View** and select an option from the contextual menu. This is the easier - and hence, preferred way - to group and sort.

- **Display the Group, Sort, and Total pane** in either Layout or Design View, and use the commands in the pane to make advanced adjustments to grouping and sorting.

**Group or sort on a field**

Organizing records into logical groups often makes them easier to read and understand. For example, you could group a sales report by the date field to quickly see how many sales occurred in a particular month.

1. In Layout View, right-click the field you want to group or sort on, and select **Group On** or a sort option from the contextual menu.

   A grouping level is added to the report and a group header is created—which you can see if you change to Design View.

   ✔ **Tip:** Sort options may include **Sort A to Z** or **Sort Largest to Smallest**, depending on the type of data you’re sorting.

**Work with the Group, Sort, and Total pane**

You can also group and sort your report data using the Group, Sort, and Total pane. Using the pane allows you to add multiple levels of grouping and sorts.

1. Display the report in **Design** or **Layout View**.

2. Click the **Design** tab on the Ribbon and click the **Group & Sort** button in the Grouping & Totals group.

   Access displays the Group, Sort and Total pane at the bottom of the screen. Here you’ll see any Fields that are currently being used for sorting or grouping your report.

---

**Exercise**

- **Exercise File:** Report.accdb
- **Exercise:** Display the rptAnnualSales report in **Layout View**. Group the report on the **TourName** field. Use the **Group, Sort, and Total** pane to add a sort level that sorts by date from oldest to newest. View the report in **Print Preview View**. Save.

**Figure 8-14:** A report grouped by the TourName field and sorted by date.
3. Click the Add a group or Add a sort button in the Group, Sort and Total pane and select a field for grouping records.

The records are grouped or sorted, and each level of sorting or grouping that you add contains several options. These options allow you to change the sort order, Create a group header or footer section, or add totals.

4. Select options you want to use by clicking on the option on the group or sort level.

✔ Tip: If you want to see even more options, click More Options on the desired level.

✔ Tip: You can set up to ten grouping and sorting levels in a report.
Summarize Data using Totals

A calculated control displays totals and other arithmetic computations on a form or report. In this lesson, we’ll look at how to add the Total feature to add calculated Fields to summarize information on a report.

With the Total feature you could, for example, total the number of phone calls each telemarketer at your company made and the number of phone calls made by all your telemarketers.

Table 8-3: Common Total Operations describes the operations you will use most often to total your reports.

Total a field

With the Total feature, Access can calculate a sum, average, or count for a field.

1. In Layout View, right-click the field you want to total, point to Total [field name] on the contextual menu, and select an operation.

A grand total appears at the end of the report, and if you have created any groups in the report, group totals are added after each group as well.

Tips

✓ The operations that are available will vary depending on the type of data in the field.
✓ You can modify the totals using options found on the Group, Sort, and Total pane.

Exercise

- **Exercise File:** Report.accdb
- **Exercise:** Display the rptAnnualSales report in Layout View and add totals to the Tickets and Total Fields using the Sum operation. View the report in Print Preview View to see the group and grand totals. Save.

Figure 8-15: Totaling the Tickets field using the contextual menu.

Figure 8-16: A report grouped by TourName and displaying totals.
### Table 8-3: Common Total Operations

<table>
<thead>
<tr>
<th>Sum</th>
<th>Totals all the values listed in a field.</th>
<th>Sum([InvoiceTotal])</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average</td>
<td>Calculates the average of all the values listed in a field.</td>
<td>Avg([InvoiceTotal])</td>
</tr>
<tr>
<td>Count Records</td>
<td>Counts the number of records.</td>
<td>Count(*)</td>
</tr>
<tr>
<td>Count Values</td>
<td>Counts how many values are listed in a field.</td>
<td>Count([InvoiceTotal])</td>
</tr>
<tr>
<td>Max</td>
<td>Finds and displays the largest value listed in a field.</td>
<td>Max([InvoiceTotal])</td>
</tr>
<tr>
<td>Min</td>
<td>Finds and displays the smallest value listed in a field.</td>
<td>Min([InvoiceTotal])</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>Finds and displays the amount of deviation from the average.</td>
<td>StDev([InvoiceTotal])</td>
</tr>
<tr>
<td>Variance</td>
<td>Finds and displays the variance of the data set.</td>
<td>Var([InvoiceTotal])</td>
</tr>
</tbody>
</table>
Understanding Report Sections

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report.

If you’ve worked with headers and footers in a word-processing program, you’re familiar with the section concept.

Table 8-4: Report Sections describes each of the sections, which are most easily seen when you view the report in Design View.

Tips

✔ To change the size of a section, click and drag its section line up or down.

Table 8-4: Report Sections

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Header</td>
<td>Contains text that appears at the top of the first page of a report, such as the name of the report.</td>
</tr>
<tr>
<td>Page Header</td>
<td>Contains text that appears at the top of each page of a report, such as the report’s column headings.</td>
</tr>
<tr>
<td>Group Header</td>
<td>Used to place text, such as a group name, at the beginning of each group of records.</td>
</tr>
<tr>
<td>Detail</td>
<td>Contains text and the actual Fields that are displayed for each record. This would be equivalent to the main body in a word-processing document.</td>
</tr>
<tr>
<td>Group Footer</td>
<td>Used to place text and numeric summaries, such as totals or averages, at the end of each group of records.</td>
</tr>
<tr>
<td>Page Footer</td>
<td>Contains text that appears at the bottom of each page of a report, such as page numbers.</td>
</tr>
<tr>
<td>Report Footer</td>
<td>Contains text that appears at the end of the last page of a report. Often also contains numeric summaries for the report, such as a grand total.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** Report.accdb
- **Exercise:** Display the `rptAnnualSales` report in **Design View** and study each of the report sections. Using the label control in the **Controls** group, add a label with the text “Detail” to the left side of the **Detail** section, then add a “Group Footer” label to the left side of the **TourName Footer** section. View the report in **Report View** and notice where the “Detail” and “Group Footer” labels appear.

Figure 8-17: Report sections
Working with Reports Review

Quiz Questions

1. Which of the following is not used to create a report?
   A. Report button
   B. Report Design button
   C. Report Wizard
   D. Report Add-in

2. You can resize report columns in Layout View. True or False?

3. You can only add one of Access’s three built-in logos to a report—you can’t add your own. (True or False?)

4. To display a report in Design View, right-click the report in the Navigation Pane and select Display Design. (True or False?)

5. In Layout View, the commands for adjusting page margins and orientation are found in the ________ group
   A. Page Setup
   B. Page Format
   C. Page Layout
   D. Adjust Page

6. You can place page numbers only at the top of a report page. (True or False?)

7. You can group and sort a report using the ________ pane.
   A. Group Report
   B. Group, Sort, and Total
   C. Group and Sort
   D. Summarize

8. The Total feature creates a calculated control for you. (True or False?)

9. Which of the following is NOT a report section?
   A. Report Header
   B. Report Title
   C. Detail
   D. Page Footer
Quiz Answers

1. D. Using the Report Add-in is not a way to create a report.
2. True. You can resize columns and controls in Layout View.
3. False. You can add your own logo to a report.
5. C. They’re found in the Page Layout group of commands.
6. False. You can place page numbers at either the top or bottom of a report page.
7. B. You can group and sort a report using the Group, Sort, and Total pane.
8. True. The Total feature creates a calculated control that summarizes the field you specify.
9. B. Report Title is not a section in a report.
This chapter guides you through the process of creating sharp-looking forms and reports that have colorful fonts, sharp-looking borders, and even controls with 3-D effects.

This chapter explains how to format your forms and reports to make them more visually attractive and easier to read. You will learn how to change the appearance, size, and color of fonts and how to align text inside a control. This chapter also describes how you can add pictures and graphics to your forms and reports.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
Formatting Fonts

You can emphasize text on a form or report by making the text darker and **heavier** (bold), **slanted** (italics), larger, or in a different **typeface** (or **font**). The Font group of commands makes it easy to apply character formatting.

**Tips**

- You can format fonts in either Layout or Design View.
- Font formatting commands can be accessed through the Text Formatting group on the Home tab or the Font group on the Format tab.

### Change font size

Font sizes are measured in points (**pt**.), which are 1/72 of an inch. The larger the number of points, the larger the font.

1. Click the control that contains the text you want to format.

2. On the Ribbon under Report Layout Tools, click the **Format** tab. Click the **Font Size** list arrow in the Font group, and select the desired font size.

   The font size changes.

   **Tip:** When you change a control’s font size, you will often need to resize the control so that it can properly display its contents.

### Change font type

1. Click the control that contains the text you want to format.

2. On the Ribbon under Report Layout Tools, click the **Format** tab. Click the **Font** list arrow in the Font group, and select the desired font.

   The font type changes.

### Format text with bold, italics, or underlining

1. Click the control that contains the text you want to format.

2. Click the **Format** tab on the Ribbon under Report Layout Tools and click the **Bold**, **Italics**, or **Underline** button in the Font group.

   The text is formatted as specified.

---

**Exercise**

- **Exercise File:** Formatting.accdb
- **Exercise:** Display the rptTourSales report in **Layout View**. Tip: Close the **Property Sheet** pane if it’s in your way. Change the “Tour Sales” title label to 22 **pt Arial** font. **Bold** each of the column headings (**TourName**, **Date**, **Tickets**, **Cost**). **Save**.

---

**Figure 9-1:** Font formatting commands in the Font group.

**Figure 9-2:** Changing font size in Layout View.
Formatting Forms and Reports

Tips

✓ The Format Painter allows you to copy the formatting attributes from one control and then apply them to another. Click the control with the formatting you want to copy, click the Format Painter button in the Font group, then click a control to apply the formatting. Click the Format Painter button twice to apply formatting more than once.
Changing Text Alignment

This lesson explains how to align a control’s text to the left, center, or right. Alignment only affects what’s inside of a control: If you apply center formatting to a text box, Access will center the text inside the text box—it won’t center the text box control on the form or report.

Tips

✓ You can change text alignment in either Layout or Design View.

✓ Text alignment commands can be accessed through the Text Formatting group on the Home tab, or the Font group on the Format tab under Report Layout Tools/Form Layout Tools.

1. Click the control that contains the text you want to align.

2. Click the Format tab on the Ribbon under Report Layout Tools and click the Align Text Left, Center, or Align Text Right button in the Font group.

   The text is aligned as specified.

Tips

✓ Besides aligning text within a control, you can also align controls themselves within a form or report. Select the controls you want to align and use the commands in the Sizing & Ordering group on the Arrange tab.

Exercise

- **Exercise File:** Formatting.accdb
- **Exercise:** Display the rptTourSales report in **Layout View**. Apply center text formatting to the “Date” and “Cost” column labels. Save.

![Exercise](image)

Figure 9-3: Examples of text alignment.

![Exercise](image)

Figure 9-4: Applying center formatting.
Changing Colors

In this day of color printers and high-resolution monitors, choosing an appropriate color for your report or form is an important formatting decision. If used tastefully, colors can make your forms and reports look more visually attractive. You can add color to lines, text, or even the background of your headers and footers.

In this lesson, you will learn how to apply color to your reports and forms.

**Tips**

✓ You can change colors in either Layout or Design View.

✓ Color formatting commands can be accessed through the Text Formatting group on the Home tab, or the Font group on the Format tab under Report Layout Tools/Form Layout Tools.

1. Click the control or area (like a Header) you want to color.

2. Click the Format tab on the Ribbon under Form Layout Tools, click the Font Color button list arrow you want to use in the Font group, and select a color.

   The color is applied. It can be a little confusing to figure out which color button to use at first, so you can refer to the table below until you get the hang of it.

   **Other Ways to Change Colors:**
   In Design View, right-click a field or area (such as a header area) of a form or report, point to Fill/Back Color or Font/Fore Color and select a color.

<table>
<thead>
<tr>
<th>Table 9-1: Color Commands</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Font Color</strong></td>
</tr>
<tr>
<td><strong>Fill/Back Color</strong></td>
</tr>
<tr>
<td><strong>Alternate Fill/Back Color</strong></td>
</tr>
</tbody>
</table>

**Exercise**

- **Exercise File:** Formatting.accdb
- **Exercise:** Display the frmCustomers form in Layout View. Change the Font color of the “Customers” title label to the color called “Orange Accent 2”, found under Access Theme Colors. Change the Fill/Back color of the form detail area to the color called “Gold Accent 2”. Save.

**Figure 9-5:** Selecting a color from the Font Color list.

**Figure 9-6:** Font color and back color formatting applied.
Using Conditional Formatting

Conditional Formatting allows you to set a condition for a field, and then specify formatting based on that condition. For example, you could tell Access to format a field’s text with red coloring if the field value is less than 0, or black if it’s greater than or equal to 0.

Tips

✓ You can apply conditional formatting in either Layout or Design View.

1. Click the field you want to format.
   You need to select a field that’s bound to an underlying value or text. For example, you can’t use conditional formatting on a label that contains text that has simply been typed in.

2. In Layout View, click the Format tab under Form Layout Tools on the Ribbon and click the Conditional Formatting button in the Control Formatting group.
   The Conditional Formatting Rules Manager dialog box appears. Here all the applied Conditional Formatting rules are displayed.

3. Click New Rule to enter in a new conditional formatting rule.

4. In the Select a rule type, choose whether the conditional formatting is based on the value of the field or the value in relation to the other records.

5. If you select Check values in the current record or use an expression, enter the conditions in the Format only cells where the Fields.
   Also select the formats that need to be applied to values that meet the conditions using the buttons to the right of the Preview field.
   For example, you could select “Field Value Is”, “less than”, enter “0”, and then select red formatting to format any value less than 0 with red text.

6. If you select Compare to other records, select the Type and Value in the Data Bar format settings.
   You can also select an alternative color from the Bar Color list arrow.

7. Click OK.

Exercise

Exercise File: Formatting.accdb
Exercise: Display the frmCustomers form in Layout View. Apply conditional formatting to the First Class field so that if the value is equal to 0, the font color is red, otherwise it’s black. View the form in Form View. Change Patricia Ventosa’s First Class status to –1 and notice the formatting change. Change it back to 0. Save.
Adding Pictures, Lines and Gridlines

Pictures and lines can make your reports and forms more professional looking. You can insert graphics and pictures created with graphics programs, scanned pictures, or graphics from a clip-art library. This lesson explains how to insert graphics and lines.

Insert a graphic

1. In Design View, click the Design tab under Form Design Tools on the Ribbon and click the Image icon in the Controls group.
   The pointer changes.
2. Click and drag on the form or report where you want to place the graphic.
   The Insert Picture dialog box appears.
3. Browse to and select the graphic File you want to use and click OK.
   The graphic is inserted and can be modified like any other control.

Add gridlines

Forms and reports with lots of information can sometimes be difficult to read. You can quickly add vertical and/or horizontal gridlines to make them more organized.

Tip: You can add gridlines to a form or report in either Layout or Design View.

1. Select the field(s) to which you want to add gridlines.
   Rows of records or heading rows often look good with gridlines.
2. In Layout View, click the Arrange tab under Form Layout Tools on the Ribbon and click the Gridlines button in the Table group.
   You have several gridline options: Both, Horizontal, Vertical, Cross Hatch, Top, Bottom, None.
3. Select the gridline option you want to use.
   Gridlines are added around the field(s).

Tip: You can change the thickness, type, and color of gridlines using the buttons in the Gridlines group.

Exercise

- Exercise File: Formatting.accdb
- Exercise: Display the frmCustomers form in Design View. Insert the Plane graphic from your practice folder next to the Customers label in the Form Header. Draw a horizontal line across the entire form at the top of the Detail area. Change to Layout View. Add horizontal gridlines, then undo the action. Save.

Figure 9-9: Adding a graphic to a form.

Figure 9-10: The Insert Picture dialog box.
**Draw a line**

Although gridlines are usually more useful and easier to use, you can also manually draw lines anywhere you want them in forms and reports.

1. In Design View, click the **Design** tab under Form Design Tools on the Ribbon and click the **Line** button in the Controls group.
   
   The pointer changes.

2. Click and drag on the form or report where you want to place the line.
   
   The line is added.

   **Tip:** You can change a line’s thickness, type, and color using the buttons in the controls group.

![Figure 9-11: A form with a line and a graphic.](image)
Working with Number Formatting

You can quickly change the formatting of values in forms and reports to display dollar signs, percent signs, or to change the number of decimal places.

1. In Layout View, click the field you want to format in the Property Sheet.

2. Click the Format tab under Report Layout Tools on the Ribbon and click one of the buttons in the Number group.

   The formatting is applied.

   You can choose from the following formatting buttons:

   **Apply Currency Format:** Formats the value with a dollar sign and marks the thousands place with a comma.

   **Apply Percent Format:** Displays the value as a percentage with a percent symbol.

   **Apply Comma Number Format:** Similar to Currency format, but without the dollar sign.

   **Increase Decimals:** Increases the number of decimal places that are displayed.

   **Decrease Decimals:** Decreases the number of decimal places.

**Other Ways to Apply Number Formatting:**

Click the Format list arrow in the Number group and select a number format.

---

**Exercise**

- **Exercise File:** Formatting.accdb
- **Exercise:** Display the rptTourSales report in Layout View. Select the Cost field and apply the Comma number format, then decrease the decimal places by 2. Save.

![Figure 9-12: Number group.](image)

<table>
<thead>
<tr>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>$2,950</td>
</tr>
<tr>
<td>$3,500</td>
</tr>
<tr>
<td>$3,500</td>
</tr>
<tr>
<td>$7,000</td>
</tr>
</tbody>
</table>

**Figure 9-13:**

Values formatted in Comma format with no decimal places.
Using Themes

Themes are built-in collections of formats such as font sizes, colors, and alignments you can quickly apply to a form or report. This Replaces the AutoFormat feature in previous versions of Access.

Themes are a great feature if you want your forms and reports to look sharp and professional but don’t have the time to format them yourself.

1. In Layout View, click the Design tab under Report Layout Tools on the Ribbon, click the Themes button in the Themes group, and select the Theme you want to use.

The Theme is applied to the form or report.

Exercise

- **Exercise File:** Formatting.accdb
- **Exercise:** In Layout View, apply the Slice Theme to the frmCustomers form. Save.

Figure 9-14: A form with Slice Theme applied.

Figure 9-15: Selecting a Theme.
Formatting Forms and Reports

Review

Quiz Questions

1. Fonts are measured in points. The larger the number of points, the smaller the size of the font. (True or False?)

2. Which of the following is NOT a type of text alignment found in Access forms and reports?
   A. Justified
   B. Center
   C. Left
   D. Right

3. You can change colors in either Layout or Design View. (True or False?)

4. Which of the following is not a conditional formatting option?
   A. Field Value Is
   B. Calculation Is
   C. Expression Is
   D. Field Has Focus

5. With gridlines, you can quickly add vertical and/or horizontal lines to make forms or reports easier to read. (True or False?)

6. Which of the following is not a number format button in the Formatting group?
   A. Currency
   B. Percent
   C. Comma
   D. Justified

7. Applying a theme automatically applies formatting options as you type. (True or False?)
Quiz Answers

1. False. It’s true that fonts are measured in points, but the larger the number of points, the larger the size of the font.

2. A. Justified is not a type of text alignment in Access forms and reports.

3. True. You can change colors in either view.

4. B. CalculationIs is not a conditional formatting option.

5. True. Gridlines allow you to quickly add lines to organize forms and reports.

6. D. Justified is not a number format button in the Formatting group.

7. False. Themes allow you quickly to format a form or report using a set of predefined formatting options.
## Additional Topics

### Importing Information .............................................. 200
- Import Access objects ........................................... 200
- Import Excel data .................................................. 201

### Exporting Information ............................................. 202

### Linking Information from an External Source ......................... 204
- Link to another Access database .................. 204
- Link to Excel data ................................................. 205

### Using Hyperlink Fields ........................................... 206

### Displaying Database Object Dependencies ...... 208

### Setting a Password in Access ................................... 209
- Set a password ................................................... 209
- Remove a password .............................................. 209

### Compacting and Repairing a Database .............. 211
- Manually Compact and Repair .................... 211
- Automatically Compact and Repair ............ 211

With Microsoft Access, you can easily share information between different databases and even different programs. In this chapter, you’ll learn how to import and export data from external sources, and you’ll learn the difference between importing and linking to outside data.

You’ll also learn how to use Access to collect data from e-mails, how to repair a database, how to set a password to protect your data, and how to create a Switchboard to make navigating a database easier.

### Using Exercise Files

This chapter suggests exercises to practice the topic of each lesson. The exercises in the chapter build upon one another, meaning the exercises in a chapter should be performed in succession from the first lesson to the last.
You can import information into a database from other File formats, such as Excel, or from other Microsoft Access databases. You can quickly and easily import Tables, forms, reports, queries, macros, and modules from one Access database into another Access database. This saves a lot of time: Instead of creating a new object (such as a form) from scratch, you can import an object from another database and then modify it as needed.

**Import Access objects**

1. Click the **External Data** tab on the Ribbon and click the **Access** button in the Import & Link group.

   The Get External Data dialog box appears. Here you need to specify the Microsoft Access database that contains the object(s) you want to import into the current database.

2. Browse to the appropriate drive and/or folder and double-click the database that contains the object(s) you want to import. Click **OK**.

   The Import Objects dialog box appears. Here you need to choose the type(s) of object(s) you want to import.

3. Click the tab that corresponds to the type of database object you want to import.

   You can import more than one database object at a time—simply click the appropriate object tab(s) and select the database objects you want to select.

4. Click **OK**.

   Access imports the selected objects into the current database.

5. Click **Close**.

   **Tip:** When you finish the Wizard, Access will ask if you want to save the import steps so you can repeat them in the future. Select the **Save import steps** option and click the **Save Import** button. To access the saved steps in the future, click the **Saved Imports** button in the Import & Link group.

   **Other Ways to Import Database Objects:**

   Open the database containing the object you want to import, copy the object, then paste the object in the current database. Or, right-click a table object in the Navigation Pane of the current database, point to **Import**, and select the type of data source you want to use.

---

**Exercise**

- **Exercise File:** Advanced.accdb, Promotions.accdb, America Expenses.xlsx, Europe Expenses.txt
- **Exercise:** Import the **tblPromotions** table from the Promotions database into the Advanced database (don’t save the import steps for any imports in this lesson). Import the data from the America Expenses Excel worksheet into a new table called “America Expenses” in the Advanced database. Import the data from the Europe Expenses text document into a new table called “Europe Expenses” in the Advanced database (be sure to select the **First Row Contains Field Names** check box in the Import Text Wizard).
Import Excel data

1. Click the **External Data** tab on the Ribbon and click the **Excel** button in the Import & Link group.

   The Get External Data dialog box appears. Here you need to specify the Microsoft Excel File that contains the data you want to import into the current database.

2. Browse to the appropriate drive and/or folder and double-click the Excel File that contains the data you want to import.

   Now you need to choose from a couple options:
   - Import the source data into a new table in the current database. Or…
   - Append a copy of the records to the table: [Table name].
   - Link to the data source by creating a linked table.

3. Select an option for how you want to store the data in the current database and click **OK**.

   The Import Spreadsheet Wizard dialog box appears.

4. Follow the onscreen instructions to finish importing the Excel data.

   ✓ **Tip:** When you finish the Wizard, Access will ask if you want to save the import steps so you can repeat them in the future. Select the **Save import steps** option and click the **Save Import** button. To access the saved steps in the future, click the **Saved Imports** button in the Import & Link group.

   ✓ **Tips**
   - You can also import data from sources such as SharePoint Lists, text Files, XML Files, or ODBC databases such as SQL Server. Just click the desired button in the Import group.

   ![Figure 10-4: The Import Spreadsheet Wizard.](image)

   ![Figure 10-5: Imported Tables.](image)
Exporting Information

When you export an Access database object, you can save its information in a different format so that it can be understood and opened by different programs. For example, you might export an Access table to an Excel worksheet.

1. Select the database object you want to export in the Navigation Pane or open a database table and select only the specific records you want to export.

   For example, you could export an entire table of customers or only the records for a few select customers.

   Next you need to select where you want to export the data: Choose from Excel, SharePoint List, PDF or XPS, Word, Text File, or more formats—such as another Access database.

2. Click the External Data tab on the Ribbon and in the Export group click the button for the type of File to which you want to export.

   The Export dialog box wizard appears. By default, Access will create a new File—named the same as the object you’re exporting—to hold the exported data.

3. Browse to the appropriate drive and/or folder where you want the new exported File to be saved.

   Tip: If desired, you can also edit the name of the new File by changing it at the end of the File path found in the File name box.

   Now you need to specify export options:
   - Export data with formatting and layout.
   - Open the destination File after the export operation is complete.
   - Export only the selected records.

4. Select desired export options and click OK.

   Access copies the data to the new location, but doesn’t delete it from the old database.

   Tip: When you finish exporting, Access will ask if you want to save the steps so you can repeat them in the future. Select the Save export steps option and click the Save Export button. To access the saved steps in the future, click the Saved Exports button in the Export group.

Exercise

Exercise File: Advanced. accdb

Exercise: Export the tblCustomers table to a new Excel workbook. Export data with formatting and layout and choose to open the destination File after the export operation is complete. Don’t save the export steps.

Figure 10-6: The Export group.

Figure 10-7: The Export dialog box.

Figure 10-8: Access table data exported to Excel.
5. Click **Close**.

**Other Ways to Export Data:**
In the Navigation Pane, right-click the database object you want to export, point to **Export**, and select the type of File to which you want to export.
Linking Information from an External Source

Another way that you can access information from an outside source is by creating a linked table. Linking data may sound a lot like importing, but there are some very important differences between the two:

- **Imported:** When you import data, you copy data from an External Data source and place it in a new table in your database.

- **Linked:** When you link to data, the data stays in its original location. If you link to another database, changes made in either Access or in the other database will flow back and forth. But if you link to an Excel source, changes made in Excel flow to Access, but not vice versa.

**Tips**

- Many databases use a front-end database File, which contains forms, reports, and queries. Front-end database Files are linked to a back-end database File, which contains the actual Tables. Such Designs work great when you want several users on several front-end databases to be able to access the same information in a single back-end database.

### Link to another Access database

1. Click the **External Data** tab on the Ribbon and click the **Access** button in the Import & Link group.

   The Get External Data dialog box appears. Here you need to specify the Microsoft Access database that contains the object(s) you want to import into the current database.

2. Browse to the appropriate drive and/or folder and double-click the database that contains the object(s) you want to import.

3. Select the **Link to the data source by creating a linked table** option. Click OK.

   The Link Tables dialog box appears. Here you need to choose the Tables to which you want to link.

4. Select the Tables you want to link to and click OK.

   The linked table appears in the Navigation Pane with an arrow icon, indicating that it is linked.

**Tip:** You can link to more than one table at a time—simply select all the Tables you want to select.
Additional Topics

**Link to Excel data**

You can also link to non-Access data sources, such as an Excel worksheet.

1. Click the **External Data** tab on the Ribbon and click the **Excel** button in the Import & Link group.
   
The Get External Data dialog box appears. Here you need to specify the Microsoft Excel File that contains the data you want to import into the current database.

2. Browse to the appropriate drive and/or folder and double-click the Excel File that contains the data you want to link.
   
   Now you need to create a linked table.

3. Select the **Link to the data source by creating a linked table** option and click **OK**.
   
The Link Spreadsheet Wizard dialog box appears.

4. Follow the onscreen instructions to finish linking to the Excel data.
   
The Excel data appears in Access as a linked table in the Navigation Pane.
Using Hyperlink Fields

In this lesson you will learn how to use hyperlinks in Microsoft Access. A hyperlink can point to any File on your computer, the network, or even a Web page on the Internet. Whenever you click on a hyperlink, you jump to the hyperlink’s destination (if it’s available). A hyperlink is usually indicated by colored and underlined text.

In this lesson you will learn how to use hyperlink Fields in Tables to Create links that point to Files on your network or the Internet.

Create a hyperlink

1. Display the table to which you want to add the hyperlink in Design View.

   First you need to create a column to hold the hyperlinks.

2. Click the first blank Field Name row and enter a name such as Link.

3. Click the Data Type list arrow and select Hyperlink. Return to Datasheet View.

   The hyperlink field is created. Now you can set up hyperlinks for certain records as desired.

4. Right-click in the Link field in the record for which you want to create a hyperlink, point to Hyperlink, and select Edit Hyperlink.

   The Insert Hyperlink dialog box appears. This is where you will specify the name and location of the File or Web page you want to add as a hyperlink.

5. Browse to a File on your computer or network, or enter a Web address in the Address box.

   The name of the File or Web site appears in the Text to display box. This is the text that will appear in the field on your table, and which you will click to activate the hyperlink.

6. Edit the text in the “Text to display box”, if desired, then click OK.

   The dialog box closes and you return to the datasheet, where hyperlink text now appears in the field.

Other Ways to Insert a Hyperlink:

Type in a full email address or web address into the field with the Hyperlink data type.

---

**Exercise**

- **Exercise File**: Advanced.accdb
- **Exercise**: Create a hyperlink to the **Canada Memo** document: In the tblTours table, add a Link column with the **Hyperlink** data type. Link the **Western Canada** record to the **Canada Memo.docx** File. Use the link to open the **Canada Memo** document.
Use a hyperlink

Once you’ve created a hyperlink, you simply click the hyperlink text in the field to go to the linked File or Web site.

1. Click the desired hyperlink text in the table field.
   The hyperlink opens the destination File or Web site.
   ✓ Tip: Depending on your computer’s security settings, you may have to click Yes to view it.

Edit a hyperlink

You can easily change either the hyperlink text that appears in the table or the hyperlink’s destination.

1. Right-click the hyperlink text, point to Hyperlink, and select Edit Hyperlink.
   The Edit Hyperlink dialog box appears, allowing you to make changes to the hyperlink.

✓ Tips

✓ To remove a hyperlink, right-click the linked text in the field, point to Hyperlink, and select Remove Hyperlink.

✓ Similar to hyperlink Fields, you can also Create OLE Object Fields. These Fields allow you to store Files Created in other programs—such as graphics, Excel worksheets, or Word documents. To Create an OLE Object field in a table, select the OLE Object field type instead of Hyperlink in Design View. The rest of the process is very similar to inserting a hyperlink.
Displaying Database Object Dependencies

Databases can often be complicated and interconnected. For example, a form might be based on a query, which in turn is based on a table. So, how do you keep track of all these interconnected database objects? By viewing object dependencies.

That way, before you delete or rename a query, you can view every database object—every query, form, and report—that is dependent on that query. You can also do the reverse and view every database object that the query requires in order to function.

Here’s how to view object dependencies.

1. Open the database in which you want to view dependencies.
2. Click a database object in the Navigation Pane.
3. Click the Database Tools tab on the Ribbon and click the Object Dependencies button in the Relationships group.

The Object Dependencies pane appears.

**Tip:** You may need to click OK to update dependency information or to turn on the Track name AutoCorrect info option before the pane will appear.

You have a couple options for how to view objects in the pane:

- **Objects that depend on me:** Select this option to view objects that use the selected object.
- **Objects that I depend on:** Select this option to view objects that the selected object uses.

4. Click the expand icon next to an object in the pane to see that object’s dependencies.

**Exercise**

- **Exercise File:** Advanced.accdb
- **Exercise:** Select the tblCustomers table and display the Object Dependencies pane. Expand the table relationships in the pane, then select the “Objects that I depend on” option and expand the relationships again.

**Figure 10-14:** The Relationships group.

**Figure 10-15:** The Object Dependencies pane.
Setting a Password in Access

You can encrypt a database using a password to keep unauthorized users from opening the database.

Set a password

To encrypt a database, you first need to open it in Exclusive mode.

1. Start the Access program.
   The Getting Started with Microsoft Office Access screen appears.

2. Click the File tab and select Open. Click Computer and then click Browse.

3. The Open menu appears. Browse to and select the Access File you want to open. Click the Open drop-down list arrow and select Open Exclusive.
   The database opens in exclusive mode.

4. Click the File tab on the Ribbon and click the Info group. Click the Encrypt with Password button.
   The Set Database Password dialog box appears.

5. Type a password in the Password box, enter it again in the Verify box, and click OK.
   The password is set. In the future, whenever anyone tries to open the database, they will first be prompted to enter the password.

   Trap: Make sure you remember the password—Microsoft can’t help you if you forget.

Remove a password

To remove a password, you once again need to open the database in Exclusive mode.

1. Start the Access program.
   The Getting Started with Microsoft Office Access screen appears.

2. Click the File tab and select Open.

3. The Open menu appears. Browse to and select the Access File you want to open. Click the Open drop-down list arrow and select Open Exclusive.
   The database opens in exclusive mode.
4. Click the **File** tab on the Ribbon and click the **Decrypt Database** button in the Info group. The Unset Database Password dialog box appears.

5. Type the password in the **Password box** and click **OK**. The password is removed from the database.
Compacting and Repairing a Database

Cars require maintenance to keep running at peak performance, and databases are no different. Your Access databases require some routine maintenance to prevent and/or correct problems and to keep them running at top performance. This lesson covers the two Access utilities:

- **Compact Database**: When you delete a database object or record, it leaves behind an empty hole that the object previously occupied. This isn’t a big deal unless, over time, you have deleted lots of database objects and records. Compacting a database rearranges how the database is stored and reduces its file size.

- **Repair Database**: Over time, normal wear and tear causes errors to appear in your database, thus affecting its performance. Usually these errors are very minor and can easily be fixed by repairing the database.

If you have been busy adding, editing, and deleting records for a while or if your database seems buggy, sluggish, or is generating error messages, it would be a good idea to run the Compact and Repair Database command.

**Tips**

- Before using the Compact and Repair Database command, it’s a good idea to back up your database. To do this, click the File tab, click Save As, click Save Database As and select Back Up Database under Advanced. Click Save As.

**Manually Compact and Repair**

1. Open the database you want to compact and repair.

2. Click the Database Tools tab and select Compact and Repair Database in the Tools group.

   Access compacts the database and repairs any errors it finds.

**Automatically Compact and Repair**

When you set up Access to automatically compact and repair a database, only the database that is currently open is affected. To set up others, you need to set up each database individually.
1. Open the database you want to set up to compact and repair automatically.

2. Click the **File** tab and select **Options**.
   The Access Options dialog box appears.

3. Click **Current Database**, then select the **Compact on Close** option in the Application Options area.
   Now Access will automatically compact and repair the database each time you close the database.

Figure 10-20: Setting up a database to automatically run the compact function when closing the database.
Additional Topics Review

Quiz Questions

1. You can import data into Access from which of the following sources?
   A. Excel
   B. Another Access database
   C. Text file
   D. All of these.

2. To export from Access, use the commands found in the ______ group on the Ribbon.
   A. Import
   B. External
   C. Export
   D. Send

3. When you create a link to a table in an external database, Access imports the table into the current database. (True or False?)

4. A hyperlink can point to...
   A. A file on your computer.
   B. A file on a network.
   C. A Web page on the Internet.
   D. All of these.

5. The Object Dependencies command is found in the ______ group.
   A. Objects
   B. Panes
   C. Show/Hide
   D. Relationships

6. To set a password, you first need to open the database in ________ mode.
   A. Exclusive
   B. Password
   C. Sharing
   D. Read-Only

7. When you set up Access to automatically compact and repair, that setting applies to all Access databases. (True or False?)
Quiz Answers

1. D. You can import data into Access from any of these files.
2. C. Use the commands in the Export group to export data from Access.
3. False. When you link to a table, the data stays in its original location.
4. D. Hyperlinks can point to any of these items.
5. D. The Object Dependencies command is found in the Relationships group.
6. A. Open a database in Exclusive mode to set a password.
7. False. You need to set up the automatic feature individually for each database.